Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: network problem

  1. #1

    Default network problem

    Hi all!

    Newbie at linux here! and poor english too...

    Ok, i am on SUSE 10.3 abd encounter network problem:
    sometimes i am able to use my network and internet (all eth interfaces, no DSL modems). but usually and suddenly the network fall down. often after a reboot, but during random connection attempts too (example, when i try Yahoo! France, it worked 2 seconds before, but it could simply crash the network).
    in these situation, i am able to ping my own interface, but neither the gateway, nor another computer on the LAN.

    using yast2, i try ifup mode and networkmanager (that i don'even understand), but it works and don't work randomly! same with "ifconfig eth0 up | down"

    on windows, i have no problem with the netword card!

    could someone help me to fix this please?


    regards!

  2. #2

    Unhappy Re: network problem

    hey,

    i really need help to diagnostic my network problem. could someone manage me please?

  3. #3
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: network problem

    Hi there & welcome to the forum!

    First thing to do when it happens again would be to check your network settings. On your next issue open a terminal console and do the following;

    ' su - ' and enter root's password

    'ifconfig eht0 ' this will give you information on current ip address end link error status - I'm assuming eht0 is the network card you always use.

    ' route ' this will display your main gateway and should be pointing to your router, try pinging the router... are you getting a reply?

    ' cat /etc/resolv.conf ' this prints the entries of your dns resolving.. it should list valid dns server entries, if there is nothing in it there is a first issue.

    That should give you a good start...

    Also important: Which version of openSUSE are you using? And what hardware do you have (mainly network card).
    Have a lot of fun!

  4. #4

    Default Re: network problem

    Hello, and thank you for the response!

    Open SUSE version is 10.3

    linux:/ # ifconfig eth0
    eth0 Link encap:Ethernet HWaddr 00:1E:0B:6F:08:C4
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:16 Memory:f8000000-f8012100


    ----------------------------------------------------------------------------------

    linux:/ # route
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    loopback * 255.0.0.0 U 0 0 0 lo
    linux:/ #

    ----------------------------------------------------------------------------------


    linux:/ # cat /etc/resolv.conf
    ### BEGIN INFO
    #
    #
    ### END INFO
    #
    nameserver 212.217.0.1
    search site
    linux:/ #

    ----------------------------------------------------------------------------------


    I don't know how to verify the driver!

    I intend to use these settings:

    eth0
    ip = 192.168.0.X
    mask = 255.255.255.0
    pass = 192.168.0.1

    dns = 212.217.0.1

    thnak you for your help!!

  5. #5

    Default Re: network problem

    someone, mayday!!

  6. #6
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: network problem

    Quote Originally Posted by revealmap View Post
    linux:/ # ifconfig eth0
    eth0 Link encap:Ethernet HWaddr 00:1E:0B:6F:08:C4
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    ...
    This bit shows your interface is up but it has no ip address (else it would have been mentioned there)

    The rest also shows your pc has no network configuration (default gateway is missing in the route table).

    Your driver seems fine and if it's a static ip configuration you want to make go into YaST > Network Devices.

    There you can;
    1) In the TAB Overview : Edit your network card settings and give it the static IP - lets say 192.168.0.20 (I understand you don't have a dhcp server running?)

    2) In the TAB DNS : looking at the resolv.conf you've already set it, but check the DNS settings

    3) In the TAB Routing : enter your gateway ip to Internet (this is your router or modem ip address, which is probably 192.168.0.1?)

    After you've set these save the settings by applying and retry if Internet is reachable.

    -Wj
    Have a lot of fun!

  7. #7

    Default Re: network problem

    Thank you Magic31 for your response!

    Using Yast2, i set the IP address (no dhcp service on my network).

    Yast2 shows IP: 192.168.0.11, Mask: 255.255.255.0,
    DNS = 212.217.0.1, Pass= 192.168.0.1.

    but it shows that too:
    "Hewlett Packard Company NC373i Integrated multifunction Gigabit Server Adapter (Not Connected).

    The cable is plugged and works fine, i tested it!

    randomly, the interface (managed by NetworkManager) turns the status of the network interface as "connected" or "not connected", even if the cable is plugged, and i don't know why!

    - on the systray, the program "kNetworkmanager" says now that wired interface is not available, and the networkcard LEDs turns on and off randomly. i thought its was the Network card whisch sucked, but with two other new, it is the same phenomenon!

  8. #8
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: network problem

    'ethtool eth0' (run as root using 'su -') should show if the nic "sees" a connection.
    You should see speed & duplex as well as a line stating 'Link detected: yes'

    If not it could be a driver issue... if there is no link please post the output of ' hwinfo --network '.

    As means of going a step back and start afresh you can try clearing out your current nic config files, *rebooting* and reconfiguring the nic using YaST.

    For this you need to remove all the ifcfg-ehtx and ifcfg-wlanx files (leaving template and lo alone)
    The files are in /etc/sysconfig/network/
    Again, you have to be root to delete the files (and only delete ifcfg-eth* and ifcfg-wl*) and reboot. If that works you can switch to knetworkmanager and go on from there.

    edit: it might be easier opening konqueror with root rights : enter ' kdesu konqueror ' on a normal console.

    Then reconfigure using YaST.

    ...

    edit2: I would suggest to configure using ifup first as this is the most direct way to setup you nic.
    Have a lot of fun!

  9. #9

    Default Re: network problem

    thanx a lot Magic!

    i set the ifup style and i try what you said an i post you the issue in about a quarter

  10. #10

    Default Re: network problem

    Link detected: no
    i will try the next step: clearing out your current nic config files, *rebooting* and reconfiguring the nic using YaST.



    here are the output of "ethtool eth0" and "hwinfo --network"

    linux:~ # ethtool eth0
    Settings for eth0:
    Supported ports: [ TP ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: Unknown! (65535)
    Duplex: Unknown! (255)
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: g
    Wake-on: d
    Link detected: no
    ############################################################################"

    linux:~ # hwinfo --network
    50: None 00.0: 10700 Loopback
    [Created at net.124]
    Unique ID: ZsBS.GQNx7L4uPNA
    SysFS ID: /class/net/lo
    Hardware Class: network interface
    Model: "Loopback network interface"
    Device File: lo
    Link detected: yes
    Config Status: cfg=no, avail=yes, need=no, active=unknown

    51: None 00.0: 10701 Ethernet
    [Created at net.124]
    Unique ID: usDW.ndpeucax6V1
    Parent ID: rBUF.sWQdX4kVaYC
    SysFS ID: /class/net/eth0
    SysFS Device Link: /devices/pci0000:00/0000:00:1c.0/0000:02:00.0/0000:03:00.0
    Hardware Class: network interface
    Model: "Ethernet network interface"
    Driver: "bnx2"
    Driver Modules: "bnx2"
    Device File: eth0
    HW Address: 00:1e:0b:6f:08:c4
    Link detected: no
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #33 (Ethernet controller)

    52: None 01.0: 10701 Ethernet
    [Created at net.124]
    Unique ID: L2Ua.ndpeucax6V1
    Parent ID: JNkJ.sWQdX4kVaYC
    SysFS ID: /class/net/eth1
    SysFS Device Link: /devices/pci0000:00/0000:00:1c.1/0000:04:00.0/0000:05:00.0
    Hardware Class: network interface
    Model: "Ethernet network interface"
    Driver: "bnx2"
    Driver Modules: "bnx2"
    Device File: eth1
    HW Address: 00:1e:0b:6f:08:c2
    Link detected: no
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #35 (Ethernet controller)

    53: None 02.0: 10701 Ethernet
    [Created at net.124]
    Unique ID: pDke.ndpeucax6V1
    Parent ID: mY_N.1iFMqOXUJgC
    SysFS ID: /class/net/eth2
    SysFS Device Link: /devices/pci0000:00/0000:00:04.0/0000:13:00.0
    Hardware Class: network interface
    Model: "Ethernet network interface"
    Driver: "e1000"
    Driver Modules: "e1000"
    Device File: eth2
    HW Address: 00:18:71:ea:e6:d8
    Link detected: no
    Config Status: cfg=new, avail=yes, need=no, active=unknown
    Attached to: #31 (Ethernet controller)
    linux:~ #
    Last edited by revealmap; 09-Jul-2008 at 06:29. Reason: the cable was plug in eth1 i re exexecute ethtool th0 and hwinfo with cable connected to eth0

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •