Results 1 to 8 of 8

Thread: Shutdown options grayed out

  1. #1
    athomepapa NNTP User

    Unhappy Shutdown options grayed out

    I am new to opensuse. I just preformed an installation of opensuse 10.3 onto a Acer Aspire 4520. I am trying to see the Windows shares on my office network and have been unable so far. After entering YaST and opening the firewall for the Samba Server I wanted to restart the machine to allow changes to take effect. When I go to the shutdown options they are all grayed out. I uninstaller opensuse 11 thinking it was corrupt for this same reason. Please help.

  2. #2
    Join Date
    Jul 2008
    Location
    ah...on earth certainly !
    Posts
    52

    Default Re: Shutdown options grayed out

    I had a similar problem last year, but I don't remember how I solved it.

    Most probably I typed "reboot" in the console as a root user.

    Your system should reboot and you should be able to access the Windows network.

    There's nothing wrong with Opensuse, you only have to learn to experiment with it better !!!

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Shutdown options grayed out

    > After entering YaST and opening the firewall for the Samba Server I
    > wanted to restart the machine to allow changes to take effect.


    first, this is not Windows(tm) so you will find that we don't have to
    shut down and reboot nearly as often....in the YaST firewall section you
    just make the changes and then click to start the firewall...


    > When I go to the shutdown options they are all grayed out. I
    > uninstaller opensuse 11 thinking it was corrupt for this same reason.
    > Please help.


    also, we don't usually need to jump to reinstall as the first thing we
    do when we run into a problem...well, sometimes that is the best way to
    remove all the crud one might mess up wandering around trying this and
    that to do what needs to be done....but, if you take your time and
    things one at a time you can usually avoid a uninstall and reinstall..

    having said that....was YaST open when you tried to logout and shutdown?
    as a general rule i usually shut down all open programs prior to log out
    and shut down..

    hmmmm, i can't help you in making contact with a Windows(tm)
    network...sorry, having none to connect to i've never tried it...but,
    i'm pretty sure there is a how-to somewhere on the SuSE site...

    oh, are you using KDE or gnome?

    --
    DenverD (Linux Counter 282315)
    A Texan in Denmark

  4. #4
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: Shutdown options grayed out

    Hi.
    Connection to windows shares is not so difficult. I'm a KDE user, so I use Konqueror where I can access windows shares directly by typing:
    Code:
    smb://ip-of-server
    You will get a list of shares with
    Code:
    remote:/
    Should work with gnome, too. And you only need to open the firewall port if you want run a samba server on your machine, i.e. if you want to share some directories on your notebook.
    Shutdown problem: Once in a while this happened to me on openSUSE 10.3, mostly after X crashed. So, I just logged off and turned off the computer in the login screen. The buttons reappeared on next boot.

  5. #5
    athomepapa NNTP User

    Default Re: Shutdown options grayed out

    Thank you all for your quick response. I am using GNOME, that is what I have gotten used to using Ubuntu and Linux Mint. I am relatively new to Linux, I have been using Linux Mint four about 4 month now. I made the switch to openSUSE as a necessity since the to have the same version as on of the companies whose software I am using for my dental practice.
    So far, I must admit, my experience has been a mixed bag. On the one hand I was able to install MONO and have my dental software running in no time. On the other hand I have had a lot of problems finding answers to my questions outside the forum with my network problem. I need to access the windows network to have access to my mySQL database and the associated share to save X-ray files to. I will continue to search for answers.
    As far as the shutdown options being grayed out. I did exit all programs before and after attempting the shutdown window at the main "start" menu, it did no seem to have an effect on the grayed out options.

  6. #6
    ab@novell.com NNTP User

    Default Re: Shutdown options grayed out

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Try going into Yast: Security and Users: Local Security

    In SLED 10, at least, there is an option in there to prevent anybody
    from 'root' performing a reboot.

    Good luck.





    athomepapa wrote:
    | Thank you all for your quick response. I am using GNOME, that is what I
    | have gotten used to using Ubuntu and Linux Mint. I am relatively new to
    | Linux, I have been using Linux Mint four about 4 month now. I made the
    | switch to openSUSE as a necessity since the to have the same version as
    | on of the companies whose software I am using for my dental practice.
    | So far, I must admit, my experience has been a mixed bag. On the one
    | hand I was able to install MONO and have my dental software running in
    | no time. On the other hand I have had a lot of problems finding answers
    | to my questions outside the forum with my network problem. I need to
    | access the windows network to have access to my mySQL database and the
    | associated share to save X-ray files to. I will continue to search for
    | answers.
    | As far as the shutdown options being grayed out. I did exit all
    | programs before and after attempting the shutdown window at the main
    | "start" menu, it did no seem to have an effect on the grayed out
    | options.
    |
    |
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFIcn+c3s42bA80+9kRAtuMAJ449SWTmWO5ISjTDDKnUpBScwWWKgCeLiUF
    z64xZ3mfcH+USrNSMlRae5o=
    =L8MY
    -----END PGP SIGNATURE-----

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Shutdown options grayed out

    i'm fresh out of help (over my head)..

    so let me suggest you join the network-internet forum, read the thread
    subjects and see if maybe the answer to your connect to shares hurdle is
    already there...OR post a new _network_ question there

    and, follow ab's (in his answer dated 7/7/08) trail to make sure
    non-root users are allowed to shut down your machine..

    and, maybe you can get back to torturing patients :-)

    and, when you get through these initial start up pains you will soon see
    (i think) why it is good to use linux when stability, predictability and
    security might have an impact greater than just your score in a game
    (maybe even affect your income)...

    have fun..

    --
    DenverD (Linux Counter 282315)
    A Texan in Denmark

  8. #8
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Shutdown options grayed out

    Hi & welcome to the forums

    Quote Originally Posted by athomepapa View Post
    ... On the other hand I have had a lot of problems finding answers to my questions outside the forum with my network problem. I need to access the windows network to have access to my mySQL database and the associated share to save X-ray files to. I will continue to search for answers.
    You say you have found answers outside the forum.. but have you also tried your luck here? Good chance you will get good direction in how to sort it out

    As far as the shutdown options being grayed out. I did exit all programs before and after attempting the shutdown window at the main "start" menu, it did no seem to have an effect on the grayed out options.
    You could check if the security setting is what is bugging >

    Open YaST > Local security - select custom settings > click next on the first screen (password settings) without changing any settings , the second screen holds the Boot Settings, check what is listed under 'Shutdown behavior of Login Manager' - this should be set to 'Automatic' or 'Users'.
    As far as I know GNOME looks at these settings to determine that you, as user, are allowed to do a system shutdown from the menu.

    Click Netx (3x) and Finish to apply the setting. You might need to logout/login for the setting to take effect.
    (edit: this setting can also be found in /etc/sysconfig/displaymanager - look for DISPLAYMANAGER_SHUTDOWN= )

    Hope that helps!

    As far for browsing to your Windows share, -supertimorplusfort mentioned it already for KDE - GNOME does the same thing;
    in Nautilus hit <CTRL>+<L> to get you location bar. Just enter ' smb://<ip or name server>/<sharename>' or ' smb://<ip or name server>/C$ ' for the administrative share.
    In openSUSE 11.0 (GNOME) you also get a mount point in Nautilus and on the desktop that ' sticks' until you dismount it.

    Cheers,
    Wj
    Have a lot of fun!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •