For the past 2 weeks I my system has automatically updated itself multiple times throughout the day without problem. Today this process repeatedly fails with a Package Kit Error, specifically with a dependency requirement failure. The 'more details' reveals about 40 instances of a "nothing provides ..." type error. Mostly the missing item is libgnome-desktop-2.80.7 needed by many other objects.

Why has this item suddenly gone missing, or suddenly become a new requirement? (I can't tell which of these applies).

Interestingly, the first bootup today resulted in a totally black, blank screen from which the only recovery option seemed to be to recycle the power. The second bootup resulted in a major change to my normal screen resolution: the characters were so small as to at the limit of my (aged) visual acuity - it certainly looked like an attempt to run my LCD (default 1280 x 1024) at something like 1920 x 1600. When I finally found the option to change screen resolution I found that the monitor type was unknown and there was no option to change from a resolution of 1280 x 1024 (which it quite clearly was not!)

On the third bootup screen resolution is back to what I normally have, but now I have these many automatic update errors.

Are these events related? Could other software updates which I implemented yesterday have caused the problem? How should I recover from these dependency failures?