Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: SigmaTel STAC9205 Dell 1520 Mic very quiet

  1. #1

    Default SigmaTel STAC9205 Dell 1520 Mic very quiet

    Hi,

    I'm running 11.0, and I just can't get the internal microphone to work correctly. It works fine in Windows, but not with Fedora 8, or what I have now installed, openSUSE 11.0

    The internal microphone is so quiet. It "works", but I just can't turn it up. I've googled a lot about this, and it seems some people have solved the issue, and others not, but playing with volume and capture settings. I've moved and clicked everything I can reach using Kmix, but no luck. I do not have a "mic boost" switch. It badly needs a mic boost switch !

    I've also tried setting

    options snd-hda-intel to various options, but no luck.

    Any ideas ? The internal mic itself, does "work", its just too quiet when using Skype and KRecord. I have to get very close to the mic for it to sound normal. As this Dell model has a webcam, I can't really put my face up to the mic when using Skype, as the webcam just picks my nose out !

    Thanks.

  2. #2

    Default Re: SigmaTel STAC9205 Dell 1520 Mic very quiet

    have you tried upping the pcm volume with kmix? not sure if this will fix it but it might help!

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: SigmaTel STAC9205 Dell 1520 Mic very quiet

    Quote Originally Posted by jjmoore27 View Post
    I'm running 11.0, and I just can't get the internal microphone to work correctly. ....The internal microphone is so quiet. It "works", but I just can't turn it up. .... I've moved and clicked everything I can reach using Kmix, but no luck. I do not have a "mic boost" switch.....I've also tried setting
    options snd-hda-intel to various options, but no luck.
    By various "options" I presume you mean you tried the options here from the ALSA-Configuration.txt file:
    (Reference: Linux Kernel Documentation :: sound : alsa : ALSA-Configuration.txt )
    Code:
    983		STAC9205/9254
    984		  ref		Reference board
    985		  dell-m42	Dell (unknown)
    986		  dell-m43	Dell Precision
    987		  dell-m44	Dell Inspiron
    How did you enter these options? Via YaST, or by editing your /etc/modprobe.d/sound file?

    Can you provide the EXACT syntax as to what your /etc/modprobe.d/sound file looks like after such an edit. ie provide the output of:
    cat /etc/modprobe.d/sound

    Please also provide output of:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a


    When connected to the internet, can you also run the two diagnostic scripts from the opensuse audio troubleshooting guide, and post the URLs here on this thread, that they provide:
    Code:
    wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh
    In the next script, when prompted for a password, enter your root password, and type "NO" for every question that you do not understand.
    Code:
    su -c 'wget -O tsalsa wget http://home.cfl.rr.com/infofiles/tsalsa && bash tsalsa'

  4. #4

    Default Re: SigmaTel STAC9205 Dell 1520 Mic very quiet

    Thanks for the detailed reply. I've not tried the dell-m44 option, and as my Dell is an inspiron, that would be a good option to pick. I'm at work now, and can't play with the laptop. But I'll execute all your suggests this evening and post the results here.

    I can turn the volume down using the capture slider, but at its highest position, its just very quiet.

    I already have the PCM slider at full, and moving this didn't make a difference.

  5. #5

    Default Re: SigmaTel STAC9205 Dell 1520 Mic very quiet

    I tried options dell-m44, dell, and dell-3stack by directly editing the sound file. Nothing changed. At first I used Yast, but this didn't seem to save the setting when I changed module. Only if I edited the file directly, did Yast pick out the change, when I checked what the setting was.

    Each time after changing the sound file, I performed a new start. But still the mic was very quiet. I played around with kmix too, but no difference. Basically it didn't seem to matter what I set module to.

    I then ran out of time. I'll post all the other test info later, and try running the diagnostic scripts.

    There are still other dell specified settings I could try too. If only there was a magic mic boost option switch !

    Thanks,
    Jon.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: SigmaTel STAC9205 Dell 1520 Mic very quiet

    Quote Originally Posted by jjmoore27 View Post
    I tried options dell-m44, dell, and dell-3stack by directly editing the sound file. Nothing changed. At first I used Yast, but this didn't seem to save the setting when I changed module. Only if I edited the file directly, did Yast pick out the change, when I checked what the setting was.
    Can you show me the EXACT syntax you used? ie paste the contents of the /etc/modprobe.d/sound file here.

  7. #7

    Default Re: SigmaTel STAC9205 Dell 1520 Mic very quiet

    suse-11:/etc/modprobe.d # cat /etc/modprobe.d/sound

    options snd slots=snd-hda-intel
    # u1Nb.uFfEBSd3JdA:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

    I have then added a line at the end to specify model. Like below.

    options snd slots=snd-hda-intel
    # u1Nb.uFfEBSd3JdA:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=dell

    I have tried dell-m44, dell, and dell-3stack as models by editing the sound file. Trying one change at a time. When using Yast to change the model, it isn't saved. Well at least it isn't saved in the sound file if it is saved. When I edit the file directly, reboot, then check with Yast, it does read the model correctly.

    Here is some more info:

    suse-11:/etc/modprobe.d # rpm -qa | grep alsa
    alsa-utils-1.0.16-35.1
    alsa-oss-1.0.15-48.1
    alsa-plugins-1.0.16-57.1
    alsa-1.0.16-39.1
    suse-11:/etc/modprobe.d # rpm -qa | grep pulse
    suse-11:/etc/modprobe.d # rpm -q libasound2
    libasound2-1.0.16-39.1
    suse-11:/etc/modprobe.d # uname -a
    Linux suse-11 2.6.25.5-1.1-pae #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux

    The first script

    Your ALSA information is located at general pastebin - J_Moore - post number 1065633

    Second script

    uploading /tmp/tsalsa.txt to nopaste.com
    tsalsa completed in 191 seconds
    paste this url in #alsa: tsalsa.txt - nopaste.com (beta)

    Thank you for taking the time to look at all this.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: SigmaTel STAC9205 Dell 1520 Mic very quiet

    Quote Originally Posted by jjmoore27 View Post
    I have then added a line at the end to specify model. Like below.
    Code:
    options snd slots=snd-hda-intel
    # u1Nb.uFfEBSd3JdA:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=dell
    I have tried dell-m44, dell, and dell-3stack as models by editing the sound file. Trying one change at a time.
    dell and dell-3stack are not proper options for your hardware audio codec, as far as I know. Why those?

    The options are as I already posted here:
    Code:
    985		  dell-m42	Dell (unknown)
    986		  dell-m43	Dell Precision
    987		  dell-m44	Dell Inspiron
    ie a file like:
    Code:
    options snd slots=snd-hda-intel
    # u1Nb.uFfEBSd3JdA:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=dell-m44
    then restart with rcalsasound restart and test your sound.

    PLEASE do NOT run alsaconf and do NOT go to yast > hardware > sound after making that edit as it will remove the edit, completely defeating the purpose of your making the edit.

    Frankly, I have no idea if you did the above properly (apologies, my wife says I am very grumpy tonight - and I think she is right - a rough day at work).

    I'll look at the rest of your post later, ... right now I'm just very tired ......

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: SigmaTel STAC9205 Dell 1520 Mic very quiet

    Quote Originally Posted by jjmoore27 View Post
    uploading /tmp/tsalsa.txt to nopaste.com
    tsalsa completed in 191 seconds
    paste this url in #alsa: tsalsa.txt - nopaste.com (beta)
    I'm looking at your mixer settings ....
    Code:
    Amixer contents for card 0 [Intel] _____________________________________        
    amixer set 'Master',0 79% on        
    amixer set 'PCM',0 100% 100%        
    amixer set 'Front',0 100%,100% on        
    amixer set 'IEC958',0 off        
    amixer set 'IEC958 Default PCM',0 on        
    amixer set 'Capture',0 Capture 0 0%,Capture 0 0% on        
    amixer set 'Capture',1 Capture 0 0%,Capture 0 0% on        
    amixer set 'Analog Loopback',0 off        
    amixer set 'Digital Input Source',0 Items: 'Analog Inputs' 'Digital Mic 1' Item0: 'Digital Mic 1'        
    amixer set 'Input Source',0 Items: 'Mic' Item0: 'Mic'        
    amixer set 'Input Source',1 Items: 'Mic' Item0: 'Mic'        
    amixer set 'Mux',0 Capture 4 100% Capture 4 100%        
    amixer set 'Mux',1 Capture 4 100% Capture 4 100%
    Try the following /etc/modprobe.d/sound file:
    Code:
    options snd slots=snd-hda-intel
    # u1Nb.uFfEBSd3JdA:82801H (ICH8 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    options snd-hda-intel model=dell-m44
    I recommend you take a hard look at your mixer settings. Any chance your laptop uses digital audio? In which case, you need to switch it on. Test that. (ie IEC958=ON, and its IEC958-PCM switched ON/up). If it doesn't work, switch it back off.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: SigmaTel STAC9205 Dell 1520 Mic very quiet

    Quote Originally Posted by oldcpu View Post
    I recommend you take a hard look at your mixer settings. Any chance your laptop uses digital audio? In which case, you need to switch it on. Test that. (ie IEC958=ON, and its IEC958-PCM switched ON/up). If it doesn't work, switch it back off.
    also, when testing your audio, try the following audio test (copy and paste it into an xterm/konsole):
    speaker-test -Dplug:front -c2 -l5 -twav

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •