Results 1 to 5 of 5

Thread: Test Sound Works, but no normal sound

  1. #1

    Default Test Sound Works, but no normal sound

    I just installed openSUSE 11.0 on this computer, which formerly had a fully-audio-functional installation of Ubuntu 8.04. I switched because I was having graphics issues. Now, the graphics are perfect, but the audio is not working (naturally...).

    I found the SDB:AudioTroubleshooting page, and went through some of the steps. I got down to the part about testing the sound in YAST, and found that I could get the test sound to work when I tried audio device 1 (I can't remember the name but I think it's in the code I'm posting here). However, whenever I try Amarok, Firefox flash media, anything else other than the test tone, I get nothing.

    Here are the advised scripts:
    Code:
    dan@linux-8amt:~> uname -a
    Linux linux-8amt 2.6.25.5-1.1-default #1 SMP 2008-06-07 01:55:22 +0200 x86_64 x86_64 x86_64 GNU/Linux
    dan@linux-8amt:~> rpm -qa | grep alsa
    alsa-plugins-1.0.16-57.1
    alsa-oss-1.0.15-48.1
    alsa-firmware-1.0.16-24.1
    alsa-1.0.16-39.1
    alsa-oss-32bit-1.0.15-48.1
    alsa-utils-1.0.16-35.1
    dan@linux-8amt:~> cat /etc/modprobe.d/sound
    
    options snd slots=snd-hda-intel,snd-hda-intel,snd-ice1712
    # Phdb.kinpUbvGVbE:M-Audio Delta 1010
    alias snd-card-2 snd-ice1712
    # 5Dex.mUj+CjFZG97:SBx00 Azalia
    alias snd-card-0 snd-hda-intel
    # l4dC.eYFlKjfSwt4:RS780 Azalia controller
    alias snd-card-1 snd-hda-intel
    Any ideas? I'm new to openSUSE so I'm a little unfamiliar with how things work, but in general I can work a command line if I get instructions. I'm still fumbling with the KDE interface too but I can manage. Any help would be greatly appreciated!

    Thanks,
    Dan

  2. #2

    Default Re: Test Sound Works, but no normal sound

    One other thing of note: I noticed when I was testing the various soundcards with the test tone that whatever card I had set as card 0 would not work; it had to be at least sound card 1. I did not try sound card 2, because that's my recording interface which I don't have anything connected to, and I haven't tested yet. I figure I'll fix one thing before I start another...

    -Dan

  3. #3

    Default Re: Test Sound Works, but no normal sound

    I fixed it, somehow! I'm not sure what I did when I was working with the settings earlier, but I restarted the computer and it all works. The only thing is the soundcard defaults to about 66% volume, which is too low for me as I have the computer hooked up to a home stereo via the headphone output. I turned it up, and it was much better. Apparently the sound settings don't apply until after a restart...

    -Dan

  4. #4

    Default Re: Test Sound Works, but no normal sound

    Rebooting the computer helps, even a simple logout. But your troubles will be back. What happens is that from time to time some application that requires alsa does not release it properly (at least that is what I think is happening).

    Here are things that I do:

    1. In some applications (e.g., VLC palyer), I had to change the audio output to OSS.

    2. Sometimes, it helps to run /usr/sbin/alsa-init as a root

    3. Sometimes, I have to logout. I tried to remove pulse, as pointed in the link provided here:

    but I prefer to wait for a real solution, so I re-installed pulse.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Test Sound Works, but no normal sound

    Quote Originally Posted by ivom66 View Post
    Rebooting the computer helps, even a simple logout. But your troubles will be back.
    Lets hope not.
    Quote Originally Posted by ivom66 View Post
    What happens is that from time to time some application that requires alsa does not release it properly (at least that is what I think is happening).
    Well, if that happens, what is useful is to determine what that app might be, and then kill the badly behaved process. To determine the app/process that is using sound, simply copy and paste into a konsole/xterm (I think with root permissions, I'm not at a linux PC so I can not confirm):
    lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

    Identify the offending process, and take action. The "kill -9 PID" command works, and before typing "kill -9 PID", one can first type "ps -A" to find the running process PID. Or simply press <CTRL><ESC> (under KDE) to see what process are running, with the appropriate option to kill errant process.

    It also helps (when sound is working properly) to run that line a few times, so that one has an idea what the baseline of a functional sound system looks like.

    Another way to restart one's sound (if necessary) is to type:
    rcalsaound restart

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •