Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Dual Boot w/Debian

  1. #1

    Default Dual Boot w/Debian

    I have an interesting scenario,

    I have 2 SATA hard drives:

    One - Hard disk with Opensuse 11 insalled. This is all setup and running on my PC.

    Second - Hard disk with Debian (64 Studio) installed, however it is from another machine. I want to install it in my current machine (currently running OPENSUSE 11).

    How do I edit the grub menu to see this drive as an option to run Debian (64 Studio)?

    Any Help would be greatly appreciated. Thank you!

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Dual Boot w/Debian

    Quote Originally Posted by homerj742 View Post
    I have an interesting scenario,

    I have 2 SATA hard drives:

    One - Hard disk with Opensuse 11 insalled. This is all setup and running on my PC.

    Second - Hard disk with Debian (64 Studio) installed, however it is from another machine. I want to install it in my current machine (currently running OPENSUSE 11).

    How do I edit the grub menu to see this drive as an option to run Debian (64 Studio)?

    Any Help would be greatly appreciated. Thank you!
    If it was from another machine, it's probably installed as if on the primary drive of the computer. If that's the case you'd need to use tha "map" function to boot it. I suggest a three step process:
    1. Back up the existing grub config file (menu.lst) with this command in a console:
      Code:
      sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.bak
    2. Reinitialise the Suse Grub installation in a fashion trhat will make it include the Debian partition:

      Go to Yast --> System --> Boot Loader. The Grub configuration screen comes up with the Tab "Section Management" activated. In the lower right is a drop-down selector labelled "Other". Select from "Other" the option "Propose New Configuration" and then wait for Grub to analyse your partitions and display a new configuration. This may take a while. Important: When that finishes, activate the tab labelled "Boot Loader Installation" and select to "Boot from the Master Boot Record". [Yast will often default to booting from the root or boot partition rather than from the MBR but that's for experts only -- always choose the MBR.] Then click Finish to save the changes and install the reconfigured Grub into the hard drive's MBR. If you get a message that "The bootloader boot sector will be written to a floppy disk ......... don't bother with the floppy -- just click OK to proceed and install to the MBR. Reboot and you should see a Debian entry along with the Suse entries on the Grub boot menu.
    3. That will allow booting back to Suse and hopefully into Debian BUT if I was right about the "map" function you will have to tweak that entry by adding these lines into the subsection for Debial in Suse's new menu.lst, just under the title line:
      Code:
      map (hd0) (hd1)
      map (hd1) (hd0)


    Luck
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3

    Default Re: Dual Boot w/Debian

    Thank you very much for this information! I will definitely try this out tomorrow after work.

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Dual Boot w/Debian

    Alternatively you could copy the stanza used by the 64 Studio's menu.lst into the current menu.lst and change all the hd0 to hd1 in that stanza.

    That's not all you need to do though. If you get 64 Studio's kernel loaded then it will use the /etc/fstab from the 64 Studio root partition. So you have to change the hda there to hdb, or sda to sdb, depending. This also needs to be done if you choose to go Swerdna's way because the swapping of disk with map only works on GRUB. Once the kernel is up, the disk will be at a different device name.

    You can do this change by mounting the disk on SUSE and then doing the edit with a text editor.

  5. #5
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: Dual Boot w/Debian

    There is another manner i use without messing with Grub config files. First make sure that Suse's Grub is installed in the root/boot partition then use a boot manager like gag. So you can google it and download. It is a small iso. Just burn it and reboot with this cd. You will be prompted by a small setup procedure where you will choose your keyboard and language. Then configure it pressing c and add all the operating systems you want. Save the configuration pressing h then return to the main menu pressing r and boot the system you decide.

  6. #6

    Default Re: Dual Boot w/Debian

    Quote Originally Posted by swerdna View Post
    If it was from another machine, it's probably installed as if on the primary drive of the computer. If that's the case you'd need to use tha "map" function to boot it. I suggest a three step process:
    1. Back up the existing grub config file (menu.lst) with this command in a console:
      Code:
      sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.bak
    2. Reinitialise the Suse Grub installation in a fashion trhat will make it include the Debian partition:

      Go to Yast --> System --> Boot Loader. The Grub configuration screen comes up with the Tab "Section Management" activated. In the lower right is a drop-down selector labelled "Other". Select from "Other" the option "Propose New Configuration" and then wait for Grub to analyse your partitions and display a new configuration. This may take a while. Important: When that finishes, activate the tab labelled "Boot Loader Installation" and select to "Boot from the Master Boot Record". [Yast will often default to booting from the root or boot partition rather than from the MBR but that's for experts only -- always choose the MBR.] Then click Finish to save the changes and install the reconfigured Grub into the hard drive's MBR. If you get a message that "The bootloader boot sector will be written to a floppy disk ......... don't bother with the floppy -- just click OK to proceed and install to the MBR. Reboot and you should see a Debian entry along with the Suse entries on the Grub boot menu.
    3. That will allow booting back to Suse and hopefully into Debian BUT if I was right about the "map" function you will have to tweak that entry by adding these lines into the subsection for Debial in Suse's new menu.lst, just under the title line:
      Code:
      map (hd0) (hd1)
      map (hd1) (hd0)


    Luck

    I'm running into one issue. After installing the Debian hard drive into my PC, and booting the PC, it shows only the grub menu for Debian, nothing pertaining to OPENSUSE 11. In order to get into OPENSUSE to make those changes stated above, I have to disconnect the hard drive with Debian Installed.

    Is this how it's supposed to be? Please advise, thank you!

  7. #7

    Default Re: Dual Boot w/Debian

    Ok, Ignore the last post, I'm able to get into Opensuse 11.0 now (after running the Boot loader again).

    I get the option for Debian (64 Studio), but it still won't boot up. I made the changes in the menu.lst in OpenSuse, but still won't let me in. Any advice would be greatly appreciated.

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Dual Boot w/Debian

    Quote Originally Posted by homerj742 View Post
    Ok, Ignore the last post, I'm able to get into Opensuse 11.0 now (after running the Boot loader again).

    I get the option for Debian (64 Studio), but it still won't boot up. I made the changes in the menu.lst in OpenSuse, but still won't let me in. Any advice would be greatly appreciated.
    Check what ken_yap said. Also how far does the boot get in Debian, if at all? Any messages on screen?
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  9. #9

    Default Re: Dual Boot w/Debian

    Quote Originally Posted by swerdna View Post
    Check what ken_yap said. Also how far does the boot get in Debian, if at all? Any messages on screen?

    I'm not entirely sure what he means by "stanza" (I'm pretty new to editing grub menus and such).

    This is the error I get:

    Code:
    Error 17: Cannot mount selected Partition
    Thank you!

  10. #10
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Dual Boot w/Debian

    Error 17 happens if you point the bootloader at the wrong partition. Please enter the following two commands in a console and post the results back here:
    sudo /sbin/fdisk -l
    and
    sudo cat /boot/grub/menu.lst
    The first command shows what partitions are on the two drives. The second shows eher you're pointing Grub and also the minor details that might trick it up.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •