Results 1 to 7 of 7

Thread: Clock is running fast

  1. #1
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Clock is running fast

    I have a PC with:

    sda - Mint 5
    sdb - openSuse 11
    sdc - sidux

    The last couple of days I've noticed that my clock in opensuse is running twenty minutes fast, so I thought it may be the battery on the motherboard. But then I logged into Mint 5 and the clock is accurate there. If the battery was bad then all three distros would be off time, correct?

    What would cause openSuse's clock to run fast?

  2. #2
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Re: Clock is running fast

    ...this morning when booting up, the clock was fast by 1 hr and 40 minutes. What could cause this?

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Clock is running fast

    Look for the file /etc/adjtime. It's probably got some insane values in it. Post what's in it and then delete it and see if that fixes your problem.

  4. #4
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Re: Clock is running fast

    here it is:

    18765.953693 1215431182 0.000000
    1215431133
    UTC

  5. #5
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Clock is running fast

    vinoman2 wrote:

    >
    > ...this morning when booting up, the clock was fast by 1 hr and 40
    > minutes. What could cause this?
    >
    >


    The system tries to 'tweak' the 'ticks' per second, so that system time will
    (slowly) catch up to real time. Occasionally, the tweak swings too far, and
    the clock runs fast...

    the control data for the ticker is /etc/adjtime

    If you delete that file, then the next time you reboot, ntp will recreate it
    with default values, and start doing the 'tweak' thing again as you adjust
    the clock.

    Big jumps are often caused by shifting from LocalTime to UTC or vice-versa.
    If you keep your system clocks on UTC, the operating system will
    automatically adjust for daylight savings. If you're booting Windows
    anytime, leave it as LocalTime, since Windows doesn't know how to deal with
    clocks in UTC (Unless you live in Greenland!)

    A good suggestion is to enable the NTP client to start at boot. This will
    correct the time at boot, and every few hours. Keeps the 'tweaker' from
    making you time-travel into the future.

    Just tell it to use random address from pool, and enable at boot. No more
    problem!!

    Take Care,

    Loni

    --
    L R Nix
    lornix@lornix.com

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Clock is running fast

    Quote Originally Posted by vinoman2 View Post
    here it is:

    18765.953693 1215431182 0.000000
    1215431133
    UTC
    Yeah that first value is too high.

  7. #7
    Join Date
    Jun 2008
    Location
    Oregon
    Posts
    455

    Default Re: Clock is running fast

    I thought so. I deleted it and rebooted. I'll see how it does tomorrow morning. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •