Results 1 to 2 of 2

Thread: opensuse 11.0 + wifi: firewall not initialising

  1. #1
    -G- NNTP User

    Default opensuse 11.0 + wifi: firewall not initialising

    Hi,
    Installed opensuse 11.0 in an old (PIII 700MHz) machine (ran OK suse 10.3
    and previous, too) with a linksys wifi card (using ndiswrapper +
    Networkmanager).
    The card connects OK to the net, one can surf with not problems.

    The problem started when I tried to ssh into the machine and it would not
    respond to ssh or to ping. (there is nothing printed on screen until I hit
    crtl-C)

    I have the correct entries in host.allow and in the Trusted_nets part of
    susefirewall2 files (which worked in suse 10.3).

    I have rebooted, re-written those config files many times and nothing, I
    just cannot ping it (but I can ping from it other machines, so the network
    is working).

    Partial clues:
    I went to Yast>System>Runlevels and disabled and immediately enabled the
    SuSEfirewall_setup service and this allowed ping to the machine, etc.

    but after rebooting the problem pops again. :-/
    I then tried:

    # SuSEfirewall2
    SuSEfirewall2: /var/lock/SuSEfirewall2.booting exists which means system
    boot in progress, exit.

    but this was several minutes after the boot (?).

    If I tried:
    # /etc/init.d/SuSEfirewall2_setup restart
    Starting Firewall Initialization (phase 2 of 2) done

    the problem is cured again until a reboot.

    I wonder if the networkmanager connects to the router too late (when the
    user desktop is up) and this interferes with the phase 2 setup of the
    firewall somehow.

    Or perhaps something is missing in the starting scripts?


    Many thanks for any suggestions.

    -G-



  2. #2
    -G- NNTP User

    Default Re: opensuse 11.0 + wifi: firewall not initialising

    I wrote:

    > Or perhaps something is missing in the starting scripts?


    Well, I found the culprit: NTP service.
    Looking in the logs, the NTP call to the server at boot time is not
    successful (I guess that it is because the wlan0 is not yet set up) and
    this seems to screw up the firewall setup.

    I thought that I would post here the solution in case anybody else has this
    problem.

    -G-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •