I couldn't get kshutdown to execute the /sbin/powerdown command because it required the superuser. What I did was chmod +s /sbin/powerdown (which changed halt because powerdown is a symbolic link) and this seemed to fix the problem. My question is: is this an adequate way of rectifying the situation or is setting powerdown to suid a bad idea?