Results 1 to 7 of 7

Thread: "Nothing provides kdegames4 >= 4.0.85 needed by ...."

  1. #1
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default "Nothing provides kdegames4 >= 4.0.85 needed by ...."

    I am using OS 11. When I tried to install the kde-based puzzle Knetwalk I get this error message:

    "Nothing provides kdegames4 >= 4.0.85 needed by kde4-knetwalk-4.0.84-2.6.i586"

    A google search leads me to:

    RPM Search kdegames4[]=46

    and this truly shows that no package at the required level exists. There is a package at the 4.0.84-2.4 level available. When I click the link to this package the page I am presented with contains the startling comment:

    "Hmm ... It's impossible ;-) This RPM doesn't exist on any FTP server"


    Any advice on how I overcome this problem? I do not have the skills or knowledge to compile the source code.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: "Nothing provides kdegames4 >= 4.0.85 needed by ...."

    Quote Originally Posted by XEyedBear View Post
    I am using OS 11. When I tried to install the kde-based puzzle Knetwalk I get this error message:
    Try installing an older version of Knetwalk.
    Webpin search for knetwalk

  3. #3
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: "Nothing provides kdegames4 >= 4.0.85 needed by ...."

    That is an elegant and simple solution. Why didn't I think of that?

    No matter. Unfortunately loading the 4.0.4 level of this puzzle, which is described as stable, leads to this when I try to execute the installed game:

    "A Fatal Error Occurred
    The application KNetWalk (knetwalk) crashed and caused the signal 11 (SIGSEGV)."

    Is the best course of recovery to uninstall this level and look for something even earlier? Or this possibly symptomatic of a systemic problem with KDE4?

  4. #4
    Join Date
    Mar 2008
    Location
    Toronto, Canada
    Posts
    305

    Default Re: "Nothing provides kdegames4 >= 4.0.85 needed by ...."

    XEyedBear wrote:

    > "Nothing provides kdegames4 >= 4.0.85 needed by
    > kde4-knetwalk-4.0.84-2.6.i586"
    >


    I've had this error since the last KDE4.1 build was pushed out a couple of days ago. I just instructed Yast not to install the game update pacakges, in order to resolve the dependencies.

    From my experience, it means that kdegames4 failed to compile properly in the build-service, and so didn't get pushed out with the rest of the 4.0.85 packages. Which causes issues for packages dependent upon it. I usually only run into this sort of thing with SL-factory updates, but given that KDE4:/factory is based on weekly snapshot updates, I suppose the same circumstances apply.

    I would just wait a day or two and see if the new packages get pushed out. That's what usually happens. It's the drawback to using the developmental version, although the positives still outweigh the negatives...

    Cheers,
    KV

  5. #5
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: "Nothing provides kdegames4 >= 4.0.85 needed by ...."

    Quote Originally Posted by else_where View Post
    XEyedBear wrote:

    > "Nothing provides kdegames4 >= 4.0.85 needed by
    > kde4-knetwalk-4.0.84-2.6.i586"
    >

    I would just wait a day or two and see if the new packages get pushed out. That's what usually happens. It's the drawback to using the developmental version, although the positives still outweigh the negatives...

    Cheers,
    KV
    This is just about the only part that I understand. I have waited for about a week, but Knetwalk still fails. I no longer get the dependency failure message. When the puzzle loads, the main window is completely blank, the pointer shows as a double headed arrow, the menu bar shows 'No Text' as the only item and the status bar (at the bottom of the window) looks normal. The only action I can complete is to quit the puzzle.

    What should I be doing to tie down the cause of the problem? This puzzle works (but very slowly) under Fedora 9 on my ancient PIII lap top, so I'm sure there is not defect in the game logic
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  6. #6
    Join Date
    Jun 2008
    Location
    Omaha, NE
    Posts
    526

    Default Re: "Nothing provides kdegames4 >= 4.0.85 needed by ...."

    Software.openSUSE.org

    Search for knetwalk and try installing different versions. For instance, I think Unstable currently has 4.0.83, where as Factory has 4.0.85, and Stable has 4.0.5

  7. #7
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: "Nothing provides kdegames4 >= 4.0.85 needed by ...."

    I'd be grateful for the exact link to one of these packages. Over the last week or so I have looked for one. Most of the packages fall into the classification that I described when I started this thread : @Hmm ... it's impossible.. doesn't exist on any ftp server'

    None of the packages that I have been able to get produce a working version (other then version 3, which I don't want) of Knetwalk. It's very strange, because the version I installed under Fedora 9 on amy laptop works without problem.
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •