Results 1 to 9 of 9

Thread: No sound in SUSE 11, KDE 4

  1. #1
    tuxpenguin NNTP User

    Unhappy No sound in SUSE 11, KDE 4

    Hey everyone,

    I'm not new to Linux, but I am new to openSUSE, so bear with me. :-/

    I just installed openSUSE 11, KDE 4 version on my computer. I love it so far, but there is one problem that I can't seem to fix with my limited Ubuntu/Kubuntu experience. I have ZERO sound right now.

    I've done everything I can think of [and yes, I've gone through the whole sound troubleshooting guide...the answer throughout it was "no, I don't have sound" and none of the steps did anything]. I have the latest version of Alsa [as far as I can tell], I looked to see about pulse-audio, saw that I didn't have it, installed it [did nothing] and reinstalled it [same thing]. I've fidded with Kmix, alsaconf, and Yast's sound module...none of them gave me sound.

    Output of
    Code:
    cat /etc/modprobe.d/sound
    :

    options snd slots=snd-emu10k1
    # gZD2.9jPiZAnlR97:SB Audigy 2 ZS (SB0350)
    alias snd-card-0 snd-emu10k1

    The most confusing thing is that I haven't gotten an error throughout. According to SUSE, my sound is working just fine. [Don't you just LOVE these types of problems? ]

    Any help would be great. Thanks.

    -Matt

  2. #2

    Default Re: No sound in SUSE 11, KDE 4

    Just a thought. Have you selected audigy output jack in the switches in kmix? By default on my install it was not selected.

  3. #3
    tuxpenguin NNTP User

    Default Re: No sound in SUSE 11, KDE 4

    I'm assuming you're talking about making sure that I'm adjusting settings for the correct sound card...in that case yes, it's the only option available.

    I really hate to say it, but this never happened to me in Ubuntu. hehe.

    Don't worry...I like SUSE enough that I don't think I'm going back.

  4. #4
    Join Date
    Jun 2008
    Location
    PHX
    Posts
    481

    Default Re: No sound in SUSE 11, KDE 4

    See if THIS helps. And make sure you are in the 'audio' group.

    $ groups
    users audio cdrom disk video wheel
    <>---><^>

  5. #5

    Default Re: No sound in SUSE 11, KDE 4

    Lets just try something simple,
    In Kmix when yuy right click on the volume control in the panel, there is an option Select Master Channel,
    try that,make sure that pcm or front or depending on your sound card that the right output is selected for the control to use. your volume control may not be set operate the correct output. after that try the Show Mixer Window and make sure the output is actually active.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound in SUSE 11, KDE 4

    Quote Originally Posted by tuxpenguin View Post
    I'm assuming you're talking about making sure that I'm adjusting settings for the correct sound card...in that case yes, it's the only option available.
    Further to what inhaler noted, please check your mixer carefully. There is guidance here:
    [Solution] Creative Audigy 1/2 + 11.0 + KDE/GNOME + ALSA - openSUSE Forums

    also ensure you have alsa-firmware installed (you must reboot after installing that) and as also noted, if still no sound, add your regular user to group "audio" (per Cryovac's suggestion).

    If that does not work, please provide the output of:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a

    and also run the two diagnostic scripts from the audio troubleshooting guide by copy and pasting the following into an xterm/terminal (while your PC is connected to the internet):
    Code:
    wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh
    and for the following type the root password when prompted for a password
    Code:
    su -c 'wget -O tsalsa wget http://home.cfl.rr.com/infofiles/tsalsa && bash tsalsa'
    and then post the URLs that these scripts provide here.

  7. #7
    tuxpenguin NNTP User

    Default Re: No sound in SUSE 11, KDE 4

    Time to smack myself in the forehead. *smack*

    That guide you posted, oldcpu, fixed it. I didn't have the correct channel enabled. [I knew it had to be something like that ]

    Thanks for the help guys.

    -Matt

  8. #8
    anthonynone NNTP User

    Default Re: No sound in SUSE 11, KDE 4

    hoping this is no stupid notice
    Having virtualbox running with the sound device initialised, is somethig that Amarok does not particularly like. Thus one (or I at least) could not utilize audio output in both the virtualbox host and suse at the same time...

  9. #9

    Default Re: No sound in SUSE 11, KDE 4

    Thanks admiralFubar, I had the same problem and doing what you wrote fixed it.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •