Results 1 to 6 of 6

Thread: Java plugin for Firefox in Suse 11.0 X86_64

  1. #1
    NetGhost6464 NNTP User

    Thumbs down Java plugin for Firefox in Suse 11.0 X86_64

    I just updates to Suse 11.0 X86_64 and use Firefox 3.0. The java plug-in does not work as it did not in the X86_64 architecture in 10.3.
    I installed IcedTea rpm's 1.7 as indicated on Mozilla site and java plug-in is recognized in aboutlugins page. Anyhow, on any applet a pop-up message displays the error message:
    "gcjwebplugin error: Failed to run /usr/lib64/jvm/java-1.7.0-icedtea-1.5_b24/jre/lib/amd64/../../bin/pluginappletviewer. For more detail rerun "firefox -g" in a terminal window."
    And indeed, there is no "pluginappletviewer" in the directory indicated in the message.

    But surprise, I find out that in Konquerer file manager/browser (I use KDE) java plugin works & applets are correctly displayed.

    Looking at the way Yast installed various packages I find that IcedTea 1.7 JRE is 32 bit version while the Java plug-in package is X86_64. That is why the X86_64 verion of the plug-in looked for an appletviewer in /usr/lib64 directory
    Replacing by installation the IcedTea 1.7 JRE 32 bit with its X86_64 version has a strange effect:
    a. Konqueror does not work anylonger
    b. Firefox does not give the error message but applets stay mute: none really work, just white square in the browser.
    Bringing back the IcedTea 1.7 JRE 32 bit restore the initial situation: java applets work in Konqueror but in Firefox one gets the same error message.
    Anyone can help??? These X86_64 java plug-in problems are there since at least Suse 10.3 it's time to fix them...
    thanks to anyone who could help

  2. #2
    Join Date
    Jun 2008
    Location
    Oregon, US
    Posts
    109

    Default Re: Java plugin for Firefox in Suse 11.0 X86_64

    I don't know if this will fix your problem, but I had problems with applets working with IcedTea 1.7. I removed all components for IcedTea in Yast, and then installed the older version OpenJDK 1.6. Applets now work in firefox for me. I am using the 64 bit version of everything, specifically, the following packages:
    java-1_6_0-openjdk
    java-1_6_0-openjdk-plugin

    I don't use konqueror for any browsing, so I don't know how this will affect that.

  3. #3
    Graham P Davis NNTP User

    Default Re: Java plugin for Firefox in Suse 11.0 X86_64

    elserj wrote:

    >
    > I don't know if this will fix your problem, but I had problems with
    > applets working with IcedTea 1.7. I removed all components for IcedTea
    > in Yast, and then installed the older version OpenJDK 1.6. Applets now
    > work in firefox for me. I am using the 64 bit version of everything,
    > specifically, the following packages:
    > java-1_6_0-openjdk
    > java-1_6_0-openjdk-plugin
    >
    > I don't use konqueror for any browsing, so I don't know how this will
    > affect that.
    >
    >


    I was about to comment that I'd tried your suggestion and it didn't work but
    luckily tried this page again -
    http://www.ssd.noaa.gov/goes/flt/t1/loop-avn.html (Tropical Storm Bertha
    winding up) - and found it's now OK.

    Also, it's still OK on Konqueror, but that worked through all Firefox's
    trials and tribulations.

    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy


  4. #4
    NetGhost6464 NNTP User

    Default Re: Java plugin for Firefox in Suse 11.0 X86_64

    I wanted to take few minutes and thank you so very much for giving me the advices that helped me solving this problem..indeed java plugin work now following the indications you gave me..thanks again!!

    I wonder why Suse does not change their installation ....I find YAST in 11.0 far more difficult to sue given the new grouping of packages...

  5. #5
    NetGhost6464 NNTP User

    Default Re: Java plugin for Firefox in Suse 11.0 X86_64

    I wanted to take few minutes and thank you so very much for giving me the advices that helped me solving this problem..indeed java plugin work now following the indications you gave me..thanks again!!

    I wonder why Suse does not change their installation ....I find YAST in 11.0 far more difficult to sue given the new grouping of packages...

  6. #6
    Graham P Davis NNTP User

    Default Re: Java plugin for Firefox in Suse 11.0 X86_64

    NetGhost6464 wrote:


    >
    > I wonder why Suse does not change their installation ....I find YAST
    > in 11.0 far more difficult to sue given the new grouping of packages...
    >
    >


    Totally agree. I think the new system was designed to stop you finding
    anything.

    --
    Graham P Davis, Bracknell, Berks., UK. E-mail: newsman not newsboy


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •