Results 1 to 8 of 8

Thread: Move VM in 10.3 to 11.0 (new installation)

  1. #1
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    39

    Default Move VM in 10.3 to 11.0 (new installation)

    Hi,

    I have virtual box working perfectly in Suse 10.3. Now I want to install 11.0 and move the working virtual machines to this new install. Is that possible and how??
    By the way, does anyone have experience with virtual box on 11.0??
    Thanks for replying!!

  2. #2
    Will Honea NNTP User

    Default Re: Move VM in 10.3 to 11.0 (new installation)

    GeckoSuse wrote:

    >
    > Hi,
    >
    > I have virtual box working perfectly in Suse 10.3. Now I want to
    > install 11.0 and move the working virtual machines to this new install.
    > Is that possible and how??
    > By the way, does anyone have experience with virtual box on 11.0??
    > Thanks for replying!!


    Copy the entire directory (default is home/<user>/.VirtualBox) from 10.3 to
    a matching directory in 11.0. If you updated and saved you /home, then
    it's already there.

    I had to use the binary from virtualbox.org but only to get the USB
    functionality I needed for a couple of apps. If you need USB, then get the
    binary from VitrualBox, extract it and execute the .run file. Otherwise,
    you can just install the OSE version via Yast - they all use the same
    virtual disc files. You will have to re-install the extensions, but the
    amount of setup is minimal - just make sure you backup your virtual disc
    files - all of them! - before you start since Murphy is alive and well.

    --
    Will Honea

  3. #3
    Niclas Ekstedt NNTP User

    Default Re: Move VM in 10.3 to 11.0 (new installation)

    Will Honea,

    The Virtualbox Community Repository below has both versions packaged
    already, the 1.6.2 version has the USB support.

    http://download.opensuse.org/reposit.../openSUSE_11.0


    --
    _________________________________________
    Niclas Ekstedt, CNA/CNE/CNS/CLS
    Systems Engineer/NSC Sysop
    Telindus Sweden AB

  4. #4
    Will Honea NNTP User

    Default Re: Move VM in 10.3 to 11.0 (new installation)

    Niclas Ekstedt wrote:

    > The Virtualbox Community Repository below has both versions packaged
    > already, the 1.6.2 version has the USB support.
    >
    >

    http://download.opensuse.org/reposit.../openSUSE_11.0
    >


    All I see there are the OSE version rpms so unless I got a weird copy there
    was NO USB in the OSE 1.6.2 version I installed - menus or config. That's
    also pretty clearly stated on the VirtualBox web pages as well - has
    something changed recently?

    --
    Will Honea

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    39

    Default Re: Move VM in 10.3 to 11.0 (new installation)

    Thanks Will for the advice. I had the same idea, but no experience. I'll let you know how things work out.

  6. #6
    Niclas Ekstedt NNTP User

    Default Re: Move VM in 10.3 to 11.0 (new installation)

    Will Honea,

    > was NO USB in the OSE 1.6.2 version I installed - menus or config. That's
    > also pretty clearly stated on the VirtualBox web pages as well - has
    > something changed recently?


    Just tried it on a testbox and you're right. There's only the OSE versions,
    now. I've been playing around with VBox so much lately, so I'm probably
    just mixing the repos up :-(
    As you say get the non-OSE version from the virtualbox site and you do get
    USB support.


    --
    _________________________________________
    Niclas Ekstedt, CNA/CNE/CNS/CLS
    Systems Engineer/NSC Sysop
    Telindus Sweden AB

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    39

    Default Re: Move VM in 10.3 to 11.0 (new installation)

    Okay dear readers,
    I 've done the above, but get the following error message;


    The virtual machine could not be started because the DVD image '/usr/share/virtualbox/VBoxGuestAdditions.iso' which is attached to it could not be found or could not be opened. Please detach the image and try again.


    Result Code:
    0x80004005
    Component:
    Console
    Interface:
    IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}


    So please help....

  8. #8
    Niclas Ekstedt NNTP User

    Default Re: Move VM in 10.3 to 11.0 (new installation)

    GeckoSuse,

    > --The virtual machine could not be started because the DVD image
    > '/usr/share/virtualbox/VBoxGuestAdditions.iso' which is attached to it
    > could not be found or could not be opened. Please detach the image and
    > try again.


    This should be as easy as just go into the VM and and select the CDROM to be
    Not Mounted. Reason for this is that the CD image that you have specified
    in the Virtual Disk Manager no longer exists. You can go into the Virtual
    Disk Manager and remove the no longer existing image and readd it once
    you've located it.


    --
    _________________________________________
    Niclas Ekstedt, CNA/CNE/CNS/CLS
    Systems Engineer/NSC Sysop
    Telindus Sweden AB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •