Results 1 to 2 of 2

Thread: NVidia legacy old driver patch failed

  1. #1

    Default NVidia legacy old driver patch failed

    I have a workstation with GeForce2GTS video card, which is only supported by NVidia driver 71.86.04. Recently I've installed openSUSE 11 x86, and now I'm trying to use this driver with 2.6.25 kernel, which comes woth the distribution. Howto on Nvidia site says to apply patch, but when I try to do this, I've got an error:

    Code:
    # sh NVIDIA-Linux-x86-71.86.01-pkg1.run --apply-patch NVIDIA_kernel-71.86.04-2305230.diff.txt
    Verifying archive integrity... OK
    Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86 71.86.01.................................................................................................................................................................................................................................
    patching file usr/src/nv/Makefile.kbuild
    patching file usr/src/nv/conftest.sh
    Hunk #1 succeeded at 97 (offset -3 lines).
    Hunk #2 succeeded at 147 (offset -3 lines).
    Hunk #3 succeeded at 526 (offset -3 lines).
    patching file usr/src/nv/nv-linux.h
    Hunk #3 succeeded at 101 (offset -1 lines).
    Hunk #4 succeeded at 122 (offset -1 lines).
    Hunk #5 succeeded at 522 (offset -3 lines).
    Hunk #6 succeeded at 540 (offset -3 lines).
    Hunk #7 succeeded at 776 (offset -3 lines).
    Hunk #8 succeeded at 981 (offset -3 lines).
    Hunk #9 succeeded at 991 (offset -3 lines).
    Hunk #10 succeeded at 998 (offset -3 lines).
    Hunk #11 succeeded at 1072 (offset -3 lines).
    Hunk #12 succeeded at 1101 (offset -3 lines).
    patching file usr/src/nv/nv-vm.c
    patching file usr/src/nv/nv-vm.h
    patching file usr/src/nv/nv.c
    Hunk #1 succeeded at 86 (offset -11 lines).
    Hunk #2 succeeded at 837 (offset -11 lines).
    Hunk #3 succeeded at 953 (offset -11 lines).
    Hunk #4 succeeded at 980 (offset -11 lines).
    Hunk #5 FAILED at 1090.
    Hunk #6 succeeded at 1186 (offset -16 lines).
    Hunk #7 succeeded at 1236 (offset -16 lines).
    Hunk #8 succeeded at 1253 (offset -16 lines).
    Hunk #9 succeeded at 1287 (offset -16 lines).
    Hunk #10 succeeded at 1302 (offset -16 lines).
    Hunk #11 succeeded at 1313 (offset -16 lines).
    Hunk #12 succeeded at 1364 (offset -16 lines).
    Hunk #13 FAILED at 1396.
    Hunk #14 succeeded at 1476 (offset -23 lines).
    Hunk #15 succeeded at 1509 (offset -23 lines).
    Hunk #16 succeeded at 2085 (offset -23 lines).
    Hunk #17 succeeded at 2215 (offset -23 lines).
    Hunk #18 succeeded at 3243 (offset -23 lines).
    Hunk #19 succeeded at 3278 (offset -23 lines).
    Hunk #20 succeeded at 3292 (offset -23 lines).
    Hunk #21 succeeded at 3314 (offset -23 lines).
    Hunk #22 succeeded at 3345 (offset -23 lines).
    Hunk #23 succeeded at 3419 (offset -23 lines).
    Hunk #24 succeeded at 3973 (offset -23 lines).
    Hunk #25 succeeded at 4107 (offset -23 lines).
    2 out of 25 hunks FAILED -- saving rejects to file usr/src/nv/nv.c.rej
    patching file usr/src/nv/nv.h
    patching file usr/src/nv/os-interface.c
    Hunk #12 succeeded at 1077 (offset 1 line).
    Hunk #13 succeeded at 1111 (offset 1 line).
    Hunk #14 succeeded at 1159 (offset 1 line).
    patching file usr/src/nv/os-registry.c
    Failed to apply patch file "/home/madcad/Install/Driver/NVIDIA_kernel-71.86.04-2305230.diff.txt".
    Doesn't anybody know a way to solve this problem?

    I was unable to find usr/src/nv/nv.c.rej or any other files - looks like they are comes from NVidia driver and being deleted after patch run fails.

  2. #2

    Default Re: NVidia legacy old driver patch failed

    Ow, I've found error - I'm using NVIDIA-Linux-x86-71.86.01-pkg1.run instead of NVIDIA-Linux-x86-71.86.04-pkg1.run. I don't remember, where I run into it, some link may be broken, look out for it. Patch now works.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •