Results 1 to 5 of 5

Thread: Passwordless Login Problem

  1. #1
    Join Date
    Jul 2008
    Location
    Ljubljana
    Posts
    522

    Question Passwordless Login Problem

    Hi. I've been struggling with this problem since I installed SuSE 11.0 ten days or so ago (I had to replace KDE4 with KDE3 because KDE4 kept crashing all the time). Now what I'd like to achieve is let my two pre-school kids acces the computer to play some online games. So I set up passwordless login to enable them to log in with just a double klick on their user names at the login screen. The problem is, there is no granularity that I know of. If I set up SuSE for passwordless login, the kids may click on any account name and just mess up the home directories of other family members (worse: did you know that even root becomes passwordless???!!!). If I uncheck the passwordless option in YAST, then EVERY account requires a password to log in (my kids can't write yet). There's analog functionality in the KDEControl Center, and it has more granularity; there you can select passwordless login on a per-user, and even on a per-group basis. The problem is, these options apparently never get read on a SuSE system, SuSE somehow just overrides them. My simple question is: how can one enable passwordless login (double-click login at the welcome screen) only for specific users on a SuSE system? And, if this is not achievable natively (via YAST, the "SuSE way"), how can one at least stop SuSE from overriding the KDE Control Center login settings? Any suggestions welcome.

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Passwordless Login Problem

    You could create the accounts with a blank password (after creating the account in YaST, open a terminal console, ' su - ' to get root rights, enter 'passwd <account name>' and hit enter twice.
    That way they can login without a password (they will probably have to hit enter on the password field).

    As far as messing up root directories, users should only have read rights to other users directories.
    If you want to have the home directories off limits to others and only viewable to the owner, you can set this by entering ' chmod 700 /home/<user directory name> ' in a console (again as root).

    Hope that helps,
    Wj

    P.s. I'm not to familiar with the KDE option you mention (mostly work in GNOME), could be something else needs to be set before that works. I can't help you there as I can't also test it at the moment.
    Have a lot of fun!

  3. #3
    Join Date
    Jul 2008
    Location
    Ljubljana
    Posts
    522

    Default Re: Passwordless Login Problem

    Thanx, your answer does help. I would like some KDE user to enlighten me on the other topic though, namely, why and how does SuSE override the KDE settings, and what are the possible countermeasures to that. It seems to me a wrong decision on the part of the SuSE team, and unnecessarily confusing to the users (allowing two separate user interfaces for setting essentially the same set of options - and then only letting one of those sets "stick").

  4. #4
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Passwordless Login Problem

    Seeing you want KDE specific info and also your question goes a bit deeper then only the passwordless login.. I would suggest for you to post a new question in the applications sub category.
    It should get you a broader repsonse.

    Good luck!
    Wj
    Have a lot of fun!

  5. #5
    Join Date
    Jul 2008
    Location
    Ljubljana
    Posts
    522

    Default Re: Passwordless Login Problem

    I think I'll do that. Thx.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •