Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Cannot Chown Limewire foler on Windows partition

  1. #1

    Default Cannot Chown Limewire foler on Windows partition

    I get The Selected Folder is invalid. you may not have permissions to write to the selected folder. when trying to set
    the folder below as my save folder.

    The full path to the folder is /windows/D/Users/Bill/Documents/LimeWire/Saved

    I can see root as bperrotta in dolphin cause I successfully chowned it.

    I su become root and chown -R bperrotta /windows or chown bperrotta Saved directory directly, before the folder. I check in Dolphin and I'm the owner.
    I go back to limewire and get the same error again. Look back through dolphin and the permissions have reverted back. I can make the limeWire Save folder on the windows partition, the save folder only when I start limewire as root. I do not believe i should have to do this what the heck is wrong?

    This has been erking me since last night.

    Bill

  2. #2
    Join Date
    Jun 2008
    Location
    Cleveland USA
    Posts
    138

    Default Re: Cannot Chown Limewire foler on Windows partition

    If the command you're entering is really chown -R bperrotta /windows then you're not changing the ownership from root. You want to enter chown -R <yourusename>:users bperrotta/windows . If you do directory list (l or ls) you'll see the name and group of the owner next to the folder name.
    Unintentionally left blank...

  3. #3

    Default Re: Cannot Chown Limewire foler on Windows partition

    Sorry but i cannot understand you.
    I added my self to the group root.

    this does not work chown -R bperrotta:root bperrotta/windows
    chown: cannot access `bperrotta/windows': No such file or directory

    chown -R bperrotta:users bperrotta/windows
    chown: cannot access `bperrotta/windows': No such file or directory

    nor does this work

    This only works but it reverts back

    chown -R bperrotta:root /windows/D/Users/Bill/Documents/LimeWire/Saved

    or this

    chown -R bperrotta:root bperrotta/windows
    chown: cannot access `bperrotta/windows': No such file or directory

  4. #4

    Default Re: Cannot Chown Limewire foler on Windows partition

    This only works but it reverts back

    chown -R bperrotta:root /windows/D/Users/Bill/Documents/LimeWire/Saved

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Cannot Chown Limewire foler on Windows partition

    You've might have windows mounted in default mode which is read-only
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  6. #6

    Default Re: Cannot Chown Limewire foler on Windows partition

    ok but i never mounted it suse did it by default and if that is the case how can i change it to read write? and is it safe to do so?
    Another thing is if it is mounted read only why is it that if i am root I can save mp3s to it? But not as a regular user
    and as a regular user i can't set it as a save directory but as root i can?

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Cannot Chown Limewire foler on Windows partition

    Quote Originally Posted by bperrotta View Post
    ok but i never mounted it suse did it by default and if that is the case how can i change it to read write? and is it safe to do so?
    Another thing is if it is mounted read only why is it that if i am root I can save mp3s to it? But not as a regular user
    and as a regular user i can't set it as a save directory but as root i can?
    I don't know why as root you can save to it. That sounds dodgy. Lets see what the propertites of the mount are first, whether it's the read-only or the read-write form. Look in the file system table to discover that. That's a text file "fstab" located at /etc/fstab. You can display the contents with this command in a console:
    cat /etc/fstab
    Here's a line from fstab in my computer showing a read/write mount of an ntfs partition:
    /dev/disk/by-id/blah_blah_-part1 /mnt/sdb1 ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    Note the bit ntfs-3g. That's the read-write driver.
    Note the bit part1. That means partition number 1. You will know which partition has windows on it in your computer. And you can identify the line corresponding to windows from partx, where x is your number (probably 1).

    Post the similar line for your windows partition back here and we'll see what access rights are contained in it's options and its driver.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  8. #8

    Question Re: Cannot Chown Limewire foler on Windows partition

    /dev/disk/by-id/scsi-SATA_WDC_WD1600AAJS-_WD-WMAS20243462-part1 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0

    Here is my fstab looks similar to yours still don't get it
    root can read-write through limewire but regular user can't maybe a limewire bug? My C and E drives have similar statements but not important because the one i want to write to is D.

  9. #9
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Cannot Chown Limewire foler on Windows partition

    So we know that the correct driver is being used. Please post the output you get in a terminal after you issue this command:
    Code:
    ls -l /windows/D/Users/Bill/Documents/
    and also this one:
    Code:
    ls -l /windows/D/Users/Bill/Documents/LimeWire/
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  10. #10
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Cannot Chown Limewire foler on Windows partition

    Sorry, don't worry about that -- I found the problem. Change your line in fstab to make the mount writeable for you. Change the tail end of it from this:
    users,gid=users,fmask=133,dmask=022,locale=en_US.U TF-8 0 0
    to this:
    defaults 0 0
    It had a coding that didn't suit your situation -- too restrictive. After you do that and reboot, there should be no need to chown because you will have full rights in there.

    And also just for my interest -- how did the mount get to be the way it was -- is that now the default that one gets when one simply installs openSUSE 11.0?
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •