Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: Wrong clock in 11.0

  1. #1

    Default Wrong clock in 11.0

    In installation process I chose correct my region and timezone. Installer show me correct time. After install I entered in system and got correct time again. But then I rebooted I got wrong time about 4 hours forward.

    'date' show me wrong time, but 'hwclock --show' show me correct time. Also if I do '/etc/init.d/boot.clock restart' time goes to correct value. But after rebooting I have it problem again.

    I tried some methods, like delete /etc/adjtime etc, but it's doesn't work.

    In 10.3 I have no any problems with clock.

  2. #2
    Join Date
    Jun 2008
    Location
    Hellas+SuSEland
    Posts
    22

    Default Re: Wrong clock in 11.0

    open with your favorite editor /etc/sysconfig/clock find the line SYSTOHC="yes" and change it to no. That way it does not write back the system time to the hardware clock at reboot or shutdown

  3. #3
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Wrong clock in 11.0

    You have probably set time to UTC and need to set it to local clock?
    Have a lot of fun!

  4. #4

    Default

    geologos, yeah I did that already, because system changed hwclock in cmos. But this didn't solve problem with system time.

    Magic31, local clock. In /etc/sysconfig/clock I have HWCLOCK="--localtime".

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,738

    Default Re: Wrong clock in 11.0

    Quote Originally Posted by geologos View Post
    open with your favorite editor /etc/sysconfig/clock find the line SYSTOHC="yes" and change it to no. That way it does not write back the system time to the hardware clock at reboot or shutdown
    I do not think this is a good idea. It is the normal way to go, either setting the clock on shutdown to local time or to zero time (the former only if you crossboot to an OS that does not know about zero time).
    In any case this setting of the hwclock can not make your system be off for four hours.

    Having said this I do not know what the real reason is (I have still 10.3 and happy with it). Check if your NTP server is OK. Check your time zone setting in YaST and try again.

    BTW if you crossboot with an MS system, did not set 'setting your HW clock to local time on shutdown' and corrected your time being in the other OS and there is four hours between local time and zero time (a long IF ... AND ... AND ....) then I do understand, but that would go wrong in 10.3 also.
    Henk van Velden

  6. #6

    Default Re: Wrong clock in 11.0

    If we do "/etc/init.d/boot.clock restart", we have correct time. Why we havnt correct time after boot?

    I add in boot.clock as first unncoment line this: 'echo "hello" >> /tmp/my.log' and check after reboot file my.log. Nothing. It dont execute in boot time.

    Then I add boot.clock script at 5 level run as "sudo ln -s /etc/init.d/boot.clock /etc/init.d/rc5.d/S99boot.clock" and rebooting. I got correct time and record in my.log. It's work.

    Then now question is why boot.clock dooesnt execute in S level in boot time?

  7. #7
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Wrong clock in 11.0

    Is there a symbolic link for boot.clock (and getclock) in /etc/init.d/boot.d?

    You could try ' insserv boot.clock ' as root to see if some link was not in place?
    Have a lot of fun!

  8. #8

    Default Re: Wrong clock in 11.0

    /etc/init.d/boot.d:
    S04boot.clock -> ../boot.clock
    S12boot.getclock -> ../boot.getclock
    Symbolic.

    insserv boot.clock - nothing.

  9. #9
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Wrong clock in 11.0

    I had a dig in bugzilla, this one could be interesting?
    https://bugzilla.novell.com/show_bug.cgi?id=385296

    See comment nr 5.

    This one could also be relevant : https://bugzilla.novell.com/show_bug.cgi?id=384254

    These should all be fixed though.. ? Curious, what did you use to install openSUSE with?

    Cheers,
    Wj
    Have a lot of fun!

  10. #10

    Default Re: Wrong clock in 11.0

    Nothing work

    I installed from iso image (openSUSE-11.0-DVD-i386.iso) booting with mini boot cd (openSUSE-11.0-NET-i386.iso). This method have also problem with language in installation time if it isnt english. But it solved yet in another thread.

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •