Results 1 to 10 of 10

Thread: 'repo-non-oss': Failed to cache repo (139).

  1. #1

    Default 'repo-non-oss': Failed to cache repo (139).

    YaST-->Software-->Online Update

    Getting error:
    There was an error in the repository initialization.
    'repo-non-oss': Failed to cache repo (139).
    History:
    - repo2solv.sh "/var/cache/zypp/raw/repo-non-oss" > "/var/cache/zypp/solv/repo-non-oss/solv"

    Output of zypper lr:
    # | Alias | Name | Enabled | Refresh
    --+-----------------------+-----------------------+---------+--------
    1 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes
    2 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No
    3 | repo-debug | openSUSE-11.0-Debug | No | No
    4 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | Yes
    5 | repo-oss | openSUSE-11.0-Oss | Yes | Yes

    If I disable the repo-non-oss repository the update works fine.

    The URL I have for the repo-non-oss repository is:
    Index of /distribution/11.0/repo/non-oss

    This has been going on for over a week.

    Do I need to use a different URL for the non-oss repository? I live in New York, United States.

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: 'repo-non-oss': Failed to cache repo (139).

    Sounds like the mirror you're being directed to is broken. Add a mirror manually.

    Mirror - openSUSE

  3. #3

    Default Re: 'repo-non-oss': Failed to cache repo (139).

    Okay, I tried almost EVERY mirror in that list, and they always give me the same error -

    Unable to create repository from mirror <whatever url i try here>

    repo-non-oss: failed to cache repo (139)

    History: -repo2solv.sh "/var/cache/zypp/raw/repo-non-oss" > "/var/cache/zypp/raw/repo-non-oss/solv"

    Try again?


    So I don't think the mirror is the problem. I can load almost all these mirrors manually with my browser - the pages all come up the same.

  4. #4
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: 'repo-non-oss': Failed to cache repo (139).

    Try deleting the cache file that it points to:
    su -c "rm -fr /var/cache/zypp/raw/repo-non-oss"

    Then refresh the repositories and see what happens.

  5. #5

    Default Re: 'repo-non-oss': Failed to cache repo (139).

    I deleted the cache file as you instructed - no problems doing this.

    I then went to YaST-->Software Repositories and used the "refresh" button. No problems doing this. (but there never was any either)

    Then I went to YaST-->Online Update and I got the same exact problem again as above except now it says it's failed to cache repo on "/var/cache/zypp/solv/repo-oss/solv"

    So... I tried your command line on repo-oss and removed that dir and ran the YaST--> Online Update again. I got the same error on repo-oss this time instead of non-repo-oss.

    I then deleted both repo-oss and non-repo-oss dirs, refreshed software repositories, then went to Online Update again. It worked for a while and then bombed out again - same error - still on solv/repo-oss/solv instead of non-repo-oss.

    Please note that this is a change from the original state. The original error was on non-repo-oss. now it's sticking on repo-oss.

    Thanks very much for your help so far, but I still can't complete an update

  6. #6
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: 'repo-non-oss': Failed to cache repo (139).

    Curious.

    Try removing both repositories, closing the software repos utility, re-open it and re-add the repositories.

    If this does not work, we'll see into cleaning the whole zypp cache and re-build it from scratch. If that doesn't work, we'll bring in the voodoo priestess

  7. #7

    Default Re: 'repo-non-oss': Failed to cache repo (139).

    Quote Originally Posted by Chrysantine View Post
    Try removing both repositories, closing the software repos utility, re-open it and re-add the repositories.
    I'm not new to Linux, but i haven't used it in about 9 years. So this whole interface is new to me.

    What I think you wanted me to do (and what I just did) was close all windows. Remove both repository directories using your commands above. (for non-oss and oss), opened repos utility, refresh, close repos utility, and then try the update again.

    Everything worked until the update, when I got the same problem with repo-oss.

    I just installed this from the download dvd about 2 weeks ago and I haven't done much in the OS yet. So if you give instructions be sure to be verbose.

  8. #8

    Default Re: 'repo-non-oss': Failed to cache repo (139).

    I've resolved this issue with the repo-update by deleting the entire /var/cache/zypp directory. This made sure every file in the cache was rebuilt and resolved all problems.

    Open a Terminal and type:

    su
    rm -rf /var/cache/zypp

    Or, with sudo enabled:

    sudo rm -rf /var/cache/zypp

    Then go to 'Software Repositories' in Yast and refresh all repositories.

  9. #9

    Default Re: 'repo-non-oss': Failed to cache repo (139).

    Quote Originally Posted by mistermartin75 View Post
    I've resolved this issue with the repo-update by deleting the entire /var/cache/zypp directory. This made sure every file in the cache was rebuilt and resolved all problems.

    Open a Terminal and type:

    su
    rm -rf /var/cache/zypp

    Or, with sudo enabled:

    sudo rm -rf /var/cache/zypp

    Then go to 'Software Repositories' in Yast and refresh all repositories.
    Thanks!

    I am having this exact problem with SUSE 11.2. Because satsolver was mentioned in my error message, I was fairly well convinced that satsolver was where the problem lay.

    Seems likely not, and that your solution will work for me too... Since I don't have the internet at home, will have to wait till I get back there to try it, but I'm betting...

  10. #10

    Default Re: Failed to cache repo (139).

    Quote Originally Posted by mistermartin75 View Post
    I've resolved this issue with the repo-update by deleting the entire /var/cache/zypp directory. This made sure every file in the cache was rebuilt and resolved all problems.

    Open a Terminal and type:

    su
    rm -rf /var/cache/zypp

    Or, with sudo enabled:

    sudo rm -rf /var/cache/zypp

    Then go to 'Software Repositories' in Yast and refresh all repositories.
    It appears that if any of the files in cache/zypp/*/* become damaged the entire update process halts with a script message about broken pipe in script during update and another regarding the checksum so no files in cache can be updated.

    This appears identically in 11.1 as well so I should imagine this is a 11.X issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •