Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: soundcard will only work after alsa restart

  1. #1

    Default soundcard will only work after alsa restart

    It seems that I am encountering a rather common problem: my soundcard seems properly configured and all the modules are loaded, but it stays mute until the alsa modules are reloaded. This can happen by:
    running alsaconfig as root,
    /etc/init.d/alsasound restart,
    deleting and reconfiguring the soundcard via yast,
    ...

    When I reboot the system, the problem reoccurs.

    My soundcard is an intel 82801H HD audio controller. The OS is Suse10.1.

    Please help.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: soundcard will only work after alsa restart

    Quote Originally Posted by tian_b View Post
    It seems that I am encountering a rather common problem: my soundcard seems properly configured and all the modules are loaded, but it stays mute until the alsa modules are reloaded. .
    Can you also achieve the same, immediately after a reboot, by typing in an xterm/konsole :
    rcalsasound restart
    and test your sound.

    If that works, then a work around (I don't know a proper fix) is to put "rcalsasound restart" in an appropriate location where it is run upon booting. Perhaps, if "rcalsasound restart" works for restoring your sound, save it in the file "/etc/init.d/boot.local" . Test if that works.

    Others may know of a better file location, or even know of a superior fix.

  3. #3

    Default Re: soundcard will only work after alsa restart

    That works! I hear Suse's login sound and everything that follows. Thank you for the advice.

    (Btw, I replaced 'rcalsasound restart' with 'rcalsasound reload'.)

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: soundcard will only work after alsa restart

    I encountered this problem too in 10.3 with a different sound card. I think it has to do with the start of the alsasound service, it is started too early or something. I worked around it by having a cron job restart the service just before I need to use it (for some scheduled recordings). I haven't checked if it's fixed in 11.0.

  5. #5
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    183

    Default I have the problem in 11.0; rcalsasound does not help

    I also have that problem in OpenSUSE 11.0: after a reboot I lose the sound. In my case rcalsasound restart doesn't get it back, but alsaconf does. So there must be something missing in rcalsasound that's present in alsaconf.

  6. #6
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    183

    Default Reloading via Yast gets sound back

    I also discovered that if I go into Yast / Hardware / Sound, delete the card, and reinstall it, the sound comes back.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Reloading via Yast gets sound back

    Quote Originally Posted by pwabrahams View Post
    I also have that problem in OpenSUSE 11.0: after a reboot I lose the sound. In my case rcalsasound restart doesn't get it back, but alsaconf does. So there must be something missing in rcalsasound that's present in alsaconf.
    Quote Originally Posted by pwabrahams View Post
    I also discovered that if I go into Yast / Hardware / Sound, delete the card, and reinstall it, the sound comes back.
    Please pardon my inquisitive nature, but I am rather skeptical that this is the entire story.

    My thinking/speculation is this: If your mixer is reset everytime you boot, then running "rcalsasound restart" or "rcalsasound reload" would not likely help your mixer setting.

    Hence by removing and re-installing your sound card set up, you could be killing the proverbial fly with a sludgehammer.

    I recommend you check to see if this is a problem with your mixer being reset every boot. Do this by setting up your mixer such that you have sound. Then in a konsole with root permissions type: alsactl store

    Then reboot, and check your sound. And if your sound does not work, do NOT run alsaconf, nor YaST, but instead, go into your mixer and see if this is a mixer problem.

  8. #8
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    183

    Default alsactl store did the trick

    I tried alsactl store and that solved the problem. I don't think it was a mixer problem, though, because I did check the mixer settings even when I wasn't getting sound, and they looked OK. Whatever it was, I'm past it now, and I hope it won't come back.

  9. #9
    vinnie01 NNTP User

    Smile Re: soundcard will only work after alsa restart

    Hi all

    I had this problem with SUSE 11.

    I adjusted the Volume to what I wanted it and read from elsewhere
    if you type the commands in the terminal. The filenames dont really need to be the same well if you cant be bothered to type u can copy/paste it.

    /usr/sbin/alsactl store -f /etc/asound.state_good

    and Add this to the /etc/init.d/boot.local

    /usr/sbin/alsactl restore -f /etc/asound.state_good

    and reboot the system and make sure alsa is done before boot.local

    Either log in to a console and play a sound or log in to the Gui and wait for start up sound

    Vincent

  10. #10
    geronimocalhoun NNTP User

    Default Re: soundcard will only work after alsa restart

    Ok gents I am not an extreme newb to linux. However, I seem to be running into a problem that a lot of you share. My intel 82801G ICH7 sound card loses sound after reboot. Once I delete the sound card from yast and then reconfigure it the sound will be back on after a reboot. I read the post about the alsactl store command once you get the sound up and running properly.... my question is what if this does not solve the issue? Also, the issue is not with the mixer because the mixer is displaying the settings and everything is correct. Now, I would like everyone to keep in mind that I have already worked my way through the suse sound troubleshooting tutorial and the sound comes back on until I reboot again and then nothing. How do I make the changes that running alsaconf and yast produce permanent? Don't need anyone to hold my hand but, a thorough response would be greatly appreciated.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •