Results 1 to 8 of 8

Thread: KDE won't start after changing monitor refresh rate in Yast

  1. #1
    Arie123 NNTP User

    Default KDE won't start after changing monitor refresh rate in Yast

    Hi,

    As a newbie Suse user I was fiddling around with openSuse 11.0 settings to investigate the possibilities and see if the already sweet eye-candy could be made to taste even sweeter.

    When I discovered that my monitor was set at 60Hz and knowing that it is actually designed to refresh at 75Hz, I decided to change it (the horizontal refresh rate). However, after rebooting I didn't notice any difference, whereas I do notice a big improvement when switching from 60 to 75Hz using other operating systems, such as Windows XP and Ubuntu 8.04. Rather stupidly, I then decided to also change the vertical refresh rate, which was set at 30 to 60 KHz, to 75 KHz, all this without testing it out and just clicked on 'save settings'.

    Anyway, now KDE will not start up and I'm able to just log into the terminal. So, now I can enjoy all of openSuse from just the terminal, which is a rather limited experience for a Linux newbie, even though it tells me 'To have a lot of fun' after logging in, which is very friendly of course.

    My questions:
    - can I change the refresh rate back to the original settings from within the terminal?

    or

    - should I reinstall using the LiveCD? (BTW: Installation went rather smoothly, much smoother than with Ubuntu)

    Thanks!

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: KDE won't start after changing monitor refresh rate in Yast

    On 07/04/2008 Arie123 wrote:
    > My questions: - can I change the refresh rate back to the original
    > settings from within the terminal?


    Login as root on the console, then
    sax2 -r
    and try again.

    What monitor and video card do you use (brand, model)?

    Uwe

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,317
    Blog Entries
    15

    Default Re: KDE won't start after changing monitor refresh rate in Yast

    On Fri, 04 Jul 2008 13:48:47 GMT
    Uwe Buckesfeld <u.buckesfeld@gmx.de> wrote:

    > On 07/04/2008 Arie123 wrote:
    > > My questions: - can I change the refresh rate back to the original
    > > settings from within the terminal?

    >
    > Login as root on the console, then
    > sax2 -r
    > and try again.
    >
    > What monitor and video card do you use (brand, model)?
    >
    > Uwe

    Hi
    Then once it's all ok, make a backup copy of the /etc/X11/xorg.conf
    file ;-)

    --
    Cheers Malcolm (Linux Counter #276890)
    SLED 10.0 SP2 x86_64 Kernel 2.6.16.60-0.23-smp
    up 3 days 21:04, 1 user, load average: 0.20, 0.18, 0.15
    GPU GeForce 8600 GTS Silent - Driver Version: 173.14.09


  4. #4
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: KDE won't start after changing monitor refresh rate in Y

    At the command line prompt, switch to root and run sax2, thus:

    Code:
    >su
    <enter password>
    #sax2
    That will start the YaST module for setting up your graphics card and monitor. Click the Change button for monitor, go to Sync Frequencies tab, enter the values. Generally sax will have filled in a range for both horizontal and vertical; you can tighten that down to specific a specific frequency by placing the same value (e.g., 60) in both the start and end range boxes. BUT be sure you know what you are doing! You can fry a monitor (also with Windows) by forcing too high a frequency, especially a laptop or LCD. After making the change, reboot.

    Before doing this, you might want to check the X server log for error messages, may give some insight. To scroll through the log, do:

    Code:
    #more /var/log/Xorg.0.log
    If sax2 does not run, the changes can be made manually from the command line. Post back if the above didn't work, and we'll provide instructions.

  5. #5
    Arie123 NNTP User

    Default Re: KDE won't start after changing monitor refresh rate in Y

    Thanks, guys, for the quick response!

    My monitor is an old Dell 15" e151fp (or something like that, I'm at work right now) and was correctly identified by openSuse and my graphics card is an equally ancient nvidia GeForce4 MX 420 (if I'm not mistaken). I still have to update the drivers for this card (which can be done quite simply through Yast I noticed), but this can only be done after I can boot into KDE again and get my wireless connection working....

  6. #6
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: KDE won't start after changing monitor refresh rate in Y

    The above to re-set your frequency may do the trick. But if it looks like you will need to have the nvidia proprietary driver, it can be downloaded and installed without YaST, from the command line. Since your wireless is not set up yet, you would have to download to another machine and copy the files to a CD. The installation files are .rpm's, only accessible from nvidia using ftp. They are at ftp://download.nvidia.com/opensuse/11.0/. I'm pretty sure your card uses the driver which is *not* the G01; you can verify this on the nvidia site. (There is an alternate installation method available to, an installation script from nvidia that compiles the driver, but you probably don't want to consider that at this time.)

  7. #7
    Arie123 NNTP User

    Default Re: KDE won't start after changing monitor refresh rate in Y

    Thanks, guys, KDE is up and running again!

  8. #8
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: KDE won't start after changing monitor refresh rate in Y

    Congratulations!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •