Results 1 to 6 of 6

Thread: Can't play .mp3 in Amarok

  1. #1

    Default Can't play .mp3 in Amarok

    Hello,

    I'm using a dual OS of openSUSE 10.2 and XP. The music folder is on the XP harddrive. When I try to play in Amarok, it says XINE can't play .mp3 and suggests me to change to other engines. But I can't find any other engine in the configure panel. Anyone could help for this newbie's question? Thanks a lot!

    Seb

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Can't play .mp3 in Amarok

    Quote Originally Posted by sebyan View Post
    I'm using a dual OS of openSUSE 10.2 and XP. The music folder is on the XP harddrive. When I try to play in Amarok, it says XINE can't play .mp3 and suggests me to change to other engines. But I can't find any other engine in the configure panel.
    Please read our stickie in the multimedia section:
    Welcome to multimedia sub-area - openSUSE Forums

    mp3 is a proprietary format. Support for mp3 does not come with openSUSE as boxed by Novell/SuSE-GmbH. It is, though, very easy to setup with 3rd party packaged applications.

    Read the stickie.

    The setup your respositories for openSUSE-10.2 (per this URL):
    Repositories/10.2 - openSUSE-Community
    being certain to have/add OSS, NON-OSS, Update and Packman repositories.

    Then replace your SuSE-GmbH packaged amarok and xine-lib with the packman packaged:
    * amarok
    * libxine1
    * xine-ui
    * mad

  3. #3

    Default Re: Can't play .mp3 in Amarok

    Quote Originally Posted by oldcpu View Post
    Please read our stickie in the multimedia section:
    Welcome to multimedia sub-area - openSUSE Forums

    mp3 is a proprietary format. Support for mp3 does not come with openSUSE as boxed by Novell/SuSE-GmbH. It is, though, very easy to setup with 3rd party packaged applications.

    Read the stickie.

    The setup your respositories for openSUSE-10.2 (per this URL):
    Repositories/10.2 - openSUSE-Community
    being certain to have/add OSS, NON-OSS, Update and Packman repositories.

    Then replace your SuSE-GmbH packaged amarok and xine-lib with the packman packaged:
    * amarok
    * libxine1
    * xine-ui
    * mad
    Many thanks for your detailed instruction. The problem is solved and I can use Amarok smoothly now.

    Seb

  4. #4

    Default Re: Can't play .mp3 in Amarok

    Packman supplies w32codec-all, download this and everything with Amarok goes well.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Can't play .mp3 in Amarok

    Quote Originally Posted by peerlaan View Post
    Packman supplies w32codec-all, download this and everything with Amarok goes well.
    peerlaan, w32codec-all is a great package, but it doesn't help mp3 in amarok.

  6. #6
    Join Date
    Jan 2008
    Location
    Kenton, TN USA
    Posts
    1,023

    Default Re: Can't play .mp3 in Amarok

    Thread moved to Multimedia
    Last edited by kastorff; 05-Jul-2008 at 17:30.
    Keith Kastorff

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •