Results 1 to 5 of 5

Thread: Opensuse 11.0 - yast firewall not forwarding ports

  1. #1
    girdance NNTP User

    Default Opensuse 11.0 - yast firewall not forwarding ports

    I'm a major newb to linux(would rate my proficiency in the negatives), so forgive me if this has been asked a million times, I've exhausted my google skills for today.

    I set up port forwards for my external zone in the yast firewall. They show in the summary. Just to be sure I set them on the wireless router as well. The ports show open on my windows lan computer, but blocked on my laptop using opensuse 11.0 - gnome.

    I can connect fine, and see myself connected through the router, mozilla works fine. I just can't get the ports to actually open (for things like azureus) for the life of me...

    I haven't bothered trying to network the two computers together due to security concerns from the desktop.

    Any help would be greatly appreciated, and Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    Hellas+SuSEland
    Posts
    22

    Default Re: Opensuse 11.0 - yast firewall not forwarding ports

    Open firewall through yast go to custom rules. Select external zone and then add the ip you wish and the ports you like. Destination and source ports can be the same. Hope this helps

  3. #3
    girdance NNTP User

    Default Re: Opensuse 11.0 - yast firewall not forwarding ports

    Thanks for the quick reply ... That's what I've set up so far, and the ports are still blocked. I went a little overkill on it as well when my initial settings didn't take.

    More info:
    Dell inspiron 9300
    gnome desktop opensuse 11.0
    wireless network conx with 128 hex WEP
    Router set to assign static ip for each mac on connection (360's, desktop, laptop)

    For all purposes the firewall says the ports are open, but they aren't. I set them in "Allowed Services > Advanced" and added the custom rules, I've even tried adding source and destination separately - but with the below firewall summary they are still being blocked.

    Firewall Starting
    • Enable firewall automatic starting
    • Firewall starts after the configuration gets written
    Internal Zone
    • No interfaces assigned to this zone.
    Demilitarized Zone
    • No interfaces assigned to this zone.
    External Zone
    Interfaces
    • eth0
    • BCM4401-B0 100Base-TX / eth1
    • 'any' Any unassigned interface will be assigned to this zone.
    Open Services, Ports, and Protocols
    • TCP Ports: 32732:32734
    • UDP Ports: 32732:32734
    Custom Rules
    • Network: 0/0, Protocol: TCP, Destination port: 32732:32734, Source port: All
    • Network: 0/0, Protocol: UDP, Destination port: 32732:32734, Source port: All
    • Network: 0/0, Protocol: TCP, Destination port: All, Source port: 32732:32734
    • Network: 0/0, Protocol: UDP, Destination port: All, Source port: 32732:32734

    When the uPnP plugin in Azureus is enabled, the port still shows blocked-However the port that I use for utorrent-31833-on the windows desktop (with uPnP) is open on this computer even though I haven't touched the firewall for it. If I disable uPnP and manually set up the ports to forward on my router, it shows blocked, also shows blocked if I leave it enabled and set up to forward. If I set the router to DMZ zone for this computer, they are still showing as blocked...

    I'm not really used to having to ask for computer help-as I've become everyone's 'go to' for windows based systems-so I'm feeling pretty dense at the moment... Have I missed something very obvious in general network settings, or is this just out of the ordinary?

    canyouseeme.org results: Error: I could not see your service on 99.236.126.201 on port (32732)
    Reason: Connection refused

    I was hoping to be able to network this into either my or my hubbies 360... But I'm thinking that may be far far off on the horizon!

  4. #4
    Join Date
    Jun 2008
    Location
    Hellas+SuSEland
    Posts
    22

    Default Re: Opensuse 11.0 - yast firewall not forwarding ports

    Code:
    Network: 0/0, Protocol: TCP, Destination port: 32732:32734, Source port: All
    Try network 192.168.1.254 or whatever your router Ip is, and source port 32732:32734. leave destination port as is. Also, if external zone does not work try internal zone.

  5. #5
    girdance NNTP User

    Default Re: Opensuse 11.0 - yast firewall not forwarding ports

    Quote Originally Posted by geologos View Post
    Code:
    Network: 0/0, Protocol: TCP, Destination port: 32732:32734, Source port: All
    Try network 192.168.1.254 or whatever your router Ip is, and source port 32732:32734. leave destination port as is. Also, if external zone does not work try internal zone.
    Wow... 0/0 is supposed to be all... But for some reason entering in the router's ip did do the trick. Thanks a lot!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •