Results 1 to 4 of 4

Thread: ath_pci/ath5k

  1. #1

    Default ath_pci/ath5k

    Hi... i have an atheros card, lspci shows this:

    03:0a.0 Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor (rev 01)

    I have some problems with it... about stability of the connection
    If I use the new madwifi driver ath5k it detects well my card, connects ok to the wireless lan, but every 5 or 10 mins it disconnects, which made my upgrades and downloads broke...

    Then i tried using ath_pci (madwifi-kmp-default), the old driver and its little bit more stable, but it keeps me disconnecting randomly, not as often as ath5k, but it does.

    I used ath_pci with opensuse 10.2 and it was ok... never had a problem. Now I have this problem with opensuse 11

    Where can i see a log that shows me why it disconnects, i also think its my router... how can i know where the problem is?


  2. #2
    Join Date
    Jan 2008
    U.K East Anglia

    Default Re: ath_pci/ath5k

    have you tried the madwifi drivers from here Index of /repositories/home:/schmolle1980/openSUSE_11.0/i586

    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  3. #3
    rossjudson NNTP User

    Default Re: ath_pci/ath5k

    I've had some oddness with WPA2 and TKIP. Forcing the adapter to use nothing but AES and WPA2 seems to have fixed it.

  4. #4

    Default Re: ath_pci/ath5k

    i can confirm issue only comes with AES or WPA2... so i had to rollback to ath_pci

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts