Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: No USB Sound SUSE 11.0

  1. #1

    Default No USB Sound SUSE 11.0

    I have installed a clean install of 11.0 from 10.3. I'm using BOSE usb speakers that worked fine under 10.3 and also Vista which I can dual boot to.
    I have gone through the audio troubleshooting and the usb audio seems to be detected but there is no sound. I checked Yast/sound and it shows card model as USB Audio, when I look at "other"/volume, there is no sound control shown and when I "test" Master Volume there is no sound.
    I ran the following script
    wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh

    output here general pastebin - howard - post number 1061376

    Then this

    su -c 'wget -O tsalsa wget http://home.cfl.rr.com/infofiles/tsalsa && bash tsalsa'

    output here:
    tsalsa.txt - nopaste.com (beta)

    Any help would be greatly appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego
    Posts
    58

    Default Re: No USB Sound SUSE 11.0

    I had the same problem with a Plantronics headset that worked fine in OpenSuSE 10.3. I solved by switching everything through the OSS server. Not a perfect solution but it seems to work. Just have to specify to the program to use /dev/dsp1.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No USB Sound SUSE 11.0

    Quote Originally Posted by madbeader View Post
    I have installed a clean install of 11.0 from 10.3. I'm using BOSE usb speakers that worked fine under 10.3 and also Vista which I can dual boot to.
    Do you have alsa-firmware installed?

    Have you tried running "alsaconf" with root permissions ? Does user root have sound?

    What are you using as a sound test? Try:
    speaker-test -Dplug:front -c2 -l5 -twav

    I find your mixer settings confusing. Do you have 2 cards?
    Code:
    Amixer contents for card 1 [Audio] _____________________________________        
    amixer set 'PCM',0 76% on        
    
    Amixer contents for card 2 [U0x46d0x8d7] _____________________________________        
    amixer set 'Mic',0 Mono: Capture 0 0% on        
    amixer set 'Auto Gain Control',0 off
    What happens when you set "auto gain control" ON ?

    Can you post the contents of your /etc/modprobe.d/sound file after running "alsaconf". ie
    cat /etc/modprobe.d/sound

    Also, post output of:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2


    Have you tried creating a custom .asoundrc file to switch on your USB device? ie under /home/your-user-name with a text editor create a text file called .asoundrc and save the following contents in that file:
    Code:
    usb.default
    # usb.default begins ###
    pcm.!default {
    type hw
    card 0
    }
    ctl.!default {
    type hw
    card 0
    }
    # usb.default ends ###
    then restart alsa with rcalsasound restart and try that sound test. DON'T turn up you sound too loud. You don't want to blow your speakers in case we get lucky.

    Failing that, try for card-1
    Code:
    usb.default
    # usb.default begins ###
    pcm.!default {
    type hw
    card 1
    }
    ctl.!default {
    type hw
    card 1
    }
    # usb.default ends ###
    then restart alsa with rcalsasound restart and try that sound test.

  4. #4

    Default Re: No USB Sound SUSE 11.0

    Thanks for the help'
    I have an onboard sound card that is disabled in the bios so my only sound is through my usb speakers.

    alsaconf: "no supported pnp or pci card found"

    Sound Test output:
    speaker-test 1.0.16

    Playback device is plug:front
    Stream parameters are 48000Hz, S16_LE, 2 channels
    WAV file(s)
    ALSA lib pcm.c:2144snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
    Playback open error: -2,No such file or directory
    ALSA lib pcm.c:2144snd_pcm_open_noupdate) Unknown PCM cards.pcm.front
    Playback open error: -2,No such file or directory

    output: cat /etc/modprobe.d/sound

    options snd slots=snd-usb-audio
    # uniq.unknown_key:USB Audio
    alias snd-card-0 snd-usb-audio
    howard@linux-6abs:~>

    output: rpm -qa | grep alsa

    alsa-plugins-pulse-32bit-1.0.16-57.1
    alsa-oss-32bit-1.0.15-48.1
    cairo-dock-alsaMixer-1.6.0.2-2.pm.20080621
    alsa-plugins-1.0.16-57.1
    alsa-firmware-1.0.16-24.1
    alsa-1.0.16-39.1
    alsa-plugins-pulse-1.0.16-57.1
    alsa-oss-1.0.15-48.1
    gmerlin-alsamixer-0.3.7-0.pm.1
    alsa-utils-1.0.16-35.1
    alsa-tools-1.0.16-47.1
    alsamixergui-0.9.0rc1-705.1

    ouput rpm -qa | grep pulse:

    alsa-plugins-pulse-32bit-1.0.16-57.1
    libpulse0-32bit-0.9.10-26.1
    alsa-plugins-pulse-1.0.16-57.1
    libpulse0-0.9.10-26.1

    output rpm -q libasound2:

    libasound2-1.0.16-39.1

    Thanks for yor help

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No USB Sound SUSE 11.0

    Quote Originally Posted by madbeader View Post
    alsaconf: "no supported pnp or pci card found
    This surprises me. Its very rare alsaconf gives such an error.

    Can you type:
    dmesg > dmesg.txt
    and post the dmesg.txt file to general pastebin - simplified internet collaboration

    Quote Originally Posted by madbeader View Post
    output: cat /etc/modprobe.d/sound
    Code:
    options snd slots=snd-usb-audio
    # uniq.unknown_key:USB Audio
    alias snd-card-0 snd-usb-audio
    This is important as it notes your usb sound card as being snd-card-0. Hence the .asoundrc file that I provided is likely the one with "card 0".

    Quote Originally Posted by madbeader View Post
    output: rpm -qa | grep alsa
    alsa-firmware-1.0.16-24.1
    Have you rebooted since you installed alsa-firmware? If not, please do so.

    Quote Originally Posted by madbeader View Post
    ouput rpm -qa | grep pulse:

    alsa-plugins-pulse-32bit-1.0.16-57.1
    libpulse0-32bit-0.9.10-26.1
    alsa-plugins-pulse-1.0.16-57.1
    libpulse0-0.9.10-26.1
    Try removing these 4 apps. Reboot, and try your sound again.

    Finally, searching the alsa web site for the snd-usb-audio kernel module (ie the USB generic driver), I note a lot of updates to the USB generic driver in 1.0.17 RC1 and 1.0.17 RC2 of alsa. Hence it might be worth while trying an alsa update. So update your alsa from a xterm/konsole with root permissions with (follow the EXACT sequence):
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia
    Code:
    zypper install alsa alsa-utils alsa-tools alsa-firmware libasound2
    Code:
    zypper rr multimedia
    Code:
    zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0/ multimedia
    Code:
    zypper install alsa-driver-kmp-default
    Code:
    zypper rr multimedia
    Then reboot, and test your audio again (per the test I recommended). Also try running in a konsole with root permissions 'alsaconf' again. Test your audio. Check your mixer.

  6. #6

    Default Re: No USB Sound SUSE 11.0

    Thanks for your help.
    I finally have sound, I'm not sure what part of the last suggestion worked but it did.
    Now I need to figure why I don't have sound in Firefox and Amarok, one thing at a time
    Thanks again

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No USB Sound SUSE 11.0

    Quote Originally Posted by madbeader View Post
    Thanks for your help.
    I finally have sound, I'm not sure what part of the last suggestion worked but it did.
    Now I need to figure why I don't have sound in Firefox and Amarok, one thing at a time
    Thanks again
    Congratulations. I am most curious to discover what worked, but I don't want to press you on this. Perhaps when you have the chance, you could post the output of:
    rpm -qa | grep alsa
    cat /etc/modprobe.d
    and also post the contents of any /home/username/.asoundrc file.

    Reference amarok, ... please setup your repositories per the guidance here: Repositories/11.0 - openSUSE-Community in particular adding OSS, NON-OSS, Update and Packman repositories. Then replace the Novell/SuSE-GmbH amarok and xine-lib with the packman packaged versions:
    * amarok
    * libxine1
    * mad

    Reference firefox, add mplayer and mplayerplug-in. ie install:
    * mplayer
    * smplayer
    * mplayerplug-in
    If you do this after setting up your repositories as noted above, all of the dependencies will be looked after automatically for you.

    You should also install flash-player, but there may be 64-bit considerations that I can not help you with.

  8. #8

    Default Re: No USB Sound SUSE 11.0

    I was having the very same problem. Thanks to your tips it is now solved!! (I am using Microsoft Lifechat LX-3000 headset.

    The only thing I was not able to implement was the removal of:

    libpulse0-32bit-0.9.10-26.1
    libpulse0-0.9.10-26.1

    When I tried to remove them, Yast2 kept running but never finished getting ready to remove them. I guess that maybe because I have VirtualBox installed(!?).

    Thanks Again.

    Paulo Andr

  9. #9

    Default Re: No USB Sound SUSE 11.0

    Hello!

    I have the same problem with an usb audio card, it's a e-mu 0202 by creative.

    I had 2 cards, this one and another pci card.
    First i could see both of them and kmix would let me choose which one i wanted to use. the problem was that the other one was set as default, and the usb one didn't work well. for example when i logged in i had no sound, then, after several attempts to switch it on and off and changing some settings in kmix and "sound" in the yast2 i could manage to get it running. but it didn't seem to make any sense cause i had to go to the same process all over again every time i rebooted the system, so i removed the pci card because i was not using it.

    So right now the yast sees the card in the hardware information, but it still doesn't want to work.

    i've renewed the alsa firmware and installed the default kernel rpm, and it still doesn't work.

    so i wondered if you could please help me

    tell me what information to send you and i'll be gratefull if you cold help me

    thanks, alex

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No USB Sound SUSE 11.0

    Quote Originally Posted by alexqaws View Post
    I have the same problem with an usb audio card, it's a e-mu 0202 by creative.

    I had 2 cards, this one and another pci card.
    First i could see both of them and kmix would let me choose which one i wanted to use. the problem was that the other one was set as default, and the usb one didn't work well. for example when i logged in i had no sound, then, after several attempts to switch it on and off and changing some settings in kmix and "sound" in the yast2 i could manage to get it running. but it didn't seem to make any sense cause i had to go to the same process all over again every time i rebooted the system, so i removed the pci card because i was not using it.

    So right now the yast sees the card in the hardware information, but it still doesn't want to work.
    It would have been better if you had started your own thread. While tagging on to an existing thread works in some forums, it does not work particularly well in ours.

    Reference your sound problem, I should caution you that I do not own a USB sound card. I've never owned a USB sound card. So anything I might be able to offer in terms of advice is strictly theoretical, or is simply based an a hazy and possible faulty recollection of what I have read about another user posting.

    You mention kmix, so I assume you are using KDE.

    I don't understand your hardware configuration. Are you saying your mother board has no onboard sound, and you had both a PCI and a USB sound card, and that you have removed the PCI sound card, and now have only the USB device?

    Could you please put your PC into the hardware configuration you desire to have working and then run the following script when your PC is connected to the Internet. Simply copy and paste into a konsole:
    Code:
    wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'
    when prompted for a password, enter the root password. Please examine carefully the number of jacks (line in/out, mic, speaker) on your PC and enter that into the script as a plug/jack when asked. This script when complete, will give you a URL linked to a page where info on your sound configuration has been copied. Please post here that URL.

    If you do not have the program wget, then install it first so you can download/run that script.

    Also, please copy and paste the following into a konsole and post the output here:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound


    Based on the above, I "might" be able to provide a recommendation.

    Also, if you created a custom .asoundrc file, please also paste its contents to http://pastebin.ca. If you don't know what I mean by an .asoundrc file then don't bother, as clearly you did not knowingly create one.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •