Results 1 to 5 of 5

Thread: failed updates on 10.3

  1. #1
    serexia NNTP User

    Default failed updates on 10.3

    Hi

    I'm running version 10.3 and it has been a couple of weeks now the automatic updates fail to apply, meaning that after every install/reboot the fancy notification icon is still there and the number of mandatory updates that I'm supposed to install is constantly increasing. Did anybody have the same issue? And how did you solve it?

    cheers
    serena

  2. #2

    Default Re: failed updates on 10.3

    In a root console run

    zypper ref
    zypper lu
    zypper up

    This will install the updates, which in turn should fix the openSUSE updater problem.
    "Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." -- Benjamin Franklin

  3. #3
    serexia NNTP User

    Default Re: failed updates on 10.3

    thanks cygnus, but when i try zypper up i have a ton of error messages of missing dependencies:

    20 Problems:
    Problem: No valid solution found with just resolvables of best architecture.
    Problem: helix-dbus-server cannot be installed due to missing dependencies
    Problem: helix-banshee-engine-gst cannot be installed due to missing dependencies
    Problem: apache2-mod_mono cannot be installed due to missing dependencies
    Problem: apache2-mod_python cannot be installed due to missing dependencies
    Problem: evolution-sharp cannot be installed due to missing dependencies
    Problem: genisoimage cannot be installed due to missing dependencies
    Problem: gimp-unstable cannot be installed due to missing dependencies
    Problem: git-core cannot be installed due to missing dependencies
    Problem: glade-sharp2 cannot be installed due to missing dependencies
    Problem: glib-sharp2 cannot be installed due to missing dependencies
    Problem: gnome-panel cannot be installed due to missing dependencies
    Problem: gsf-sharp cannot be installed due to missing dependencies
    Problem: gtk-sharp2 cannot be installed due to missing dependencies
    Problem: icedax cannot be installed due to missing dependencies
    Problem: ldapcpplib cannot be installed due to missing dependencies
    Problem: tsclient cannot be installed due to missing dependencies
    Problem: vino cannot be installed due to missing dependencies
    Problem: eel-32bit cannot be installed due to missing dependencies
    Problem: java-1_4_2-gcj-compat cannot be installed due to missing dependencies

    Problem: No valid solution found with just resolvables of best architecture.
    With this run only resolvables with the best architecture have been regarded.
    Regarding all possible resolvables takes time, but can come to a valid result.
    Solution 1: Make a solver run with ALL possibilities.
    Regarding all resolvables with a compatible architecture.
    number, (r)etry or (c)ancel> r


    what does "make a solver run mean"?

    *s*

  4. #4

    Default Re: failed updates on 10.3

    You could try the following command as root:

    'rpmdb --rebuilddb'

    Your rpm database might be damaged. You can also issue tthe following commands as root:

    'init 1'
    This will bring Linux in its limited console mode
    'cd /tmp'
    remove everything in THIS directory

    'cd /var/tmp/'
    remove everything in THIS directory

    Please verify that you ARE in these directories!!!

    'init 5'
    Brings you back to normal graphic login screen

    Now you can do in a root console:

    'zypper refresh'
    'zypper -r update'

    Changes are great that your update will succeed.

  5. #5
    serexia NNTP User

    Default Re: failed updates on 10.3

    no Tom, the errors remain, and they are exactly the same...
    how can i find out which dependencies it is looking for?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •