XSANE Segmentation fault as non-root

Whenever I run Xsan-gimp as a non-root user, it immediately seg faults.

I tried to scan with XSANE and when I scan as root it works fine,without any issues
If I try to scan as a normal user , or with the GIMP, the system says “Segment violation”
I ran Xsane as normal user with “strace xsane >&myerror.txt” and ran “less myerror.txt”
with the following result (only last lines)
clone(child_stack=0, flags=CLONE_PARENT_SETTID|SIGCHLD, parent_tidptr=0x7fff199ceaf8) = 24157
wait4(24157, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 24157
rt_sigaction(SIGINT, {SIG_DFL}, NULL, 8) = 0
rt_sigaction(SIGQUIT, {SIG_DFL}, NULL, 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
--- SIGCHLD (Child exited) @ 0 (0) ---
shmget(0xeca86420, 4096, 0666) = 589824
shmget(0xeca86421, 4096, 0666) = 622593
shmget(0xeca86422, 4096, 0666) = 655363
shmget(0xeca86423, 4096, 0666) = 688132
shmget(0xeca86424, 4096, 0666) = 720901
shmget(0xeca86425, 4096, 0666) = 753670
shmget(0xeca86426, 4096, 0666) = 786439
shmget(0xeca86427, 4096, 0666) = 819208
shmget(0xeca86428, 4096, 0666) = 851977
shmget(0xeca86429, 4096, 0666) = 884746
shmget(0xeca8642a, 4096, 0666) = 917515
shmget(0xeca8642b, 4096, 0666) = 950284
shmat(589824, 0, 0) = ?
shmat(622593, 0, 0) = ?
shmat(655363, 0, 0) = ?
shmat(688132, 0, 0) = ?
shmat(720901, 0, 0) = ?
shmat(753670, 0, 0) = ?
shmat(786439, 0, 0) = ?
shmat(819208, 0, 0) = ?
shmat(851977, 0, 0) = ?
shmat(884746, 0, 0) = ?
shmat(917515, 0, 0) = ?
shmat(950284, 0, 0) = ?
setuid(0) = -1 EPERM (Operation not permitted)
iopl(0x3) = -1 EPERM (Operation not permitted)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
It is the default SUSE 11.0 installation, I did not change any permissions.
Has anyone an idea?