Results 1 to 3 of 3

Thread: Question about setting the host name

  1. #1
    jimbren NNTP User

    Default Question about setting the host name

    Hello--

    I'm new to OpenSuse after having used (k)ubuntu for the last 5 years. After doing a clean install of OpenSuse, I was surprised to miss an option to set the host name during the installation. I figured that it was something I had just missed, and set it to what I wanted in /etc/hosts:
    Code:
    127.0.0.2       ingsoc.site ingsoc
    This did not change the hostname as I'd expected. I tried
    Code:
     set HOSTNAME=ingsoc
    , this didn't work either.

    Finally after poking around in Yast, I set the hostname under Yast/Network Devices/Network Settings.

    Now the hostname shows from prompt as jim@ingsoc:, but when I do
    [CODE]echo $HOSTNAME, I still get the default of linux-y0bf

    So, yeah. I feel like a 'tard here. What am I missing?

    thanks,

    jimbo

  2. #2
    ab@novell.com NNTP User

    Default Re: Question about setting the host name

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Assuming it is set by you now and NOT set to get a name via DHCP have
    you tried rebooting? I THINK this is only set during bootup though I
    could easily be wrong on that.

    Good luck.





    jimbren wrote:
    | Hello--
    |
    | I'm new to OpenSuse after having used (k)ubuntu for the last 5 years.
    | After doing a clean install of OpenSuse, I was surprised to miss an
    | option to set the host name during the installation. I figured that it
    | was something I had just missed, and set it to what I wanted in
    | /etc/hosts:
    |
    | Code:
    | --------------------
    | 127.0.0.2 ingsoc.site ingsoc
    | --------------------
    |
    |
    | This did not change the hostname as I'd expected. I tried
    |
    | Code:
    | --------------------
    | set HOSTNAME=ingsoc
    | --------------------
    | , this didn't work either.
    |
    | Finally after poking around in Yast, I set the hostname under
    | Yast/Network Devices/Network Settings.
    |
    | Now the hostname shows from prompt as jim@ingsoc:, but when I do
    |
    | Code:
    | --------------------
    | echo $HOSTNAME, I still get the default of linux-y0bf
    |
    | So, yeah. I feel like a 'tard here. What am I missing?
    |
    | thanks,
    |
    | jimbo
    |
    |
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.2 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

    iD8DBQFIbGzK3s42bA80+9kRAmfEAJ9bNAlZmJos0t51GDmL1QDvNCfXUwCfQtGU
    AsfRCKEPFi37ocQhQHcBYfc=
    =VvnQ
    -----END PGP SIGNATURE-----

  3. #3

    Default Re: Question about setting the host name

    can change the host name in yast -> network devices -> network cards or edit /etc/hostnames as root

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •