Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Double boot Suse + Linux os2007

  1. #1

    Question Double boot Suse + Linux os2007

    Was using linuxos2007 and decided to add suse 10.3 . I created a new partition on the disc . Some problems happened with the hard disc (long story short) somehow Suse end up installing itself and not asking me where I wanted the bootloader ( which was going to be in the partition not to the mbr where the os2007 bootloader was). I think pclinux2007 is still there somewhere. I want to try to modify the grub menulst to add linux os and see if it gives me the option of dual boot.Have been trying to access the menulst but only get permission denied . I do not know , maybe I am using the wrong commands. I f anyone can help with this I will thank you greatly.

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Double boot Suse + Linux os2007

    Welcome to the openSUSE Forums liamkincaid25

    menu.lst is rw for root and forbidden for all else (-rw-------). To open/see it you use one of these:
    kdesu kwrite /boot/grub/menu.lst
    gnomesu gedit /boot/grub/menu.lst
    sudo cat /boot/grub/menu.lst
    and so on

    To get Grub to search for and include other kernels goto Yast --> system --> bootloader --> other --> propose new configuration
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  3. #3

    Question Re: Double boot Suse + Linux os2007

    Quote Originally Posted by swerdna View Post
    Welcome to the openSUSE Forums liamkincaid25

    menu.lst is rw for root and forbidden for all else (-rw-------). To open/see it you use one of these:
    kdesu kwrite /boot/grub/menu.lst
    gnomesu gedit /boot/grub/menu.lst
    sudo cat /boot/grub/menu.lst
    and so on

    To get Grub to search for and include other kernels goto Yast --> system --> bootloader --> other --> propose new configuration
    Thank you for your help. Your first and third suggestion worked.But now I am confused. I installed suse in dev/sda8NOw I am getting this information
    linux:~ # fdisk -l

    Disk /dev/sda: 20.0 GB, 20003880960 bytes
    255 heads, 63 sectors/track, 2432 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x0004c57d

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 1019 8185086 83 Linux
    /dev/sda2 1020 2432 11349922+ 5 Extended
    /dev/sda5 1020 1368 2803311 82 Linux swap / Solaris
    /dev/sda6 1369 1626 2072353+ 83 Linux
    /dev/sda7 1627 1757 1052226 82 Linux swap / Solaris
    /dev/sda8 1758 2432 5421906 83 Linux
    linux:~ # gnomesu gedit /boot/grub/menu.lst
    linux:~ # sudo cat /boot/grub/menu.lst
    # Modified by YaST2. Last modification on Thu Jul 3 04:55:30 BST 2008
    default 0
    timeout 8
    gfxmenu (hd0,7)/boot/message

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_HTC426020G5CE00_L6VP1U-part8 vga=0x317 resume=/dev/sda5 splash=silent showopts
    initrd /boot/initrd-2.6.22.5-31-default

    ###Don't change this comment - YaST2 identifier: Original name: linux (/dev/sda1)###
    title linux (/dev/sda1)
    root (hd0,0)
    configfile /boot/grub/menu.lst

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_HTC426020G5CE00_L6VP1U-part8 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd-2.6.22.5-31-default


    And also I am getting this

    # Modified by YaST2. Last modification on Thu Jul 3 04:55:30 BST 2008
    default 0
    timeout 8
    gfxmenu (hd0,7)/boot/message

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_HTC426020G5CE00_L6VP1U-part8 vga=0x317 resume=/dev/sda5 splash=silent showopts
    initrd /boot/initrd-2.6.22.5-31-default

    ###Don't change this comment - YaST2 identifier: Original name: linux (/dev/sda1)###
    title linux (/dev/sda1)
    root (hd0,0)
    configfile /boot/grub/menu.lst

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_HTC426020G5CE00_L6VP1U-part8 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd-2.6.22.5-31-default
    For my dual boot I read that I needed to edit the menu.lst adding something like "PSLINUXOS2007 CHAINLOADER +1" But after seeing all this I do not know where to put it ( sorry I am still quite new to linux and barelygraspping a few concepts now). Can you point me in the right direction? Thank you

  4. #4

    Question Re: Double boot Suse + Linux os2007

    I performed your last suggestion and YAST was not able to find any other kernell. So it appear that for the 12 time in the last 6 weeks my attempt at a dual configuration went south. Can you look throught my data already in this post and tell me if there is hope for a dual boot system? Thank you again.

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Double boot Suse + Linux os2007

    I suggest this:

    For the time being, live with the fact that Suse's Grub overwrote the other Linux code in the MBR, and work to improve on that.

    Backup your current menu.lst with this command in a console window:
    Code:
    sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.backup
    Then recalibrate Grub, letting Yast do the work:
    GoTo Yast --> System --> Boot Loader. The Grub configuration screen comes up with the Tab "Section Management" activated. In the lower right is a drop-down selector labelled "Other". Select from "Other" the option "Propose New Configuration" and then wait for Grub to analyse your partitions and display a new configuration. This may take a while. Important: When that finishes, activate the tab labelled "Boot Loader Installation" and select to "Boot from the Master Boot Record". [Yast will often default to booting from the root or boot partition rather than from the MBR but that's for experts.] Then click Finish to save the changes and install the reconfigured Grub into the hard drive's MBR. If you get a message that "The bootloader boot sector will be written to a floppy disk ......... don't bother with the floppy -- just click OK to proceed and install to the MBR.

    At that stage you can check to see if Suse's Grub has included PCLInux2007 in menu.lst for the bootloader by looking at the output from this console command:
    sudo cat /boot/grub/menu.lst
    Hopefully you will be able to reboot and get to PCLinux.

    If not, continue on to Suse and post the output from
    sudo cat /boot/grub/menu.lst
    Swerdna

    Reference: GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Double boot Suse + Linux os2007

    Quote Originally Posted by liamkincaid25 View Post
    I performed your last suggestion and YAST was not able to find any other kernell. So it appear that for the 12 time in the last 6 weeks my attempt at a dual configuration went south. Can you look throught my data already in this post and tell me if there is hope for a dual boot system? Thank you again.
    You must have posted while I was typing. So if you followed the EXACT steps, INCLUDING the second half about the MBR, then post the menu.lst, else redo it EXACTLY as suggested.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  7. #7

    Smile Re: Double boot Suse + Linux os2007

    Thank you for your answer. What I meant I did was this ("To get Grub to search for and include other kernels goto Yast --> system --> bootloader --> other --> propose new configuration") from your first answer. The other post I have not tried it yet. As soon as I get home I will follow your directions and post the result. Thank you for your time an help (yeah I imagined that suse overwrote the mbr as soon as I saw it was the OS that loaded upon restart , but do not know why it did not give the option of where to install the loader I guess the problems with the hard disk caused this) Thank you

  8. #8

    Default Re: Double boot Suse + Linux os2007

    Greetings once more!
    Did all the steps as you instructed but when rebooted no option for linuxos2007 appeared.The result of the menu.lst is as follow
    linux:~ # sudo cat /boot/grub/menu.lst
    # Modified by YaST2. Last modification on Thu Jul 3 10:09:43 EDT 2008
    default 0
    timeout 8
    gfxmenu (hd0,7)/boot/message

    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 10.3
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_HTC426020G5CE00_L6VP1U-part8 resume=/dev/sda5 splash=silent showopts
    initrd /boot/initrd-2.6.22.5-31-default

    ###Don't change this comment - YaST2 identifier: Original name: linux (/dev/sda1)###
    title linux (/dev/sda1)
    root (hd0,0)
    configfile /boot/grub/menu.lst

    ###Don't change this comment - YaST2 identifier: Original name: floppy###
    title Floppy
    rootnoverify (hd0,7)
    chainloader (fd0)+1

    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 10.3
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_HTC426020G5CE00_L6VP1U-part8 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd-2.6.22.5-31-default

    ###Don't change this comment - YaST2 identifier: Original name: memtest86###
    title Memory Test
    kernel (hd0,7)/boot/memtest.bin

    ###Don't change this comment - YaST2 identifier: Original name: Kernel-2.6.22.5-31-default###
    title Kernel-2.6.22.5-31-default
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.22.5-31-default root=/dev/disk/by-id/scsi-SATA_HTC426020G5CE00_L6VP1U-part8 resume=/dev/sda5 splash=silent showopts
    initrd /boot/initrd-2.6.22.5-31-default
    It seems I did something wrong.Can you make an evaluation of this and enlighten me on WTHIDW? (what the hell I did wrong) or at least if there is a chance to fix it?. I have no problem erasing the hard disk and starting from scratch , as this is a machine I am using to test linux ( boy I think this is the 10 or 12 time the dual boot goes wrong )
    Thank you for your time and help

  9. #9
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Double boot Suse + Linux os2007

    This one:
    ###Don't change this comment - YaST2 identifier: Original name: linux (/dev/sda1)###
    title linux (/dev/sda1)
    root (hd0,0)
    configfile /boot/grub/menu.lst
    looks like Suse's estimate of PCLinux. (hd0,0) is Grub-speak for sda1. Suse thinks there's a configuration stored in (h0,0)/boot/grub/menu.lst -- but that's not working. There's two things you can try. One is to add an entry below the one I quoted, an entry like this:
    title PC Linux (/dev/sda1)
    rootnoverify (hd0,0)
    chainloader (hd0,0)+1
    Try that first. You can open the file for editing with command
    Code:
    kdesu kwrite /boot/grub/menu.lst
    The other (if that fails) is to boot to PC Linux using the install media (I've no idea whether that's possible) and reinstall grub there.

    ??
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  10. #10

    Post Re: Double boot Suse + Linux os2007

    Quote Originally Posted by swerdna View Post
    This one:

    looks like Suse's estimate of PCLinux. (hd0,0) is Grub-speak for sda1. Suse thinks there's a configuration stored in (h0,0)/boot/grub/menu.lst -- but that's not working. There's two things you can try. One is to add an entry below the one I quoted, an entry like this:

    Try that first. You can open the file for editing with command
    Code:
    kdesu kwrite /boot/grub/menu.lst
    The other (if that fails) is to boot to PC Linux using the install media (I've no idea whether that's possible) and reinstall grub there.

    ??
    I performed your instructions. Upon rebooting the pclinux option
    appeared on the menu I selected it and the this message appeared "ERROR 13 INVALID OR UNSUPPORTED EXECUTABLE FORMAT"
    The las part of your post when you say to use the install media from pclinux , do you mean running it until I reach which point?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •