Results 1 to 7 of 7

Thread: Display not right with external monitor

  1. #1

    Default Display not right with external monitor

    I installed openSUSE on a laptop through an external monitor, one that I wanted to use for default (since the internal monitor is pretty messed up). It installed fine, and at the end where it listed hardware configuration it listed the external monitor as the monitor with its correct resolution and all, but when it loaded into openSUSE when the install finished the picture looks too big for the screen and the resolution also looks too low. Also, where it says "Activate 3D Acceleration" at the bottom of the window, that is grayed out.

    What do I do?

  2. #2
    andyford NNTP User

    Default Re: Display not right with external monitor

    Have you tried manually setting the resolution in Yast?

  3. #3

    Default Re: Display not right with external monitor

    Quote Originally Posted by andyford View Post
    Have you tried manually setting the resolution in Yast?
    Yes. That didn't help. The display still seems to stretch beyond the screen and appear at a low resolution. I managed to change the resolution and then in the screen alignment test page I was able to get it to the correct width, but it was still too tall, and the resolution was still off. I think it was trying to use the resolution of the laptop's screen for the external monitor, but when I tried activating the setting for dual monitors that didn't seem to help.

  4. #4
    afilep NNTP User

    Default Re: Display not right with external monitor

    Just wondering if you were able to solve the problem?

    I am having a similar issue trying to use an external monitor. Need different resolutions on the internal display and external monitor. What's the recommended procedure for getting this to work?

  5. #5

    Default Re: Display not right with external monitor

    Afilep, I haven't found a solution to my particular problem, though I just tried it in Kubuntu and the display showed up perfectly. For you, I would recommend you try plugging in the external monitor and, in the Yast display settings, setting the option for dual displays. If that doesn't help maybe you should just stick with Kubuntu for now, too, until Novell fixes this huge problem.

  6. #6

    Default Re: Display not right with external monitor

    Hi there,

    That's quite sad opensuse is not able to support external screens, or at least display the thing properly.

    Fresh opensuse 11.0 install and no was to have the display set correctly...

  7. #7

    Default Re: Display not right with external monitor

    Just wanted to post a reply in here, since I fixed my problem.

    I had exactly the same problem with having a 'too big' displayed picture for the screen. Tho, the "lenovo" screen was always coming back in sax, even if I specified thousand times that it was a DELL 20".

    You have to set up your screen, as if it's the laptop's one. Then, activate dualhead, then clone your screen to the external one. Do all the necessary updates, and the screen will display just fine !


    @1 poster : the 3d accelration box is greyed, prolly because your drivers are not properly installed. I had such prob with an ATI card. there's a 1 button installation for ATI graphic cards which is working pretty fine! you can find more info on ATI - openSUSE

    Voil !

    Cheers!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •