I'm getting the black-screen-of-death with some 3D apps and not with others

fgl_glxgears = good
Sauerbraten = good

glxgears = BSoD
Blender 3D = BSoD

Anyone have any ideas why 3D works for some of these apps and not the others?

SuSE 11, KDE 4
AMD 2800 Semperon / ATI x1900 / 1Gb RAM

AMDCCC
Software -> Driver Version 8.49.7
SOftware -> CCC Version 1.10
OpenGL -> Provider ATI Tech
OpenGL -> Renderer Radeon X1900 Series
OpenGL -> Version 2.1.7537 Release


fglrxinfo
Code:
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1900 Series
OpenGL version string: 2.1.7537 Release
glxinfo
Code:
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2

OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1900 Series
OpenGL version string: 2.1.7537 Release
xorg.conf
Code:
# /.../
# SaX generated X11 config file
# Created on: 2008-07-01T23:51:28-0700.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
        Identifier     "Layout[all]"
        Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    "Keyboard[0]" "CoreKeyboard"
        InputDevice    "Mouse[1]" "CorePointer"
        Option      "Clone" "off"
        Option      "Xinerama" "off"
EndSection

Section "Files"
        InputDevices   "/dev/gpmdata"
        InputDevices   "/dev/input/mice"
        FontPath     "/usr/share/fonts/misc:unscaled"
EndSection
Section "Module"
        Load  "dbe"
        Load  "type1"
        Load  "freetype"
        Load  "extmod"
        Load  "glx"
EndSection

Section "ServerFlags"
        Option      "AllowMouseOpenFail" "on"
        Option      "ZapWarning" "on"
EndSection
Section "Modes"
        Identifier     "Modes[0]"
        ModeLine     "1440x900" 104.6 1440 1520 1672 1904 900 901 904 931
        ModeLine     "1440x900" 85.8 1440 1488 1520 1600 900 903 909 925 +hsync -vsync
        ModeLine     "1280x960" 105.6 1280 1360 1496 1712 960 961 964 995
        ModeLine     "1280x960" 86.8 1280 1328 1360 1440 960 963 967 988 +hsync -vsync
        ModeLine     "1024x768" 81.8 1024 1080 1192 1360 768 769 772 802
        ModeLine     "1024x768" 76.2 1024 1080 1192 1360 768 769 772 800
        ModeLine     "1024x768" 69.7 1024 1080 1184 1344 768 769 772 798
        ModeLine     "1024x768" 69.5 1024 1072 1104 1184 768 771 775 796 +hsync -vsync
        ModeLine     "1024x768" 64.1 1024 1080 1184 1344 768 769 772 795
        ModeLine     "800x600" 48.9 800 840 920 1040 600 601 604 627
        ModeLine     "800x600" 45.5 800 840 920 1040 600 601 604 625
        ModeLine     "800x600" 44.0 800 848 880 960 600 603 607 622 +hsync -vsync
        ModeLine     "800x600" 42.1 800 840 920 1040 600 601 604 623
        ModeLine     "800x600" 38.2 800 832 912 1024 600 601 604 622
        ModeLine     "1440x900" 106.0 1440 1520 1672 1904 900 903 909 934 +hsync -vsync
EndSection
Section "Monitor"
        Identifier   "Monitor[0]"
        VendorName   "SAM"
        ModelName    "SAMSUNG SYNCMASTER"
        UseModes     "Modes[0]"
        DisplaySize  410        257
        HorizSync    30.0 - 81.0
        VertRefresh  43.0 - 75.0
        Option      "DPMS"
        Option      "PreferredMode" "1440x900"
EndSection
Section "Monitor"
        Identifier   "aticonfig-Monitor[0]"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection
Section "Device"

  #BusID        "1:0:0"
        Identifier  "Device[0]"
        Driver      "radeonhd"
        VendorName  "ATI"
        BoardName   "Radeon X1900"
        Option      "monitor-DVI-I_2/digital" "Monitor[0]"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
EndSection

Section "Screen"
        Identifier "Screen[0]"
        Device     "Device[0]"
        Monitor    "Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
                Depth     15
                Modes    "1440x900" "1280x960" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
                Depth     16
                Modes    "1440x900" "1280x960" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
                Depth     24
                Modes    "1440x900" "1280x960" "1024x768" "800x600"
        EndSubSection
        SubSection "Display"
                Depth     8
                Modes    "1440x900" "1280x960" "1024x768" "800x600"
        EndSubSection
EndSection
Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device     "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Section "DRI"
        Group        "video"
        Mode         0660
EndSection