Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: opensuse 11.0: Missing virtual tty like qtyp ttyp

  1. #1
    Join Date
    Jul 2008
    Location
    Dreieich, Germany
    Posts
    5

    Default opensuse 11.0: Missing virtual tty like qtyp ttyp

    Hallo,
    The virtual ttys like qtyp0/ttyp0, qtyp1/ttyp1, ... in /dev are not available in opensuse 11.0.
    Is there any chance to make opensuse 11.0 creating these ttys upon system start like 10.3 does.
    Just using "mknod" is creating the ttys but they do not work.
    I need this ttys to connect the hamradio program xnet/linuxnet to the kernel ax25.

    Best regards, Walter DL8FCL

  2. #2
    Join Date
    Jun 2008
    Location
    Vancouver, B.C.
    Posts
    61

    Default Re: opensuse 11.0: Missing virtual tty like qtyp ttyp

    Tips and solutions for SUSE Linux (please do not post questions here)

  3. #3
    Join Date
    Jul 2008
    Location
    Dreieich, Germany
    Posts
    5

    Default Re: opensuse 11.0: Missing virtual tty like qtyp ttyp

    ??????????????

    I am asking for a tip or solution. Where shall I post it, according to your "very polite" opinion Mr. policeman.

  4. #4
    Join Date
    Jan 2008
    Location
    Kenton, TN USA
    Posts
    1,023

    Default Re: opensuse 11.0: Missing virtual tty like qtyp ttyp

    Thread moved to Applications
    Keith Kastorff

  5. #5

    Default Re: opensuse 11.0: Missing virtual tty like qtyp ttyp

    Quote Originally Posted by dl8fcl View Post
    Hallo,
    The virtual ttys like qtyp0/ttyp0, qtyp1/ttyp1, ... in /dev are not available in opensuse 11.0.
    BSD-style ptys are obsolete. Unix98 ptys are allocated through /dev/ptmx, spawing /dev/pts/N.

  6. #6
    Join Date
    Jul 2008
    Location
    Dreieich, Germany
    Posts
    5

    Default Re: opensuse 11.0: Missing virtual tty like qtyp ttyp

    Hallo,

    I know that these virtual ttys are obsolete.
    But a kiss connection between kernel ax25 and xnet ((X)NET) does not work with /dev/ptmx and /dev/pts/N. These programs require a qty?/tty? or a real /dev/ttyS? link.
    These obsolete ttys are still available in opensuse 10.3 and I think they are somehow created by udevd. An entry naming these ttys is also available in openSUSE 11.0 /etc/udev/rules.d/50-udev-default.rules but they are no longer created ...
    Anyway, thank you for reading posting ...
    Best regards, Walter DL8FCL

  7. #7

    Default Re: opensuse 11.0: Missing virtual tty like qtyp ttyp

    Well, too bad. These programs are 5+ years old now and I don't see a source.

    There is a kernel-level Serial KISS driver, would that one work? AX.25 - LinuxHam has more information.

  8. #8
    Join Date
    Jul 2008
    Location
    Dreieich, Germany
    Posts
    5

    Default Re: opensuse 11.0: Missing virtual tty like qtyp ttyp

    I am using this kernel-level Serial KISS driver to connect xnet to ax25. All tries to use /dev/ptmx failed. Only /dev/pty??-/dev/tty?? or two real serial ports, connected with a null modem cable, are working.

  9. #9

    Default Re: opensuse 11.0: Missing virtual tty like qtyp ttyp

    Once you have the source to the xnet program it is easy to fix.

    What's `uname -a` giving?

  10. #10
    Join Date
    Jul 2008
    Location
    Dreieich, Germany
    Posts
    5

    Default Re: opensuse 11.0: Missing virtual tty like qtyp ttyp


    These ttys are disabled in the kernel configuration.
    So I only had to recompile the current kernel with a few virtual ttys enabled and my problem was solved.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •