Results 1 to 2 of 2

Thread: updating glib

  1. #1
    Join Date
    Jun 2008
    Location
    Madrid
    Posts
    81

    Default updating glib

    While trying to install xfce I got the message that glib >= 2.6.0 was not found. Searching on yast I only found glib-1.2.10 installed (and a glib2-2.16.3 already installed), and no newer version available.

    I downloaded glib-2.16.0 from gtk.org, and during make install I got the errors:

    Code:
    gtester.c:276: error: ARG_MAX undeclared (first use in this function)
    gtester.c:276: error: (Each undeclared identifier is reported only once
    gtester.c:276: error: for each function it appears in.)
    gtester.c:276: warning: unused variable argv
    make[4]: *** [gtester.o] Error 1
    make[4]: Leaving directory `/usr/lib/glib-2.16.0/glib'
    make[3]: *** [install-recursive] Error 1
    make[3]: Leaving directory `/usr/lib/glib-2.16.0/glib'
    make[2]: *** [install] Error 2
    make[2]: Leaving directory `/usr/lib/glib-2.16.0/glib'
    make[1]: *** [install-recursive] Error 1
    make[1]: Leaving directory `/usr/lib/glib-2.16.0'
    make: *** [install] Error 2
    not sure how to interpret or deal with this though.

    I added a certain number of repositories suggested for openSUSE11 from opensuse.org, and it may just be a matter of adding a more appropriate repository to find and install this version with YAST, but I'd like to understand a bit better what is not working. Thank you for your suggestions and tips.

  2. #2
    Join Date
    Jun 2008
    Location
    Madrid
    Posts
    81

    Default Re: updating glib

    just downloaded glib-2.16.4, and that installed without a problem..
    SuSE-12.3, Lenovo G780, 3.7.10-1.16-desktop

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •