This is essentially a bug report for Konqueror 4.0.4, 20080505 release 15.1. I installed Adobe flash-player using YaST. Flash-player works in Firefox, and not in Konqueror. Flash-player worked just fine for Konqueror in openSuSE 10.3.