Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: dependacy problems with multimedia programs

  1. #1
    Join Date
    Jun 2008
    Location
    Hertfordshire, England
    Posts
    46

    Default dependacy problems with multimedia programs

    Hi all,

    I have just installed OpenSuse 11 with KDE 3.5.9, and everything went OK.

    I am now trying to install some programs that I use

    Videomaker
    Audacity
    Streamtuner
    Streamripper
    Qdvdauthor
    etc

    and all fail with the depandancy problem

    nothing provides libmagick.so.10 needed by transcode-1.0.5-0.pm.o.i586

    is it something missing on my computer or is it something more radical.

    I read that someone was having a problem with "audacity" which means at least they managed to install it?

    Best regards Keith

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: dependacy problems with multimedia programs

    Quote Originally Posted by tinca View Post
    and all fail with the depandancy problem...is it something missing on my computer or is it something more radical.
    Have you setup your repositories? If so, please advise. If not, please read on:

    Please look at our stickie to this multimedia section:
    Welcome to multimedia sub-area - openSUSE Forums

    in particular this link:
    Repositories - openSUSE-Community

    which for 11.0 leads you here:
    Repositories/11.0 - openSUSE-Community
    which provides some very straight forward instructions on how to setup your repositories. In particular note you should add Packman.

  3. #3
    Join Date
    Jun 2008
    Location
    Hertfordshire, England
    Posts
    46

    Default Re: dependacy problems with multimedia programs

    Hi oldcpu,

    many thanks for your reply.

    The repositories that I have enabled are

    nvidia
    opensuse-dvd 11.0
    main repository (non-oss)
    main repository (oss)
    videolan
    packman
    update for 11.0
    opensuse-11-debug
    opensuse-11-oss
    opensuse-11.0-non-oss

    I hope that this information will help

    Best regards Keith

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: dependacy problems with multimedia programs

    Quote Originally Posted by tinca View Post
    The repositories that I have enabled are
    nvidia
    opensuse-dvd 11.0
    main repository (non-oss)
    main repository (oss)
    videolan
    packman
    update for 11.0
    opensuse-11-debug
    opensuse-11-oss
    opensuse-11.0-non-oss
    why two non-os, and two oss?

    I recommend you reduce this to:
    packman
    update for 11.0
    opensuse-11-oss
    opensuse-11.0-non-oss

    and remove the rest. Too many repos can cause dependency problems. The others can be added briefly an an adhoc if and when required basis.

  5. #5

    Default Re: dependacy problems with multimedia programs

    Quote Originally Posted by tinca View Post
    nothing provides libmagick.so.10 needed by transcode-1.0.5-0.pm.o.i586
    Code:
    $ wget --quiet "http://packman.links2linux.org/download/transcode/158506/transcode-1.0.5-0.pm.1.i586.rpm"
    $ rpm -qRp transcode-1.0.5-0.pm.1.i586.rpm
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(CompressedFileNames) <= 3.0.4-1
    /usr/bin/gawk
    libICE.so.6
    libSDL-1.2.so.0
    libSM.so.6
    libX11.so.6
    libXau.so.6
    libXaw8.so.8
    libXext.so.6
    libXpm.so.4
    libXt.so.6
    libXv.so.1
    liba52.so.0
    libamrnb.so.3
    libamrwb.so.3
    libavcodec.so.51
    libavutil.so.49
    libc.so.6
    libc.so.6(GLIBC_2.0)
    libc.so.6(GLIBC_2.1)
    libc.so.6(GLIBC_2.1.3)
    libc.so.6(GLIBC_2.2)
    libc.so.6(GLIBC_2.3)
    libc.so.6(GLIBC_2.3.2)
    libc.so.6(GLIBC_2.3.4)
    libc.so.6(GLIBC_2.4)
    libc.so.6(GLIBC_2.7)
    libdc1394.so.22
    libdl.so.2
    libdl.so.2(GLIBC_2.0)
    libdl.so.2(GLIBC_2.1)
    libdv.so.4
    libdvdread.so.3
    libfaac.so.0
    libfaad.so.0
    libfame-0.9.so.1
    libfreetype.so.6
    libgcc_s.so.1
    libglib-1.2.so.0
    libgsm.so.1
    libjpeg.so.62
    liblzo2.so.2
    libm.so.6
    libm.so.6(GLIBC_2.0)
    libm.so.6(GLIBC_2.1)
    libmjpegutils-1.9.so.0
    libmp3lame.so.0
    libmp4v2.so.0
    libmpeg2.so.0
    libmpeg2convert.so.0
    libogg.so.0
    libpostproc.so.51
    libpthread.so.0
    libpthread.so.0(GLIBC_2.0)
    libpthread.so.0(GLIBC_2.1)
    libpthread.so.0(GLIBC_2.2)
    libpthread.so.0(GLIBC_2.3.2)
    libpthread.so.0(GLIBC_2.3.3)
    libpvm3.so.3
    libquicktime.so.0
    libraw1394.so.8
    libstdc++.so.6
    libstdc++.so.6(CXXABI_1.3)
    libtheora.so.0
    libtheora.so.0(libtheora.so.1.0)
    libvorbis.so.0
    libvorbisenc.so.2
    libvorbisfile.so.3
    libx264.so.57
    libxcb-xlib.so.0
    libxcb.so.1
    libxml2.so.2
    libxvidcore.so.4
    libz.so.1
    rpmlib(PayloadIsLzma) <= 4.4.2-1
    Code:
    $ smart query --provides="libmagick.so.10"
    Cargando cach...
    Actualizando cach...                       ########################################################## [100%]
    
    $ smart query --requires="libmagick.so.10"
    Cargando cach...
    Actualizando cach...                       ########################################################## [100%]

    Don't ask me why it's asking about libmagick.so.10... but no package provides or requires it. Since you changed a '0' for a 'o' with "transcode-1.0.5-0.pm.o.i586"... right now the most logic thing I can think of is that you also copied wrongly "libmagick.so.10". So I recommend you to directly copy&paste the output of "zypper in transcode".

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: dependacy problems with multimedia programs

    Quote Originally Posted by RedDwarf View Post
    Don't ask me why it's asking about libmagick.so.10... but no package provides or requires it.
    Hmmm, ... I disagree with that as a global statement.

    I agree that non of the apps mentioned in this thread have rpm dependencies requiring libmagick, BUT there are rpms that DO require libmagick.

    But having typed the above, maybe you were referring only to the apps mentioned in this thread, in which case I agree with that qualification.

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: dependacy problems with multimedia programs

    Quote Originally Posted by RedDwarf View Post
    but no package provides ... it
    I don't think you mean this (as typed). I happen to have libMagick10-6.3.5.10-2 installed, and it does provide libmagick.so.10.

  8. #8

    Default Re: dependacy problems with multimedia programs

    Quote Originally Posted by oldcpu View Post
    But having typed the above, maybe you were referring only to the apps mentioned in this thread, in which case I agree with that qualification.
    I was refering to the packages available in the following repos:
    Code:
    $ smart channel --show
    [non-oss]
    type = yast2
    name = openSUSE-11.0-Non-Oss
    manual = yes
    priority = 500
    baseurl = http://download.opensuse.org/distribution/11.0/repo/non-oss/
    compressed = yes
    
    [rpm-sys]
    type = rpm-sys
    name = RPM System
    
    [oss]
    type = yast2
    name = openSUSE-11.0-Oss
    manual = yes
    priority = 500
    baseurl = http://download.opensuse.org/distribution/11.0/repo/oss/
    compressed = yes
    
    [home_RedDwarf]
    type = rpm-md
    name = RedDwarf's Home Project
    priority = 10000
    baseurl = http://download.opensuse.org/repositories/home:/RedDwarf/openSUSE_11.0
    /
    
    [videolan]
    type = rpm-md
    name = VideoLan Repository
    priority = 5
    baseurl = http://download.videolan.org/pub/videolan/vlc/SuSE/11.0/
    
    [games]
    type = rpm-md
    name = openSUSE BuildService - Games
    priority = 300
    baseurl = http://download.opensuse.org/repositories/games/openSUSE_11.0/
    
    [updates]
    type = rpm-md
    name = openSUSE-11.0-Updates
    priority = 500
    baseurl = http://download.opensuse.org/update/11.0/
    
    [packman]
    type = rpm-md
    name = Packman Repository
    priority = 10
    baseurl = http://ftp.skynet.be/pub/packman/suse/11.0/
    
    [nvidia]
    type = rpm-md
    name = NVIDIA Repository
    priority = 5000
    baseurl = http://download.nvidia.com/opensuse/11.0/
    
    [debug]
    type = yast2
    name = openSUSE-11.0-Debug
    disabled = yes
    priority = 500
    baseurl = http://download.opensuse.org/distribution/11.0/repo/debug/
    compressed = yes
    
    [education]
    type = yast2
    name = openSUSE Education
    priority = 300
    baseurl = http://www.opensuse-education.org/download/repo/1.0/11.0/
    compressed = yes
    
    [openSUSE_Tools]
    type = rpm-md
    name = openSUSE.org tools
    priority = 300
    baseurl = http://download.opensuse.org/repositories/openSUSE:/Tools/openSUSE_11.                              0/
    
    [wine]
    type = rpm-md
    name = BuildService de openSUSE - Revisiones CVS de Wine
    priority = 5000
    baseurl = http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.                              0/
    That's what smart query --[provides|requires]="libmagick.so.10" was about.

  9. #9

    Default Re: dependacy problems with multimedia programs

    Quote Originally Posted by oldcpu View Post
    I happen to have libMagick10-6.3.5.10-2 installed, and it does provide libmagick.so.10.
    That's a 10.3 package. And yes, transcode from 10.3 requires libmagick.so.10... so I suppose tinca is using 10.3 Packman repository on openSUSE 11.0.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: dependacy problems with multimedia programs

    Quote Originally Posted by RedDwarf View Post
    That's what smart query --[provides|requires]="libmagick.so.10" was about.
    Investigating this, makes me think that tinca had 10.3 repos in their 11.0.

    I see /usr/lib/libGraphicsMagick.so.1.0.11 is provided by libGraphicsMagick1-1.1.11-29.1 which comes in 11.0.

    libGraphicsMagick.so.1.0.10 is a library typically associated with openSUSE-10.3.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •