Page 1 of 5 123 ... LastLast
Results 1 to 10 of 47

Thread: And again: No Sound on Thinkpad T61 under openSUSE 11.0

  1. #1
    Join Date
    Jun 2008
    Location
    Gelnhausen, approx. 50 km east of Frankfurt
    Posts
    89

    Question And again: No Sound on Thinkpad T61 under openSUSE 11.0

    Hi,

    since installing openSUSE 11.0 on my Lenovo Thinkpad T61 there is no sound.

    The machine uses an Intel 82801 using audio codec AD1984 and alsa 1.0.15.

    The openSUSE support database says I need to modify the codec options in
    /etc/modprobe.d/sound.

    The SDB also says I would find these options in "ALSA-Configuration.txt"
    in "/usr/src/linux/Documentation/sound/alsa".

    I can't find this file on my system.

    Anybody know this file? Where can I find the appropriate codec options for AD1984 on a Lenovo Thinkpad T61.

    Cheers.

    H.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: And again: No Sound on Thinkpad T61 under openSUSE 11.0

    Quote Originally Posted by hgeis View Post
    since installing openSUSE 11.0 on my Lenovo Thinkpad T61 there is no sound. The machine uses an Intel 82801 using audio codec AD1984 and alsa 1.0.15. The openSUSE support database says I need to modify the codec options in /etc/modprobe.d/sound. The SDB also says I would find these options in "ALSA-Configuration.txt" in "/usr/src/linux/Documentation/sound/alsa". I can't find this file on my system. Anybody know this file? Where can I find the appropriate codec options for AD1984 on a Lenovo Thinkpad T61.
    I'm not at a Linux PC, and I don't have this memorized, so I can't point out the file precise location to you. Typically it comes with one's kernel documentation, or with the alsa tarball/documentation (for cases where one downloads an updated alsa tarball).

    If you search the web (google) for ALSA-Configuration.txt its very easy to find. For example:
    Linux Kernel Documentation :: sound : alsa : ALSA-Configuration.txt

    ... of course there is always the question, for which version of ALSA does this specific ALSA-Configuration.txt file apply. I think the one I linked is for the stable 1.0.16 of ALSA. Hence for your AD1984:
    Code:
    926		AD1984
    927		  basic		default configuration
    928		  thinkpad	Lenovo Thinkpad T61/X61
    929		  dell		Dell T3400
    which means you need to insert "model=thinkpad" in the appropriate place in your /etc/modprobe.d/sound file. If you post the contents of that file here, I can make some suggestions (re: the syntax). to get the file contents, simply type:
    cat /etc/modprobe.d/sound

  3. #3
    Join Date
    Jun 2008
    Location
    Gelnhausen, approx. 50 km east of Frankfurt
    Posts
    89

    Default Re: And again: No Sound on Thinkpad T61 under openSUSE 11.0

    Hi there oldcpu,

    Thanks for your help again. I've already modified /etc/modprobe.d/sound like that and when doing a rcalsasound start I get these error messages.

    Can you make something out of that? Something with the kernel?

    linux-vc38 2.6.25.5-1.1-default

    WARNING: Error inserting snd (/lib/modules/2.6.25.5-1.1-default/kernel/sound/core/snd.ko):
    Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting snd_hwdep (/lib/modules/2.6.25.5-1.1-default/kernel/sound/core/snd-hwdep.ko):
    Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting snd_timer (/lib/modules/2.6.25.5-1.1-default/kernel/sound/core/snd-timer.ko):
    Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting snd_pcm (/lib/modules/2.6.25.5-1.1-default/kernel/sound/core/snd-pcm.ko):
    Unknown symbol in module, or unknown parameter (see dmesg)
    FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.25.5-1.1-default/kernel/sound/pci/hda/snd-hda-intel.ko):
    Unknown symbol in module, or unknown parameter (see dmesg)
    ..failed

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: And again: No Sound on Thinkpad T61 under openSUSE 11.0

    Quote Originally Posted by hgeis View Post
    Thanks for your help again. I've already modified /etc/modprobe.d/sound like that and when doing a rcalsasound start I get these error messages.
    Please, can you provide the output of:
    cat /etc/modprobe.d/sound

  5. #5
    Andrew C Taubman NNTP User

    Default Re: And again: No Sound on Thinkpad T61 under openSUSE 11.0

    I had this on my t61p under SLED 10.2, all I had to do was run alsaconf
    once and it works fine now.
    --
    Andrew C Taubman
    Novell Support Forums Volunteer SysOp
    http://forums.novell.com/
    (Sorry, support is not provided via e-mail)

    Opinions expressed above are not
    necessarily those of Novell Inc.

  6. #6
    Join Date
    Jun 2008
    Location
    Gelnhausen, approx. 50 km east of Frankfurt
    Posts
    89

    Unhappy And again: No Sound on Thinkpad T61 under openSUSE 11.0

    Hi,

    Here are the details: content /etc/modprobe.de/sound, hwinfo --sound and the installed ALSA packages.

    /etc/modprobe.d/sound

    options snd slots=snd-hda-intel
    # u1Nb.iJWhLrosxI5:ThinkPad T61
    alias snd-card-0 snd-hda-intel

    hwinfo --sound

    29: PCI 1b.0: 0403 Audio device
    [Created at pci.310]
    UDI: /org/freedesktop/Hal/devices/pci_8086_284b
    Unique ID: u1Nb.iJWhLrosxI5
    SysFS ID: /devices/pci0000:00/0000:00:1b.0
    SysFS BusID: 0000:00:1b.0
    Hardware Class: sound
    Model: "Lenovo ThinkPad T61"
    Vendor: pci 0x8086 "Intel Corporation"
    Device: pci 0x284b "82801H (ICH8 Family) HD Audio Controller"
    SubVendor: pci 0x17aa "Lenovo"
    SubDevice: pci 0x20ac "ThinkPad T61"
    Revision: 0x03
    Driver: "HDA Intel"
    Driver Modules: "snd_hda_intel"
    Memory Range: 0xfe020000-0xfe023fff (rw,non-prefetchable)
    IRQ: 17 (6339 events)
    Module Alias: "pci:v00008086d0000284Bsv000017AAsd000020ACbc04sc03i00"
    Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
    Config Status: cfg=no, avail=yes, need=no, active=unknown

    ALSA Packages

    alsa-oss-32bit-1.0.15-48.1
    alsa-1.0.16-39.1
    alsa-oss-1.0.15-48.1
    alsa-utils-1.0.16-35.1
    alsa-plugins-1.0.16-57.1

    I have tried alsaconf. It successfully installs the sound card, but there is no test sound playing.

    In alsamixer I have spotted the label of a roll bar at the right end of the window labelled "internal speakers". I cannot access the roll bar and adjust the values.

    Thanks again.

    Heinrich

  7. #7
    Join Date
    Jun 2008
    Location
    Gelnhausen, approx. 50 km east of Frankfurt
    Posts
    89

    Default P.S. And again: No Sound on Thinkpad T61 under openSUSE 11.0

    The file producing the errors shown in my first posting looked like this:

    options snd slots=snd-hda-intel model=thinkpad enable=1 index=0
    # u1Nb.iJWhLrosxI5:ThinkPad T61
    alias snd-card-0 snd-hda-intel

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: And again: No Sound on Thinkpad T61 under openSUSE 11.0

    Quote Originally Posted by hgeis View Post
    /etc/modprobe.d/sound
    Code:
    options snd slots=snd-hda-intel
    # u1Nb.iJWhLrosxI5:ThinkPad T61
    alias snd-card-0 snd-hda-intel
    Please:
    a. install alsa-firmware and restart your pc; and
    b. change your /etc/modprobe.d/sound file to:
    Code:
    options snd slots=snd-hda-intel
    # u1Nb.iJWhLrosxI5:ThinkPad T61
    alias snd-card-0 snd-hda-intel 
    options snd-hda-intel model=thinkpad
    and restart your alsa with root permissions with rcalsasound restart and test your sound by copying and pasting the following line into an xterm konsole:
    speaker-test -c2 -Ddefault -l5 -twav

    Please do NOT use alsaconf nor yast>hardware>sound while trying this hand edit method. But alsaconf & yast will remove those custom settings from the /etc/modprobe.d/sound file.

    If that syntax does not work in the /etc/modprobe.d/sound file, then try:
    Code:
    options snd slots=snd-hda-intel model=thinkpad
    # u1Nb.iJWhLrosxI5:ThinkPad T61
    alias snd-card-0 snd-hda-intel
    and restart your alsa with root permissions with rcalsasound restart
    and test your sound by copying and pasting the following line into an xterm konsole:
    speaker-test -c2 -Ddefault -l5 -twav

    and if that syntax does not work with /etc/modprobe.d/sound file, then try:
    Code:
    options snd-hda-intel enable=1 index=0 model=thinkpad
    # u1Nb.iJWhLrosxI5:ThinkPad T61
    alias snd-card-0 snd-hda-intel
    and restart your alsa with root permissions with rcalsasound restart
    and test your sound by copying and pasting the following line into an xterm konsole:
    speaker-test -c2 -Ddefault -l5 -twav

    Also, if the above does not work, remove all your pulseaudio applications, and try again from the start.

    Please also post error messages. If too long, paste them in general pastebin - simplified internet collaboration

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: And again: No Sound on Thinkpad T61 under openSUSE 11.0

    Quote Originally Posted by oldcpu View Post
    b. change your /etc/modprobe.d/sound file to:
    Please also keep a record of the exact contents of each /etc/modprobe.d/sound file you tried that failed, and post the exact file contents here. I am finding an increasing number of openSUSE users are making typing/syntax errors when editing this fail, in essence dooming their sound to non-functionality. If they post precisely what they tried, then at least I can point out syntax errors, and the correct file can be tried.

  10. #10
    Join Date
    Jun 2008
    Location
    Gelnhausen, approx. 50 km east of Frankfurt
    Posts
    89

    Default And again: No Sound on Thinkpad T61 under openSUSE 11.0

    This is the syntax that produced the errors as you find it on SDB:Intel-HDA sound problems - openSUSE

    options snd slots=snd-hda-intel model=thinkpad enable=1 index=0
    # u1Nb.iJWhLrosxI5:ThinkPad T61
    alias snd-card-0 snd-hda-intel

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •