Results 1 to 2 of 2

Thread: Getting Compiz working

  1. #1
    Join Date
    Jul 2008
    Location
    /dev/null
    Posts
    37

    Default Getting Compiz working

    I have compiz and compiz fusion icon installed. How do I get compiz working in Suse 10.3
    Code:
    glade@Mean-Machine:~> compiz --replace
    compiz (core) - Fatal: No composite extension
    glade@Mean-Machine:~>
    Code:
    glade@Mean-Machine:~> glxinfo
    name of display: :0.0
    display: :0  screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.2
    server glx extensions:
        GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
        GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
        GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
        GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
    client glx vendor string: SGI
    client glx version string: 1.4
    client glx extensions:
        GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
        GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
        GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
        GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
        GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
        GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
    GLX extensions:
        GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
        GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
        GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
        GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_SGI_make_current_read,
        GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig
    OpenGL vendor string: Tungsten Graphics, Inc
    OpenGL renderer string: Mesa DRI Intel(R) 945GM 20061017
    OpenGL version string: 1.3 Mesa 7.0.1
    OpenGL extensions:
        GL_ARB_depth_texture, GL_ARB_fragment_program, GL_ARB_imaging,
        GL_ARB_multisample, GL_ARB_multitexture, GL_ARB_point_parameters,
        GL_ARB_shadow, GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
        GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
        GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
        GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
        GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,
        GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_window_pos,
        GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
        GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate,
        GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
        GL_EXT_cull_vertex, GL_EXT_compiled_vertex_array, GL_EXT_convolution,
        GL_EXT_copy_texture, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
        GL_EXT_histogram, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
        GL_EXT_point_parameters, GL_EXT_polygon_offset, GL_EXT_rescale_normal,
        GL_EXT_secondary_color, GL_EXT_separate_specular_color,
        GL_EXT_shadow_funcs, GL_EXT_stencil_wrap, GL_EXT_subtexture,
        GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
        GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
        GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
        GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle,
        GL_EXT_vertex_array, GL_3DFX_texture_compression_FXT1,
        GL_APPLE_client_storage, GL_APPLE_packed_pixels,
        GL_ATI_blend_equation_separate, GL_IBM_rasterpos_clip,
        GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
        GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_MESA_window_pos,
        GL_NV_blend_square, GL_NV_light_max_exponent, GL_NV_texture_rectangle,
        GL_NV_texgen_reflection, GL_NV_vertex_program, GL_NV_vertex_program1_1,
        GL_OES_read_format, GL_SGI_color_matrix, GL_SGI_color_table,
        GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
        GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGIX_depth_texture,
        GL_SUN_multi_draw_arrays
    glu version: 1.3
    glu extensions:
        GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess
    
       visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
     id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
    ----------------------------------------------------------------------
    0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
    0x24 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
    0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
    0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
    0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
    0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
    0x29 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
    0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
    0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
    0x2c 24 dc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
    0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
    0x2e 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
    0x2f 24 dc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
    0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
    0x31 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
    0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
    glade@Mean-Machine:~>
    It is a HP nx6320 laptop: T5500 processor, 1GB RAM, Intel GMA950/945GM Onboard graphics. Compiz works perfectly and very smoothly with Ubuntu

  2. #2
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    1,273

    Default Re: Getting Compiz working

    Which DE are you using (KDE/GNOME)?

    Have you tried enabling it using the Desktop Effects item in the control center? This should also give you the status is your video card is supported ' out of the box ' or if you might need to do some things before you can get it running..

    Cheers,
    Wj
    Have a lot of fun!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •