Results 1 to 10 of 10

Thread: OpenSUSE 11.0 10-digit WEP problem!

  1. #1
    nding NNTP User

    Default OpenSUSE 11.0 10-digit WEP problem!

    Hi all!

    I am in the midst of migrating from Windows to OpenSUSE, but was unable to get the wireless up initially.

    Just yesterday, I managed to get WUSB54G v4 to establish connection to the wireless AP through serial monkey rt2570 drivers.

    I choose my ESSID on the nodes that Network Manager informed me, and they prompt me the WEP encryption code.
    I entered the code is written on at the bottom of the 2Wire 2700HG ADSL Router. There are some WEP choices, to indicate it in Passphrase, HEX or ASCII.

    The code below the ADSL router is a 10-digit string.
    When I chose Passphrase or HEX, it was rejected.
    When I chose ASCII, it did not allow me to hit the OK button.

    I changed the ID from 10-digits to 13-digits, and I gave it a try... ASCII allowed me to proceed with the code, but it rejected my connection as well...

    Can anyone advise what I should do next? I am quite lost right now... Is the code written below the ADSL router HEX or ASCII?

    Thanks!

  2. #2
    Join Date
    Jan 2008
    Location
    Darmstadt, Germany
    Posts
    478

    Default Re: OpenSUSE 11.0 10-digit WEP problem!

    Can anyone advise what I should do next? I am quite lost right now... Is the code written below the ADSL router HEX or ASCII?
    A 10-digit string is most likely HEX. If there is any character besides 0-9 and A-F within the key, it would be an indication that it's not HEX. WEP-Keys can be 10-digit or 26-digit HEX in length, dependant if you're using 64bit or 128bit encryption. I would try to enter the key with colons and without colons first, maybe that's the issue (I'd vote for "without colons" between the HEX pairs). Unfortunately I have no WEP network running here and cannot reproduce the error, sorry. Besides of that I'd recommend you using WPA/WPA2 whenever possible, WEP is not much better than no encryption at all.
    No, I'll not describe how to get rid of it here, lol.

    Best of luck!

  3. #3
    nding NNTP User

    Default Re: OpenSUSE 11.0 10-digit WEP problem!

    Hi rhorstkoetter!

    Thanks for your reply.

    Besides of that I'd recommend you using WPA/WPA2 whenever possible, WEP is not much better than no encryption at all.
    I know that WEP is like an open door *lol* but I have no choice as there are some laptops hanging around here that have to use WEP (too old!).

    I tried on your advice, and entered the 10-digits and selected WEP HEX as the encryption type, but Network Manager keeps kicking me out! And it does not allow characters to be entered, so colons can't work out in that situation.

    I decided to turn away from Network Manager and use the traditional "ifconfig" method.

    I configured the interface, and restarted the network service. "iwconfig" and "ifconfig" shows that the WEP code that I issued is able to connect both the WUSB54Gv4 to the router. But the IP address is not there. I ran "dhclient" and rausb0 does not give me an IP address and timeout.

    I decided to go for another approach. I assign a static IP to the interface, "iwconfig" and "ifconfig" looks good.
    Next, I PING the IP I assigned... 192.168.1.70 (the network is in the 192.168.1.0/24) and it works.
    When I tried to PING the router, which is the standard 192.168.1.254, the PING packets failed to reach and drops out.

    Any idea which is the best approach I should tackle this problem?

    Thanks!

    Cheers!
    Andy

  4. #4
    nding NNTP User

    Default [Solved] OpenSUSE 11.0 10-digit WEP problem!

    Hi rhorstkoetter!

    I managed to solve the problem!!

    I checked an option in Network Settings to request the DHCP server to respond. And I did a dhclient and I saw communication between my PC and the router and TADAAAAA...

    The IP address was leased to me!

    The problem has been solved!

    Thank you!

    Cheers!
    Andy

  5. #5
    Join Date
    Jan 2008
    Location
    Darmstadt, Germany
    Posts
    478

    Default Re: [Solved] OpenSUSE 11.0 10-digit WEP problem!

    I checked an option in Network Settings to request the DHCP server to respond.
    Hm, I'm glad that you solved the problem.
    lol, where did you changed this setting? I'm just curious as I think it's more than a nice-to-have-feature that a DHCP server responds to a request.

    Anyway, I hope you'll enjoy your openSUSE experience! Welcome on board!

  6. #6
    nding NNTP User

    Default Re: OpenSUSE 11.0 10-digit WEP problem!

    I can't attach a graphic?

    Anyway, it is at the following:
    Network Settings --> Global Options tab --> Request Broadcast Response

    But well, there is still some problem. On boot, dhclient would try to get from the router, and it fails once again..
    I have to do a manual dhclient to get be assigned the DHCP IP, then am I able to go online...

    Now I am going on the approach to lengthen the following:
    Code:
    DHCLIENT_WAIT_AT_BOOT="15"
    In /etc/sysconfig/network/dhcp

    Wait for my news!

  7. #7
    nding NNTP User

    Default Re: OpenSUSE 11.0 10-digit WEP problem!

    I doubled the count... From the default 15 to 30, and OpenSUSE managed to boot up with the IP from the router!

  8. #8
    Join Date
    Jan 2008
    Location
    Darmstadt, Germany
    Posts
    478

    Default Re: OpenSUSE 11.0 10-digit WEP problem!

    Quote Originally Posted by nding View Post
    I doubled the count... From the default 15 to 30, and OpenSUSE managed to boot up with the IP from the router!
    That's an interesting problem you encounter here. I'm currently wondering what's the reason for that behaviour. Never had such issues with DHCP yet. Anyway, great to hear, that it's finally working for you. Thanks for keeping me in the loop!

  9. #9

    Default Re: OpenSUSE 11.0 10-digit WEP problem!

    I have the same problem but i cant solve it. I have 11.4 suse version
    I cant to change the wep key, it should is in my work
    i tried with the networkmanager and nothing, i can conect with open networks and hexadeciamls but not with ten digits networks wep key
    i tried with the last one post but nothing, i will be crazy JA

    y bueno en pocas palabras si funciona mi tarjeta inalambrica pero solo puedo conectar con redes abiertas no de 10 digitos y con hexadecimanes
    saludos, greetings

  10. #10
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: OpenSUSE 11.0 10-digit WEP problem!

    On 10/12/2011 01:36 AM, ior1yagami wrote:
    >
    > I have the same problem but i cant solve it. I have 11.4 suse version
    > I cant to change the wep key, it should is in my work
    > i tried with the networkmanager and nothing, i can conect with open
    > networks and hexadeciamls but not with ten digits networks wep key
    > i tried with the last one post but nothing, i will be crazy JA


    With openSUSE, you must use the hexadecimal key for WEP. The built-in conversion
    routine does not match the one used by Windows.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •