Results 1 to 10 of 10

Thread: 32 bit firefox in 64 bit openSUSE 11.0

  1. #1

    Cool 32 bit firefox in 64 bit openSUSE 11.0

    Could anybody install the 32 bit firefox in a 64 bit OS?

    As usual, this is necessary to make java plugin working. Although there may be other solutions, I used this way since years.

    But this time I get an error when starting firefox:

    Could not find compatible GRE between version 1.9.0 and 1.9.0

    I have installed the 64 and 32 bit versions of mozilla-xulrunner, both separately and together.

    The 32 bit firefox never worked.
    Last edited by ZStefan; 01-Jul-2008 at 13:38. Reason: Buggy wiki: mixed title with tag words

  2. #2
    serkankoyuncu NNTP User

    Default Re: 32 bit firefox in 64 bit openSUSE 11.0

    I dont know which rpms I've installed but same error message is appears on my laptop.

  3. #3

    Default Re: 32 bit firefox in 64 bit openSUSE 11.0

    I don't have problems with FF 64 bit...
    I didn't do anything after initial install from OS11.
    Main: openSUSE Tumbleweed | KDE | AMD A8-7600 R7 | 16GB | Xonar Essence STX
    Laptop: openSUSE Leap 15 | KDE | Intel i5-2520M | 8GB | Intel HD

  4. #4
    serkankoyuncu NNTP User

    Default Re: 32 bit firefox in 64 bit openSUSE 11.0

    it is weird :s
    on my desktop pc FF is working flawlessly but on my laptop, doesnt.
    I tried to install xulrunner-1.9.0 32 bit but it doesnt solved.

  5. #5
    serkankoyuncu NNTP User

    Default Re: 32 bit firefox in 64 bit openSUSE 11.0

    I removed xulrunner-1.9.0 package with ignore dependencies and re-installed,
    it is working again.

  6. #6
    Join Date
    Jun 2008
    Location
    Rome, Italy
    Posts
    248

    Default Re: 32 bit firefox in 64 bit openSUSE 11.0

    I did it on mine opensuse10.2 (64bit) box. So i don't know if it works on os11.0. I downloaded the generic tar.bz2 for the Mozilla site, then i extracted it in /usr/local and run from there. It asked if i wanted to make it the default browser. I answered yes, and it works flawlessy until now. Give it a try.

  7. #7

    Default Re: 32 bit firefox in 64 bit openSUSE 11.0

    I installed xulrunner (not the 32 bit version) as a 32 bit package (thus i586 instead of x86_64) and that helped for me.

  8. #8
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,107

    Default Re: 32 bit firefox in 64 bit openSUSE 11.0

    I gave up and just installed the 32bit version of Seamonkey - which works fine for java based websites that don't work too well with knqueror.

  9. #9
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,107

    Default Re: 32 bit firefox in 64 bit openSUSE 11.0

    changing xulrunner 190 to the i585 version worked for me

  10. #10

    Default Re: 32 bit firefox in 64 bit openSUSE 11.0

    I am running openSUSE 10.3, but ran into similar problems.

    I have the following packages
    rpm -qva |grep -i -E -e 'firefox|xulrunner|seamonkey'|sort
    MozillaFirefox-3.0-1.2
    mozilla-xulrunner190-1.9.0.1-1.1
    mozilla-xulrunner190-gnomevfs-1.9.0.1-1.1
    mozilla-xulrunner190-translations-1.9.0.1-1.1
    seamonkey-1.1.11-1.1
    seamonkey-dom-inspector-1.1.11-1.1
    seamonkey-venkman-1.1.11-1.1


    Using strace on firefox I noticed
    open("/usr/lib/firefox/application.ini", O_RDONLY) = 3
    precedes the check of the /etc/gre.d/1.9.0.1.system.conf contents.

    In application.ini, I found

    [Gecko]
    MinVersion=1.9.0
    MaxVersion=1.9.0

    Changing those values to 1.9.0.1 did the trick.Further experimenting showed that I only need to set the MaxVersion value to 1.9.0.1.
    Which (duh!) makes sense given the xulrunner version I have.

    Very frustrating!

    --Eric

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •