Results 1 to 3 of 3

Thread: 10.3 is verry sluggish

  1. #1

    Default 10.3 is verry sluggish

    I just installed 10.3 and am experiencing a lot of sever sluggishness in the response time to interactive commands in KDE windows, either via shell windows or application windows. TOP is not showing any processes taking up a large percentage of CPU time, although that may be misleading as it too will stop updating during the times the system is really slow. Swap space seems fine also. Below is a snapshot taken from TOP as best as I can get.

    Any help tracking down why this system is responding so slow will be much appreciated. Other info, CPU is a dual core Intel Pentium processor running at 2.8ghz, memory 2gb. Thanks in advance! Marc...


    top - 23:42:06 up 1 day, 16:41, 15 users, load average: 0.52, 0.25, 0.57
    Tasks: 185 total, 3 running, 180 sleeping, 1 stopped, 1 zombie
    Cpu(s): 0.0%us, 0.2%sy, 0.0%ni, 98.2%id, 1.5%wa, 0.0%hi, 0.2%si, 0.0%st
    Mem: 2060616k total, 2051136k used, 9480k free, 47096k buffers
    Swap: 53199208k total, 718744k used, 52480464k free, 1366556k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    28162 root 15 0 8628 1188 828 R 0 0.1 0:00.09 top
    1 root 18 0 808 80 44 S 0 0.0 0:00.54 init
    2 root 11 -5 0 0 0 S 0 0.0 0:00.02 kthreadd
    3 root RT -5 0 0 0 S 0 0.0 0:00.01 migration/0
    4 root 34 19 0 0 0 S 0 0.0 0:00.00 ksoftirqd/0
    5 root RT -5 0 0 0 S 0 0.0 0:00.00 migration/1
    6 root 34 19 0 0 0 S 0 0.0 0:00.37 ksoftirqd/1
    7 root 10 -5 0 0 0 S 0 0.0 0:00.12 events/0
    8 root 10 -5 0 0 0 S 0 0.0 0:00.03 events/1
    9 root 11 -5 0 0 0 S 0 0.0 0:00.00 khelper
    30 root 10 -5 0 0 0 S 0 0.0 0:00.02 kblockd/0
    31 root 10 -5 0 0 0 S 0 0.0 0:13.10 kblockd/1
    32 root 20 -5 0 0 0 S 0 0.0 0:00.00 kacpid
    33 root 20 -5 0 0 0 S 0 0.0 0:00.00 kacpi_notify
    135 root 20 -5 0 0 0 S 0 0.0 0:00.00 cqueue/0
    136 root 10 -5 0 0 0 S 0 0.0 0:00.00 cqueue/1
    137 root 11 -5 0 0 0 S 0 0.0 0:00.02 kseriod
    169 root 10 -5 0 0 0 S 0 0.0 4:38.84 kswapd0
    170 root 20 -5 0 0 0 S 0 0.0 0:00.00 aio/0
    171 root 20 -5 0 0 0 S 0 0.0 0:00.00 aio/1
    405 root 20 -5 0 0 0 S 0 0.0 0:00.00 kpsmoused
    415 root 13 -5 0 0 0 S 0 0.0 0:00.00 kondemand/0
    416 root 14 -5 0 0 0 S 0 0.0 0:00.00 kondemand/1
    467 root 10 -5 0 0 0 S 0 0.0 0:00.00 ata/0

  2. #2
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: 10.3 is verry sluggish

    You wouldn't happen to have Beagle running, would you?

    If you do, uninstall it *completely* - this will most definitely help you.

  3. #3
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: 10.3 is verry sluggish

    Is the system slow indefinitely?

    As mentioned above, beagle can be a problem. Usually it's multiple instances of beagle-helper being spawned. They run as nice 19, so there isn't a lot of cpu taken. But it ties up the file system, slowing other things down. I eliminated that problem by configuring beagle to limit where it crawls. Or you can remove beagle to see if that helps.

    Also on 10.3, if you have the opensuse updater applet loading, zypper starts up immediately and can tie up the system. But you would see periodic spikes in the cpu load.

    Have you looked at the kernel boot log? Perhaps the hardware is not being initialized correctly, or there is a kernel parameter needed for your hardware. For example, check whether you have throttling enabled in the bios, and whether the kernel is enabling it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •