Results 1 to 5 of 5

Thread: USB HDD mount problems

  1. #1
    Join Date
    Jul 2008
    Location
    /dev/null
    Posts
    37

    Default USB HDD mount problems

    To begin with, I have already installed ntfs-config and ntfsprogs-fuse
    When I plug in my USB HDD (formatted in NTFS fs), I get:
    Permission denied
    So I mount it manually:
    Code:
    sudo mount /dev/sdb1 /media/Glade
    Now if I try to access it, I get:
    mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so
    dmesg | tail returns: http://pastebin.com/m2250c797

    The HDD shows "No files, No folder" and the above mentioned error message. While on the same laptop, I dual boot with Ubuntu Hardy and the HDD works perfectly. Plus, ofcourse, it works fine with my Windows desktop.

    I have tried everything advised here:
    http://www.orkut.co.in/CommMsgs.aspx...412784&start=1

    Any suggestions?

  2. #2
    Alberto García baladía NNTP User

    Default Re: USB HDD mount problems

    LinuxIsInnovation wrote:

    >
    > To begin with, I have already installed ntfs-config and ntfsprogs-fuse
    > When I plug in my USB HDD (formatted in NTFS fs), I get:
    >> Permission denied

    > So I mount it manually:
    >
    > Code:
    > --------------------
    > sudo mount /dev/sdb1 /media/Glade
    > --------------------
    >
    > Now if I try to access it, I get:
    >> mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing
    >> codepage or helper program, or other error In some cases useful info is
    >> found in syslog - try dmesg | tail or so

    >
    > dmesg | tail returns: http://pastebin.com/m2250c797
    >
    > The HDD shows "No files, No folder" and the above mentioned error
    > message. While on the same laptop, I dual boot with Ubuntu Hardy and
    > the HDD works perfectly. Plus, ofcourse, it works fine with my Windows
    > desktop.
    >
    > I have tried everything advised here:
    > http://tinyurl.com/63dr7a
    >
    > Any suggestions?
    >
    >

    Yes. Read post from Nagilum and the answer in this group (30/6/08)

    --
    Alberto García Baladía

  3. #3
    Join Date
    Jul 2008
    Location
    /dev/null
    Posts
    37

    Default Re: USB HDD mount problems

    First of all, thanks for replying
    As I mentioned that I did everything advised here: http://www.orkut.co.in/CommMsgs.aspx...412784&start=1

    At the ^^^^ Link (See page 2), I was advised this:
    Automounting NTFS external USB storage with ntfs-3g - alt.os.linux.suse | Google Groups

    And didn't work. This is same as your workaround.
    Thanks again but the problem still remains unsolved.

  4. #4

    Arrow Re: USB HDD mount problems

    I have the same problem. And the problem is right there in the mount command.
    Code:
    mount /dev/sdb1 /media/Glade
    That worked in 10.3 perfectly with NTFS partitions. In 11.0 it returns an error - says unknown fs type.

    Still I have only one suggestion. Try to use NTFS-3G driver and use the command:
    Code:
    mount -t ntfs-3g /what/ /where/ -o force,locale=ru_RU.UTF-8
    The last part is optional. Use "force" option in case you have the problem with "unclear unmounts" and use the "locale" option, if you have language-specific problems with your NTFS partition. (if you do not need both - skip the "-o" as well)

    I think, we should wait for updates.

    P.S.
    DO NOT use ntfs-config - thats my personal recommendation. In 10.3 I had real problems with this app. It worked 100% well for my external NTFS HDD, but at the same time I got issues with my USB Flash disks, which are FAT-32.
    The NTFS-3G driver and some manual manipulations allowed me to have my external USB HDD automount on hotplug with write permissions for user. Unfortunately, that does not work on 11.0, because mount problem

  5. #5

    Default Re: USB HDD mount problems

    I got it!

    The only thing you have to do to make everything work OK is to duplicate a symlink.

    First make sure, you have all these installed:
    ntfs-3g
    fuse
    libfuse2

    Then open your file manager (root) go to /sbin/ search for mount.ntfs-3g and copy it with the name mount.ntfs

    It works for me.
    I have automount in KDE3 working, no problems with locale, no problems with flash disks.

    There is only one problem - if you used NTFS-CONFIG - this might not work. Be careful.
    I reinstalled my 11.0 to make this work.

    P.S.
    Good luck!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •