Results 1 to 8 of 8

Thread: Question regarding yum/yast

  1. #1

    Question Question regarding yum/yast

    I am using debian and wanted to try opensuse. When I wanted to get something like XMMS (MP3 Player) I would do apt-get install xmms. I tried doing this using yum but it doesn't do anything. Is there something similar to apt-get in opensuse?
    It seems like yast/yum only pull packages from the CD.

  2. #2
    Join Date
    Jan 2008
    Location
    N40 44.977 W073 59.356
    Posts
    1,170

    Default Re: Question regarding yum/yast

    encino wrote:
    > I am using debian and wanted to try opensuse. When I wanted to get
    > something like XMMS (MP3 Player) I would do apt-get install xmms. I
    > tried doing this using yum but it doesn't do anything. Is there
    > something similar to apt-get in opensuse?
    > It seems like yast/yum only pull packages from the CD.
    >
    >

    Although yum works, the command line package management really is
    zypper. If you wanted xmms you would run zypper in xmms.

  3. #3
    Join Date
    Jun 2008
    Location
    Freiburg, Germany
    Posts
    32

    Default Re: Question regarding yum/yast

    Try zypper. Syntax is very similar to apt-get.

  4. #4

    Default Re: Question regarding yum/yast

    so it would be zypper install xmms ?
    cause that doesnt work so obviously I am doing something wrong.
    do i need to add an additional repo?

  5. #5
    darvr NNTP User

  6. #6
    Join Date
    Jan 2008
    Location
    N40 44.977 W073 59.356
    Posts
    1,170

    Default Re: Question regarding yum/yast

    What version of openSUSE are you using and what is the output to zypper lr?

  7. #7

    Default Re: Question regarding yum/yast

    opensuse 11

    zypper install xmms
    Reading installed packages...
    'xmms' not found
    Nothing to do.

    I d/led the RPM and tried to install that way but it tells me its missing a dependency gtk+ but when I do a zypper install gtk+ it tells me its already installed.
    I am doing rpm -i xmms-1.2.10-1.i386.rpm
    error: Failed dependencies:
    gtk+ >= 1:1.2.2 is need by xmms-1.2.10-1.i386.rpm
    then I do zypper install gtk+ I get:
    Reading installed packages...
    'gtk' providing 'gtk+' is already installed.
    Nothing to do.

  8. #8
    Join Date
    Jun 2008
    Location
    Freiburg, Germany
    Posts
    32

    Default Re: Question regarding yum/yast

    There are two things you should check:

    1) Check if you have added all the needed Repositories. You can do this very simple by using YAST. I think adding the Packman Repository should do it, if it is XMMS you are looking for. Try

    zypper lr

    and post your output here, so we can see if everything is right with your repositories.

    2) zypper is case-sensitive and it is a fundamential requirement, that the package you want to install is written in the right way. So, if you want to install a package from a repository, you should start searching it:

    zypper search xmms

    Doing this, you will get a list of all packages containing xmms (for looking up also in descriptions and more stuff about zypper head for the man-page) and you can install the package you want.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •