Results 1 to 6 of 6

Thread: No WSXGA+(1680x1050) under VMware and OpenSuse 11

  1. #1
    Kornelis NNTP User

    Default No WSXGA+(1680x1050) under VMware and OpenSuse 11

    Hi,

    i just got my new Notebook (Asus V1Sn) with the pretty resolution of 1680x1050.

    No i tried to install OpenSuse 11 in a virtual Machine. The installation went very well and the system runs fast.

    But i have a problem to set the resolution to 1680x1050 for fullscreen mode...
    I changed the Monitor to LCD 1680x1050@60Hz an the resolution even to 1680x1050. But if i run the Test, it displays a resolution of 1600x1024. The Screen is centered and has to black bars right and left.

    Does someone have any idea how to fix this problem?

    Best Regards

    Kornelis

    p.s.

    I have the VMTools already installed

  2. #2
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: No WSXGA+(1680x1050) under VMware and OpenSuse 11

    Are you sure the vmware video driver (it's installed with the tools) supports this resolution?

    Which method are you using to try to change it? Sounds like sax2 (the YaST Graphics Card module). Do you know how to manually change the X-server control file? Why don't you post back here the contents of that file, it's /etc/X11/xorg.conf

  3. #3
    Kornelis NNTP User

    Default Re: No WSXGA+(1680x1050) under VMware and OpenSuse 11

    Hi,

    yes i changed the config via Sax2.

    I'm sure that the vmware supports the resolution because for testing purpose, i installed Kubuntu 8 KDE4 Remix and it had no problem with the wsxga+ resolution in fullscreen mode.

    Here is the code from my xorg.cfg

    Unfortunetly i'm pretty new to Linux / OpenSuse so i'll first have to figure out, how to change with something without the Gui

    Code:
    # /.../
    # SaX generated X11 config file
    # Created on: 2008-07-01T15:19:54+0200.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"
      FontPath     "/usr/share/fonts/URW"
      FontPath     "/usr/share/fonts/Speedo"
      FontPath     "/usr/share/fonts/PEX"
      FontPath     "/usr/share/fonts/cyrillic"
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
      FontPath     "/usr/share/fonts/baekmuk:unscaled"
      FontPath     "/usr/share/fonts/japanese:unscaled"
      FontPath     "/usr/share/fonts/kwintv"
      FontPath     "/usr/share/fonts/truetype"
      FontPath     "/usr/share/fonts/uni:unscaled"
      FontPath     "/usr/share/fonts/CID"
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"
      FontPath     "/usr/share/fonts/xtest"
      FontPath     "/opt/kde3/share/fonts"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "ServerFlags"
      Option       "AllowMouseOpenFail" "on"
      Option       "ZapWarning" "on"
    EndSection
    
    Section "Module"
      Load         "extmod"
      Load         "type1"
      Load         "glx"
      Load         "freetype"
      Load         "dbe"
    EndSection
    
    Section "InputDevice"
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "de"
      Option       "XkbModel" "microsoftpro"
      Option       "XkbRules" "xfree86"
      Option       "XkbVariant" "nodeadkeys"
    EndSection
    
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "VMware Mouse"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    
    Section "Monitor"
      DisplaySize  380 290
      HorizSync    30-66
      Identifier   "Monitor[0]"
      ModelName    "1680X1050@60HZ"
      Option       "DPMS"
      Option       "PreferredMode" "1680x1050"
      VendorName   "--> LCD"
      VertRefresh  50-61
      UseModes     "Modes[0]"
    EndSection
    
    
    Section "Modes"
      Identifier   "Modes[0]"
    EndSection
    
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "Device"
      BoardName    "VMWARE0405"
      BusID        "0:15:0"
      Driver       "vmware"
      Identifier   "Device[0]"
      Screen       0
      VendorName   "VMWare Inc"
    EndSection
    
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
    EndSection

  4. #4
    Kornelis NNTP User

    Default Re: No WSXGA+(1680x1050) under VMware and OpenSuse 11

    well i just found a very interesting fact...

    if i change to fullscreen my desktop i get a grey bar on the right side. But it seems that just the Desktop i limited to this bar because if i maximize a programm (e.g. Firefox) i takes the whole screen.

    On the second Image you have to look at the right bottom corner...





    Any Ideas?

    Best Regards

    Kornelis

  5. #5
    Kornelis NNTP User

    Default Re: No WSXGA+(1680x1050) under VMware and OpenSuse 11

    i don't know why, but the problem solved itself...

    i changed the location of the Panel to the right side of the display (it layed over the gray bar) and changed it back to the bottom of the screen and suddenly it sized it self to the full width of the screen. Then i changed the background image and it had the same effect that it suddenly stratched to the full width.

    Greeting

    Kornelis

  6. #6
    Join Date
    Jun 2008
    Location
    Atlanta, Georgia, USA
    Posts
    2,429

    Default Re: No WSXGA+(1680x1050) under VMware and OpenSuse 11

    Kornelis@

    Great! I suppose if it's fixed, however it happened, best to leave it be. However . . .

    Looking at your xorg.conf file, I think your "display size" is off relative to your resolution. The resolution of 1680x1050 is a wide-screen aspect ratio of 1.6. But the display size shown is 1.3. Under the monitor spec in sax2 (YaST graphics card module), there is a tab for display size. You can provide a diagonal measure, aspect ratio, or the vertical/horizontal dimensions. Sax will calculate the remaining values based upon what you enter (i.e., it will calculate dimensions based on the diagonal or the reverse). The aspect ratio is your resolution ratio.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •