Results 1 to 7 of 7

Thread: NFS mount works manually, but not during boot up ... why?

  1. #1

    Default NFS mount works manually, but not during boot up ... why?

    From my openSUSE 11 client computer, I can do an NFS mount with the following command to another openSUSE 11 computer (which is the server):

    mount server_name:/data /test_mount

    so the /data directory on the "server" computer gets mounted to the /test_mount directory on the "client" computer.

    This works fine.

    But when I tried to make this mount automatically during boot up, it doesn't work.

    This is what I did:

    On the "client" computer, inside the /etc/fstab file, this is what I have:

    server_name:/data /test_mount nfs defaults 0 0


    After rebooting the client computer, the mount point is not mounted. Any suggestion as to how to fix this problem? Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    East of Podunk
    Posts
    33,091
    Blog Entries
    15

    Default Re: NFS mount works manually, but not during boot up ... why?

    Quote Originally Posted by serendipity1276
    From my openSUSE 11 client computer, I can do an NFS mount with the
    following command to another openSUSE 11 computer (which is the
    server):

    mount server_name:/data /test_mount

    so the /data directory on the "server" computer gets mounted to the
    /test_mount directory on the "client" computer.

    This works fine.

    But when I tried to make this mount automatically during boot up, it
    doesn't work.

    This is what I did:

    On the "client" computer, inside the /etc/fstab file, this is what I
    have:

    server_name:/data /test_mount nfs defaults 0 0


    After rebooting the client computer, the mount point is not mounted.
    Any suggestion as to how to fix this problem? Thanks.

    Hi
    That is probably due to the network not being up when your trying to
    mount the remote file system? Shouldn't you be using a client utility
    like mount.nfs?

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.0 x86 Kernel 2.6.25.18-0.1-default
    up 3 days 7:22, 1 user, load average: 0.07, 0.12, 0.15
    GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80


  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,680

    Default Re: NFS mount works manually, but not during boot up ... why

    Quote Originally Posted by serendipity1276 View Post
    From my openSUSE 11 client computer, I can do an NFS mount with the following command to another openSUSE 11 computer (which is the server):

    mount server_name:/data /test_mount

    so the /data directory on the "server" computer gets mounted to the /test_mount directory on the "client" computer.

    This works fine.

    But when I tried to make this mount automatically during boot up, it doesn't work.

    This is what I did:

    On the "client" computer, inside the /etc/fstab file, this is what I have:

    server_name:/data /test_mount nfs defaults 0 0


    After rebooting the client computer, the mount point is not mounted. Any suggestion as to how to fix this problem? Thanks.
    Your entry in /etc/fstabs looks allright. Did you check if dmesg gives you any errors?

    Also, having this entry, can you mount by hand giving only the mountpoint:
    Code:
    mount /test_mount
    or does this give errors?
    Henk van Velden

  4. #4
    flurl NNTP User

    Default Re: NFS mount works manually, but not during boot up ... why

    hi,
    i stumbled upon the same problem and in my case enabling the "nfs client services" in the runlevel editor was the solution.

  5. #5

    Default Re: NFS mount works manually, but not during boot up ... why

    I believe you are correct.

    But what's the syntax to turn on "NFS client" from the client computer?

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,680

    Default Re: NFS mount works manually, but not during boot up ... why

    As flurl saus: YaST > System > System Services (Runlevel)
    Scroll to 'nfs no NFS client services', select, click Enable, click Finish.
    Henk van Velden

  7. #7
    Join Date
    Aug 2008
    Location
    Maryland
    Posts
    208

    Default Re: NFS mount works manually, but not during boot up ... why

    I am also having problems with nfs mounting during boot, but on 11.1. See post.

    openSUSE 11.1 not mounting NFS at boot - openSUSE Forums

    Did you create the fstab entry yourself or did you use the nfs client in yast2? Starting in 10.3 if you did not use the nfs client in yast2 then the nfs share would not mount at boot. The nfs client must be writing some data in another file besides fstab. Because I never saw a differance between the entries in fstab that I created and the ones created by the nfs client.

    Dave

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •