Results 1 to 3 of 3

Thread: Compat-Wireless make error in opensuse11.0 64bit

  1. #1

    Default Compat-Wireless make error in opensuse11.0 64bit

    Hi

    I have a Dell Vostro M1500 laptop with Intel 3945 chipset running opensuse 11.0

    Trying to install compat-wireless drivers but gives an error when running make command. the error is

    /root/software/compat-wireless-2008-06-29/config.mk:48: "WARNING: You are running a kernel >= 2.6.23, you should enable in it CONFIG_NETDEVICES_MULTIQUEUE for 802.11[ne] support"

    and goes on to end as

    root/software/compat-wireless-2008-06-29/drivers/net/wireless/b43/rfkill.c:91: error: RFKILL_STATE_UNBLOCKED undeclared (first use in this function)
    /root/software/compat-wireless-2008-06-29/drivers/net/wireless/b43/rfkill.c:91: error: (Each undeclared identifier is reported only once
    /root/software/compat-wireless-2008-06-29/drivers/net/wireless/b43/rfkill.c:91: error: for each function it appears in.)
    /root/software/compat-wireless-2008-06-29/drivers/net/wireless/b43/rfkill.c:101: error: RFKILL_STATE_SOFT_BLOCKED undeclared (first use in this function)
    make[6]: *** [/root/software/compat-wireless-2008-06-29/drivers/net/wireless/b43/rfkill.o] Error 1
    make[5]: *** [/root/software/compat-wireless-2008-06-29/drivers/net/wireless/b43] Error 2
    make[4]: *** [/root/software/compat-wireless-2008-06-29/drivers/net/wireless] Error 2
    make[3]: *** [_module_/root/software/compat-wireless-2008-06-29] Error 2
    make[2]: *** [sub-make] Error 2
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/usr/src/linux-2.6.25.5-1.1-obj/x86_64/default'
    make: *** [modules] Error 2

    Can someone help. i've looked around and cant find a solution.
    Any help would be greatly appreciated

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Compat-Wireless make error in opensuse11.0 64bit

    rbkumaran wrote:
    > Hi
    >
    > I have a Dell Vostro M1500 laptop with Intel 3945 chipset running
    > opensuse 11.0
    >
    > Trying to install compat-wireless drivers but gives an error when
    > running make command. the error is
    >
    > /ROOT/SOFTWARE/COMPAT-WIRELESS-2008-06-29/CONFIG.MK:48: \"WARNING: YOU
    > ARE RUNNING A KERNEL >= 2.6.23, YOU SHOULD ENABLE IN IT
    > CONFIG_NETDEVICES_MULTIQUEUE FOR 802.11[NE] SUPPORT\"
    >
    > and goes on to end as
    >
    > root/software/compat-wireless-2008-06-29/drivers/net/wireless/b43/rfkill.c:91:
    > error: ‘RFKILL_STATE_UNBLOCKED’ undeclared (first use in this function)
    > /root/software/compat-wireless-2008-06-29/drivers/net/wireless/b43/rfkill.c:91:
    > error: (Each undeclared identifier is reported only once
    > /root/software/compat-wireless-2008-06-29/drivers/net/wireless/b43/rfkill.c:91:
    > error: for each function it appears in.)
    > /root/software/compat-wireless-2008-06-29/drivers/net/wireless/b43/rfkill.c:101:
    > error: ‘RFKILL_STATE_SOFT_BLOCKED’ undeclared (first use in this
    > function)
    > make[6]: ***
    > [/root/software/compat-wireless-2008-06-29/drivers/net/wireless/b43/rfkill.o]
    > Error 1
    > make[5]: ***
    > [/root/software/compat-wireless-2008-06-29/drivers/net/wireless/b43]
    > Error 2
    > make[4]: ***
    > [/root/software/compat-wireless-2008-06-29/drivers/net/wireless] Error
    > 2
    > make[3]: *** [_module_/root/software/compat-wireless-2008-06-29] Error
    > 2
    > make[2]: *** [sub-make] Error 2
    > make[1]: *** [all] Error 2
    > make[1]: Leaving directory
    > `/usr/src/linux-2.6.25.5-1.1-obj/x86_64/default'
    > make: *** [modules] Error 2
    >
    > Can someone help. i've looked around and cant find a solution.
    > Any help would be greatly appreciated


    You should post your message to linux-wireless@vger.kernel.org. That
    way the compat-wireless people will see it.

    Larry

  3. #3

    Thumbs up Re: Compat-Wireless make error in opensuse11.0 64bit

    *** Problem Resolved ***

    Seems to have gone away with todays build (1st July).

    and the warning 2.6.23, about CONFIG_NETDEVICES_MULTIQUEUE is a mere warning...Accroding to compat-drivers mailing list this can be ignored.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •