Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: No sound on IBM laptop

  1. #1

    Default No sound on IBM laptop

    Hi all,

    Just installed opensuse 11.0 on my ibm stinkpad. My sounds seems to be dead. I have looked through the audio troublehshooter with no joy. I am including some things to get an idea of what I could look at next.

    ibm-linux:/etc/modprobe.d # rpm -qa | grep alsa
    alsa-utils-1.0.16-35.1
    alsa-1.0.16-39.1
    alsa-plugins-1.0.16-57.1
    alsa-oss-1.0.15-48.1
    ibm-linux:/etc/modprobe.d # rpm -qa | grep pulse
    ibm-linux:/etc/modprobe.d # rpm -q libasound2
    libasound2-1.0.16-39.1
    ibm-linux:/etc/modprobe.d # uname -a
    Linux ibm-linux 2.6.25.5-1.1-pae #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux
    ibm-linux:/etc/modprobe.d # cat /etc/modprobe.d/sound
    alias snd-card-0 snd-intel8x0
    alias sound-slot-0 snd-intel8x0
    ibm-linux:/etc/modprobe.d #


    I also ran a script that uploads the tsalsa.txt to the no past site: tsalsa.txt - nopaste.com (beta)

    Can someone point me in the right direction?

    TIA,

    R

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound on IBM laptop

    Quote Originally Posted by rhltechie View Post
    I also ran a script that uploads the tsalsa.txt to the no past site: tsalsa.txt - nopaste.com (beta)
    Thanks, running that script was especially helpful. It tells me your thinkpad as an AD1981B.

    I noted some aspects out of your mixer settings:
    Code:
    Amixer contents for card 0 [ICH6] _____________________________________        
    amixer set 'Headphone',0 68%,68% on        
    amixer set 'Line',0 45% off 45% off Capture on        
    amixer set 'External Amplifier',0 on
    On earlier openSUSE versions, this AD1981B has often caused user problems. The "trick" appears to be to switch the External Amp OFF. Please try that.

    I've also read of an other user who suggested that if switching OFF the External Amp was not enough, then one should also switch OFF the "headphone jack" and the "line sense jack". I'm not convinced that is a solution, but if switching off the External Amp does not "do the trick" by itself, you could also try switching OFF those two.

  3. #3

    Default Re: No sound on IBM laptop

    First, thanks for replying.

    When you say switch it off do you mean to just go into Kmix and make it dark? If so, I tried this with no joy along with the phone part of it. If not, is there a better way for me to do this?

    TIA,

    R

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound on IBM laptop

    Quote Originally Posted by rhltechie View Post
    When you say switch it off do you mean to just go into Kmix and make it dark?
    I mean disable it.

    Also, what is your sound test? Please use the following as a sound test (copy and paste the following into an xterm/konsole):
    speaker-test -Dplug:front -c2 -l5 -twav

    Also, reboot and check your BIOS. Ensure your sound is ENABLED. Also ensure your MODEM in the BIOS is enabled (as I have read disabling the modem has blocked the sound for some IBM laptop users).

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound on IBM laptop

    Quote Originally Posted by rhltechie View Post
    I have looked through the audio troublehshooter with no joy.
    Did your "looking" including running alsaconf ?

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound on IBM laptop

    Quote Originally Posted by rhltechie View Post
    ibm-linux:/etc/modprobe.d #cat /etc/modprobe.d/sound
    Code:
    alias snd-card-0 snd-intel8x0
    alias sound-slot-0 snd-intel8x0
    Try the following edit in your /etc/modprobe.d/sound file:
    Code:
    alias snd-card-0 snd-intel8x0
    alias sound-slot-0 snd-intel8x0
    options snd-intel8x0 model=thinkpad
    Then restart your alsa by typing the following in an xterm/konsole: rcalsasound restart
    Then test your sound with:
    speaker-test -Dplug:front -c2 -l5 -twav

    Note the following must be done in conjunction with your external amp switched off (disabled).

    If that doesn't work, you could also try "toshiba" instead of "thinkpad", or "hp" instead of "thinkpad", but I think "thinkpad" most likely for your IBM.

  7. #7

    Default Re: No sound on IBM laptop

    Hi,

    I did try to run alsaconf and it seems to run properly but when it plays the test wav i am still unable to hear it.

    How might i actually disable the portion you are speaking of?

    Also, I tried to make the changes to my sound in modprobe directory but when restarting I receive this error:

    ibm-linux:/etc/modprobe.d # rcalsasound restart
    /usr/sbin/alsactl: save_state:1497: No soundcards found...
    Shutting down sound driver done
    Starting sound driver: intel8x0FATAL: Error inserting snd_intel8x0 (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/pci/snd-intel8x0.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    failed


    I see this in dmesg:

    snd_intel8x0: Unknown parameter `model'

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound on IBM laptop

    Quote Originally Posted by rhltechie View Post
    Also, I tried to make the changes to my sound in modprobe directory but when restarting I receive this error: ....Unknown symbol in module, or unknown parameter (see dmesg) .....
    I see this in dmesg: snd_intel8x0: Unknown parameter `model'
    Thanks. ... I gave you a model option for the AD1981, even though you have an AD1981B. Maybe that "thinkpad" option will not work in an AD1981B.

    Please, can you post here the EXACT contents of your /etc/modprobe.d/with that change, so I can check your syntax? ie output of typing:
    cat /etc/modprobe.d/sound

    You could also try this syntax:
    Code:
    alias snd-card-0 snd-intel8x0 model=thinkpad
    alias sound-slot-0 snd-intel8x0
    ... and then try "rcalsasound restart" again.

    or perhaps try this:
    Code:
    alias snd-card-0 snd-intel8x0 model=auto
    alias sound-slot-0 snd-intel8x0
    ... and then try "rcalsasound restart" again.

    If those do not work, put your /etc/modprobe./sound back to how it was originally.

    Don't forget to check the BIOS like I asked.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: No sound on IBM laptop

    Quote Originally Posted by rhltechie View Post
    How might i actually disable the portion you are speaking of?
    ALL OF THE OTHER TESTS ARE LIKELY MEANINGLESS if you don't do this ... ie you will have to do them again. Please, don't waste your time here. Get this done first. Lets be clear on this.

    There should be a setting in kmix (if using kde) or alsamixer (if using Gnome). Failing that, you could try "amixer" from a konsole/xterm, although that is not very user friendly. "man amixer" will provide a difficult to follow "man" guide.

  10. #10

    Default Re: No sound on IBM laptop

    I checked the bios ask you asked but forgot to post that everything checked out ok.

    When I move the model=thinkpad up and get rid of the options line I get something else a little weird.

    ibm-linux:/etc/modprobe.d # cat sound
    options snd slots=snd-intel8x0 model=thinkpad
    alias snd-card-0 snd-intel8x0


    ibm-linux:/etc/modprobe.d # rcalsasound restart
    Starting sound driver: intel8x0WARNING: Error inserting snd (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/core/snd.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting snd_timer (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/core/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting snd_pcm (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/core/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    WARNING: Error inserting snd_ac97_codec (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/pci/ac97/snd-ac97-codec.ko): Unknown symbol in module, or unknown parameter (see dmesg)
    FATAL: Error inserting snd_intel8x0 (/lib/modules/2.6.25.5-1.1-pae/kernel/sound/pci/snd-intel8x0.ko): Unknown symbol in module, or unknown parameter (see dmesg)

    and dmesg..



    PCI: Setting latency timer of device 0000:00:1e.2 to 64
    intel8x0_measure_ac97_clock: measured 55363 usecs
    intel8x0: clocking to 48000
    ACPI: PCI interrupt for device 0000:00:1e.2 disabled
    snd_intel8x0: Unknown parameter `model'
    ACPI: PCI Interrupt 0000:00:1e.2[A] -> GSI 22 (level, low) -> IRQ 22
    PCI: Setting latency timer of device 0000:00:1e.2 to 64
    intel8x0_measure_ac97_clock: measured 55336 usecs
    intel8x0: clocking to 48000
    ACPI: PCI interrupt for device 0000:00:1e.2 disabled
    snd: Unknown parameter `model'
    snd_timer: Unknown symbol snd_verbose_printd
    snd_timer: Unknown symbol snd_info_register
    snd_timer: Unknown symbol snd_info_create_module_entry
    snd_timer: Unknown symbol snd_info_free_entry
    snd_timer: Unknown symbol snd_verbose_printk
    snd_timer: Unknown symbol snd_iprintf
    snd_timer: Unknown symbol snd_ecards_limit
    snd_timer: Unknown symbol snd_oss_info_register
    snd_timer: Unknown symbol snd_unregister_device
    snd_timer: Unknown symbol snd_device_new
    snd_timer: Unknown symbol snd_register_device_for_dev
    snd_pcm: Unknown symbol snd_verbose_printd
    snd_pcm: Unknown symbol snd_info_register
    snd_pcm: Unknown symbol snd_info_create_module_entry
    snd_pcm: Unknown symbol snd_timer_notify
    snd_pcm: Unknown symbol snd_timer_interrupt
    snd_pcm: Unknown symbol snd_info_free_entry
    snd_pcm: Unknown symbol snd_add_device_sysfs_file
    snd_pcm: Unknown symbol snd_info_get_str
    snd_pcm: Unknown symbol snd_verbose_printk
    snd_pcm: Unknown symbol snd_ctl_register_ioctl
    snd_pcm: Unknown symbol snd_card_file_add
    snd_pcm: Unknown symbol snd_iprintf
    snd_pcm: Unknown symbol snd_major
    snd_pcm: Unknown symbol snd_unregister_device
    snd_pcm: Unknown symbol snd_timer_new
    snd_pcm: Unknown symbol snd_device_new
    snd_pcm: Unknown symbol snd_ctl_unregister_ioctl
    snd_pcm: Unknown symbol snd_lookup_minor_data
    snd_pcm: Unknown symbol snd_info_create_card_entry
    snd_pcm: Unknown symbol snd_power_wait
    snd_pcm: Unknown symbol snd_device_free
    snd_pcm: Unknown symbol snd_card_file_remove
    snd_pcm: Unknown symbol snd_register_device_for_dev
    snd_pcm: Unknown symbol snd_device_register
    snd_pcm: Unknown symbol snd_info_get_line
    snd_ac97_codec: Unknown symbol snd_info_register
    snd_ac97_codec: Unknown symbol snd_ctl_add
    snd_ac97_codec: Unknown symbol snd_info_free_entry
    snd_ac97_codec: Unknown symbol snd_interval_refine
    snd_ac97_codec: Unknown symbol snd_ctl_find_id
    snd_ac97_codec: Unknown symbol snd_verbose_printk
    snd_ac97_codec: Unknown symbol snd_ctl_new1
    snd_ac97_codec: Unknown symbol snd_ctl_remove_id
    snd_ac97_codec: Unknown symbol snd_component_add
    snd_ac97_codec: Unknown symbol snd_pcm_hw_rule_add
    snd_ac97_codec: Unknown symbol snd_iprintf
    snd_ac97_codec: Unknown symbol snd_ctl_boolean_mono_info
    snd_ac97_codec: Unknown symbol snd_device_new
    snd_ac97_codec: Unknown symbol snd_info_create_card_entry
    snd_ac97_codec: Unknown symbol snd_info_get_line
    snd_intel8x0: Unknown symbol snd_verbose_printd
    snd_intel8x0: Unknown symbol snd_ac97_pcm_close
    snd_intel8x0: Unknown symbol snd_ac97_resume
    snd_intel8x0: Unknown symbol snd_pcm_new
    snd_intel8x0: Unknown symbol snd_pcm_limit_hw_rates
    snd_intel8x0: Unknown symbol snd_card_register
    snd_intel8x0: Unknown symbol snd_card_free
    snd_intel8x0: Unknown symbol snd_pcm_lib_preallocate_pages_for_all
    snd_intel8x0: Unknown symbol snd_card_proc_new
    snd_intel8x0: Unknown symbol snd_ac97_pcm_open
    snd_intel8x0: Unknown symbol snd_ac97_set_rate
    snd_intel8x0: Unknown symbol snd_ac97_update_bits
    snd_intel8x0: Unknown symbol snd_ac97_mixer
    snd_intel8x0: Unknown symbol snd_ac97_bus
    snd_intel8x0: Unknown symbol snd_verbose_printk
    snd_intel8x0: Unknown symbol snd_ac97_pcm_double_rate_rules
    snd_intel8x0: Unknown symbol snd_ac97_update_power
    snd_intel8x0: Unknown symbol snd_card_new
    snd_intel8x0: Unknown symbol snd_ac97_suspend
    snd_intel8x0: Unknown symbol snd_iprintf
    snd_intel8x0: Unknown symbol snd_pcm_lib_malloc_pages
    snd_intel8x0: Unknown symbol snd_pcm_lib_ioctl
    snd_intel8x0: Unknown symbol snd_pcm_lib_free_pages
    snd_intel8x0: Unknown symbol snd_pcm_set_ops
    snd_intel8x0: Unknown symbol snd_pcm_hw_constraint_list
    snd_intel8x0: Unknown symbol snd_device_new
    snd_intel8x0: Unknown symbol snd_ac97_get_short_name
    snd_intel8x0: Unknown symbol snd_pcm_suspend_all
    snd_intel8x0: Unknown symbol snd_card_disconnect
    snd_intel8x0: Unknown symbol snd_ac97_pcm_assign
    snd_intel8x0: Unknown symbol snd_pcm_hw_constraint_integer
    snd_intel8x0: Unknown symbol snd_pci_quirk_lookup
    snd_intel8x0: Unknown symbol snd_pcm_hw_constraint_msbits
    snd_intel8x0: Unknown symbol snd_pcm_period_elapsed
    snd_intel8x0: Unknown symbol snd_ac97_tune_hardware
    ibm-linux:/etc/modprobe.d #

    I also had already used alsamixer to go through and set the external amp to OFF, i assume this is what you mean by disabled.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •