Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Subversion JavaHL bindings

  1. #1

    Default Subversion JavaHL bindings

    Hi, For Subclipse to work properly, I would like to have the JavaHL bindings from Subversion. These seem to be not available in the current repository build. Is there a way to get it, is there a separate repo for this?

  2. #2

    Default Re: Subversion JavaHL bindings

    I'm also trying to get Subversion working in Eclipse. It seems JavaHL is packaged with "subversion" in the openSUSE 11 repo, but after installing it, I still cannot get Subclipse to recognize the SVN client.

    Anyone have Eclipse working with Sunversion in openSUSE 11?

  3. #3

    Default Re: Subversion JavaHL bindings

    Still can't get this working. I also tried adding "-Djava.library.path=/usr/lib/:/usr/lib/svn-javahl" to the Eclipse JVM args, as is suggested on some other forums. I opened bug 423274 to track this.

  4. #4

    Default SOLVED: Subversion JavaHL bindings

    This was apparently fixed in Subclipse 1.4.4. It works fine now.

  5. #5
    cnoelker NNTP User

    Default Re: Subversion JavaHL bindings

    I searched for JavaHL in openSUSE 11.1 (64bit) and could not find it. It's not in the subversion package and a search for javahl did not yield anything. Is it just not there/available? I'd like to know if anybody can help!

    My workaround for Subclipse is now to use the SVNKit instead, even if it is not the recommended way.

  6. #6
    bosschebol NNTP User

    Default Re: Subversion JavaHL bindings

    I also cannot get Subversion working with Eclipse using JavaHl. I can get it working with SVNKit. Add subclipse: Subclipse Update Site as update site and install SVNKit. After restart select in preferences SVNKit instead of JavaHL.

  7. #7

    Wink Re: Subversion JavaHL bindings

    Hi,
    I was able to use JavaHL on openSUSE 11.1 (x86) using the code from this repository Index of /repositories/Subversion/Apache_openSUSE_11.1 .

    I hope this help!

    Massimo

  8. #8

    Default Re: Subversion JavaHL bindings

    Updating from the mmontecchi repo (subversion client) and the current Eclipse-3.4 packages from Opensuse_Factory and executing with this parameters, works for me:

    eclipse -vmargs -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner-1.9.1 -Djava.library.path=/usr/lib64/:/usr/lib64/svn-javahl/
    Note: I'm working in a 64-bit system

  9. #9

    Question Re: Subversion JavaHL bindings

    Does anybody know where the repository http://download.opensuse.org/reposit...openSUSE_11.1/ has been moved to?
    Or where I could download the JavaHL libraries?

    Many Thanks
    Martin

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,332
    Blog Entries
    15

    Default Re: Subversion JavaHL bindings

    Quote Originally Posted by martin45
    Does anybody know where the repository http://tinyurl.com/c4jxdk has
    c4jxdk ->
    http://download.opensuse.org/reposit...openSUSE_11.1/
    been moved to? Or where I could download the JavaHL libraries?

    Many Thanks
    Martin
    Hi
    Those files are all part of the subversion package for example for
    openSUSE 11.1 version 1.5.5;
    Code:
    libsvnjavahl-1.so
    libsvnjavahl-1.so.0
    libsvnjavahl-1.so.0.0.0
    svn-javahl.jar
    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.45-0.1-default
    up 6 days 7:24, 4 users, load average: 0.32, 0.54, 0.55
    GPU GeForce 8600 GTS Silent - CUDA Driver Version: 195.36.15


Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •