Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: Intel PRO/Wireless 3945ABG again

  1. #1

    Default Intel PRO/Wireless 3945ABG again

    Hello,

    I have this Intel Corporation PRO/Wireless 3945ABG on HP Compaq 6720s. It worked flawlessly on openSUSE 10.3. After upgrade to openSUSE 11, I have to either ifdown/ifup it or at least scan APs using iwlist after each boot. Without this annoying procedure, ifconfig shows everything is OK, but iwconfig shows that access point is invalid and wireless connection doesn't work. Currently, I'm using iwl3945 module, and as I remember the module ipw3945 was used in 10.3, but it is not available in the distribution anymore.

    Any suggestions how to fix this?

  2. #2
    ionu NNTP User

    Default Re: Intel PRO/Wireless 3945ABG again

    I have problems finding wireless ap too. It worked on the rc1, buggy, but worked. I reinstalled the opensuse 11 with the gold release and now I do not have any wireless in knetworkmanager. I am using the same card, on a lenovo r61i. The system settings shows the card has no problems.
    Help

  3. #3

    Default Re: Intel PRO/Wireless 3945ABG again

    you have the exact same card (and laptop as well!) as i do. it's a nice laptop. this is odd, since suse 11 for me is working flawlessly. perhaps you need to check your set up in yast? what encryption method are you using for the wireless network? you should be able to not have traditional method with ifup, but control with knetworkmanager, it works fine for me, so no reason why it shouldn't for you, with exactly the same hardware. except you may have more or less ram etc (im on 2gb) but this wouldn't effect wireless.

  4. #4

    Default Re: Intel PRO/Wireless 3945ABG again

    Quote Originally Posted by thestig View Post
    you have the exact same card (and laptop as well!) as i do. it's a nice laptop. this is odd, since suse 11 for me is working flawlessly. perhaps you need to check your set up in yast? what encryption method are you using for the wireless network? you should be able to not have traditional method with ifup, but control with knetworkmanager, it works fine for me, so no reason why it shouldn't for you, with exactly the same hardware. except you may have more or less ram etc (im on 2gb) but this wouldn't effect wireless.
    I didn't use knetworkmanager in several previous versions of openSUSE, since it didn't work once when I tried it. After your suggestion I switched to knetworkmanager, and as you told-it works quite fine! Thanks!

  5. #5

    Default Re: Intel PRO/Wireless 3945ABG again

    yup, i too had big problems with knetworkmanager on previous suse versions, in 10.3 i used wifi-radar and that worked flawlessly, but now, knetworkmanager works fine. anyway...glad you got it sorted.

  6. #6

    Default Re: Intel PRO/Wireless 3945ABG again

    Network Manager works much better than it used to, and is more flexible. I have no problems using it with the same card. I don't even need to use Profile Manager anymore when using various access points.

  7. #7
    Join Date
    Jul 2008
    Location
    Germany
    Posts
    17

    Default Re: Intel PRO/Wireless 3945ABG again

    Hi there...

    I'm new in here, and I've problems with that card, too, but on a Samsung Q45...
    Well I didn't want to start a new Thread on same issues so I post my problem here if that's ok...

    So here the issue:

    On 10.3 the networkcard worked out of the box using networkmanager...and now I installed 11.0 and it doesn't find any networks.
    Here are some outputs for tracking...

    /sbin/lspci -nn says:

    Code:
    ...
    2:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG Network Connection [8086:4222] (rev 02)
    ...
    hwinfo --wlan says:

    Code:
    08: PCI 200.0: 0282 WLAN controller
       [Created at pci.310]
       UDI: /org/freedesktop/Hal/devices/pci_8086_4222
       Unique ID: y9sn.EjEjpkprfHE
       Parent ID: z8Q3.yjCEx5JbDxB
       SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:02:00.0
       SysFS BusID: 0000:02:00.0
       Hardware Class: network
       Model: "Intel PRO/Wireless 3945BG Network Connection"
       Vendor: pci 0x8086 "Intel Corporation"
       Device: pci 0x4222 "Pro/Wireless 3945BG Network Connection"
       SubVendor: pci 0x8086 "Intel Corporation"
       SubDevice: pci 0x1034 "PRO/Wireless 3945BG Network Connection"
       Revision: 0x02
       Driver: "iwl3945"
       Driver Modules: "iwl3945"
       Device File: wlan0
       Features: WLAN
       Memory Range: 0xf0300000-0xf0300fff (rw, non-prefetchable)
       IRQ: 220 (no events)
       HW Adress: 00:1f:3c:1c:76:3b
       Link detected: no
       WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
       WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
       WLAN encryption modes: WEP40 WEP104 TKIP CCMP
       WLAN authentication modes: open sharedkey wpa-psk wpa-eap
       Module Alias: "pci:v00008086d00004222sv00008086sd00001034bc02sc80i00"
       Driver Info #0:
         Driver Status: iwl3945 is active
         Driver Activation Cmd: "modprobe iwl3945"
       Config Status: cfg=no, avail=yes, need=no, active=unknown
       Attached to: #18 (PCI bridge)
    and something strange I recently found was...

    dmesg says:

    Code:
    ...
    iwl3945: Microcode SW error detected. Restarting 0x82000008.
    iwl3945: Error Reply type 0x00000005 cmd REPLY_SCAN_CMD (0x80) seq 0x4418 ser 0x0000004B
    iwl3945: Can't stop Rx DMA.
    ...
    My homenetwork is WPA-PSK encrypted is that is of relevance...

    I really hope to get some help here, since I tried nearly everything I read in other forums...nothing worked yet..

  8. #8

    Default Re: Intel PRO/Wireless 3945ABG again

    Have you tried entering the SSID of the access point manually in Network Manager?

  9. #9
    Join Date
    Jul 2008
    Location
    Germany
    Posts
    17

    Default Re: Intel PRO/Wireless 3945ABG again

    Yes I tried that all day long...

    what happens is...

    I go like
    -"New connection" --> "wlan0"
    -enter my SSID
    -Select WPA-PSK-->enter my passphrase
    -don't touch the rest of the settings
    -it automatically tries to connect but fails
    -the specified network appears in the dialog "connect to other network" but hat signal=0 and fails on connecting

    -a thing I recognized is, that when I enter the
    connections preferences again, the key looks very different to the one I entered...don't know if that's got something to say...

  10. #10

    Default Re: Intel PRO/Wireless 3945ABG again

    Occasionally, I have to keep trying to reconnect in order to get the connection to come up. Most of the time it just connects when I login, but as I said, sometimes I have to make it reconnect many times before it works. And I also get the WPA-PSK change, but that is fine. It eventually does work.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •