Results 1 to 2 of 2

Thread: texlive-xetex bug

  1. #1
    Join Date
    Jun 2008
    Location
    Bosnia
    Posts
    10

    Default texlive-xetex bug

    I recently discovered a bug in texlive-xetex package that is shipped with default openSUSE 11 installation (DVD), texlive-xetex version 2007-177.1. This is present in Ubuntu Hardy's repo too, but corrected in unstable Debian Sid repo. This is the thing:

    When you use accents like "\=" or "\^" (without quotes) in a word in which later comes "-" (without qoutes too), characters after the accent and before the "-" are repeated twice. For example, if you enter:
    Code:
    "Uj\=unul-eser"
    you'll get:

    Code:
    "Uj^unul-nul-eser"
    Can anyone confirm it? And where to report it?

    Here's a simple example:

    Code:
    \documentclass[a4paper,10pt]{scrbook}
    \usepackage[cm-default]{fontspec}
    \usepackage{xunicode}
    \usepackage{xltxtra}
    \defaultfontfeatures{Scale=MatchLowercase,Mapping=tex-text}
    \setmainfont{URW Palladio L}
    
    \begin{document}
    Uj\=unul-eser
    \end{document}

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,443

    Default Re: texlive-xetex bug

    Not a LaTeX expert but when using an accent in BibTeX you would enclose it in braces to prevent it affecting any higher level code.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •