Results 1 to 5 of 5

Thread: Display standby: where do I disable it?

  1. #1
    Join Date
    Jun 2008
    Posts
    15

    Default Display standby: where do I disable it?

    I have disabled all energy saving settings for my display in system settings (see screenshot) but my screen still keeps blanking after a few minutes. Where can I disable this additional setting? I cannot seem to find anything, energy saving settings are also all disabled in BIOS-setup, it's not a BIOS issue either. Talking about openSUSE 11 with KDE 4.0.4 here.


  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Display standby: where do I disable it?

    * mj42

    this is nagging me since 10.x, the only way I found is to start sax2 and disable DPMS for the display.

    Uwe

  3. #3
    Join Date
    Jun 2008
    Posts
    15

    Default Re: Display standby: where do I disable it?

    Thank you! That did indeed solve the problem. I can even use the energy saving settings now because they actually do work once DPMS is disabled

  4. #4
    Join Date
    Jun 2008
    Location
    Oklahoma, US
    Posts
    822

    Default Re: Display standby: where do I disable it?

    mj42 wrote:

    >
    > Thank you! That did indeed solve the problem, and now I can even use the
    > energy saving settings because they actually do work now
    >
    >


    Xwindows defaults to blanking the screen after 600 seconds (10 minutes)

    Can be changed with the xset command:

    # set no blanking ever
    xset s off
    # set blanking after 3 minutes
    xset s 180

    xset also handles DPMS settings

    # turn dpms off entirely
    xset -dpms
    # enable dpms with Xserver defaults
    xset +dpms
    # set dpms for standby after 30 minutes, suspend after 45 minutes and off
    after 60 minutes
    xset dpms 1800 2700 3600
    # remember, ALL times are from 'zero', and must be ascending if specified.
    # standby <= suspend <= off

    the xset man page has more information, and there are many more options to
    tweak. ('xset q' is very useful)




    --
    L R Nix
    lornix@lornix.com

  5. #5

    Default Re: Display standby: where do I disable it?

    In case you have a text mode installation you can add the following to /etc/init.d/boot.local:
    Code:
    setterm -blank 0
    setterm -powersave off
    setterm -powerdown 0
    More info in the man pages for setterm.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •