Results 1 to 4 of 4

Thread: Wrong screen resolution Intel GM965 with OpenSUSE 11

  1. #1
    Join Date
    Jun 2008
    Location
    Cambridgeshire, UK
    Posts
    51

    Default Wrong screen resolution Intel GM965 with OpenSUSE 11

    My laptop (Fujitsu Siemens S7210) had the correct scren resolution (1280x800 @ 60Hz) under OpenSUSE 10.3 but having now installed the latest version the resolution set by Yast is 1152x768 @ 54.8Hz. I can't work out how to force it to the correct resolution - anyone have any ideas? Ubuntu 8.04 uses the correct resolution.

    The entry in xorg.conf has

    Section "Monitor"
    DisplaySize 304 190
    HorizSync 30-52
    Identifier "Monitor[0]"
    ModelName "1280X800@60HZ"
    Option "DPMS"
    Option "PreferredMode" "1280x800"
    VendorName "--> LCD"
    VertRefresh 50-60
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "965 GM"
    BusID "0:2:0"
    Driver "intel"
    Identifier "Device[0]"
    Option "monitor-LVDS" "Monitor[0]"
    Screen 0
    VendorName "Intel"
    EndSection

    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    InputDevice "Mouse[3]" "SendCoreEvents"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection

    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    Option "Composite" "on"
    EndSection

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: Wrong screen resolution Intel GM965 with OpenSUSE 11

    Try SaX2 and see if that will resolve the problem. I also think you will find there is another thread about this problem but I'm not sure where.

  3. #3
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    638

    Default Re: Wrong screen resolution Intel GM965 with OpenSUSE 11

    You could try setting it in yast, I suppose your intel driver
    uses randr 1.2. Do as follows in yast:

    system>/etc/sysconf editor
    set desktop>display manager>displaymanager_randr_mode_auto to
    1280x800_60

  4. #4
    Join Date
    Jun 2008
    Location
    Cambridgeshire, UK
    Posts
    51

    Smile Re: Wrong screen resolution Intel GM965 with OpenSUSE 11

    Quote Originally Posted by john_hudson View Post
    Try SaX2 and see if that will resolve the problem. I also think you will find there is another thread about this problem but I'm not sure where.
    Installed all the latest updates then 'SaX2 -r' did the trick - thanks for pointing me in the right direction.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •